Template does not load properly!!!

Discuss the development and implementation of Joomla! 1.0.x templates here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Locked
alexrjhb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Mar 11, 2008 9:00 pm

Template does not load properly!!!

Post by alexrjhb » Tue Mar 11, 2008 9:06 pm

Hello guys,

I am new to the forum and almost new to Joomla and CSS.

I am trying to create an online store with Joomla and VirtueMart.

I downloaded a template called eStore Plazza from TemplatePlazza.com and am having
a problem where the CSS or whatever does not open up properly on my front page.
Instead of the beautiful template I only get text with no images.

I installed the same template on another domain and it works just fine. Tried deleting and re-installing - same thing.

Have I done something wrong or has one of my files gone corrupt somewhere?

Here is the link to my homepage: http://www.eemporium.co.za

PLEASE,PLEASE help!!! :'(
Last edited by alexrjhb on Thu Mar 13, 2008 7:30 pm, edited 1 time in total.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22278
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Template does not load properly!!!

Post by pe7er » Tue Mar 11, 2008 9:53 pm

The HTML source shows all links to stylesheets & images as "templates/..." instead of "http://www.example.com/templates/...".

The $mosConfig_live_site is not used properly in your template.
You'll need to put just before all current links ( so like: <?php echo $mosConfig_live_site;?> /templates/... )
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

alexrjhb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Mar 11, 2008 9:00 pm

Re: Template does not load properly!!!

Post by alexrjhb » Wed Mar 12, 2008 5:07 am

pe7er wrote:The HTML source shows all links to stylesheets & images as "templates/..." instead of "http://www.example.com/templates/...".

The $mosConfig_live_site is not used properly in your template.
You'll need to put just before all current links ( so like: <?php echo $mosConfig_live_site;?> /templates/... )
Hi

Thanks for the reply...

I am not sure I understand... Must I change the html of the template?
Where do I find $mosConfig_live_site? Ih the configuration.php or elsewhere? Are you telling me to change wherever it says $mosConfig_live_site to <?php echo $mosConfig_live_site;?> /templates/?

I would really appreciate if you could give me a bit more help on this one, I need to have this site up and running efore end of today...

Cheers... :pop

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22278
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Template does not load properly!!!

Post by pe7er » Wed Mar 12, 2008 9:03 am

alexrjhb wrote:
pe7er wrote:I am not sure I understand... Must I change the html of the template?
Where do I find $mosConfig_live_site? Ih the configuration.php or elsewhere? Are you telling me to change wherever it says $mosConfig_live_site to <?php echo $mosConfig_live_site;?> /templates/?
Sorry, you only have to change:
http://www.example.com/templates/estore ... /index.php

Look for the references to templates/... and change those to
<?php echo $mosConfig_live_site;?>/templates/...

The references to the template_css.css and the images are all relative (without the domain name),
and you will have to make those absolute.

$mosConfig_live_site is a variable (defined in your configuration.php) which contains the URL of your website.
If you "echo" that variable in your template's index.php, in front of all references to CSS & images,
then the template should be able to show the images & settings in the CSS files.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

alexrjhb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Mar 11, 2008 9:00 pm

Re: Template does not load properly!!!

Post by alexrjhb » Wed Mar 12, 2008 2:28 pm

Sorry about that....

I know I look stupid now, but as I said I am new to this and I wouldnt like to damage my code again as I did last week and I had to reload everything from scratch.

Here is my index.php, can you highlite where I must insert the code you sent me, pleaseeeeeeeeeeee......

I would really appreciate it.

Thanks and Regards,
Alex
<?php
defined( '_VALID_MOS' ) or die( 'Restricted access' );
// needed to seperate the ISO number from the language file constant _ISO
$iso = explode( '=', _ISO );
// xml prolog
echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><head>

<?php
require($mosConfig_absolute_path."/templates/" . $mainframe->getTemplate() . "/template_config.php");
require($mosConfig_absolute_path."/templates/" . $mainframe->getTemplate() . "/tptabslider.php");
?>
<?php mosShowHead(); ?>

<?php
if ( $my->id ) { initEditor(); }

// general width calculation
if ( mosCountModules('left')) {
$bodywrapper = $templatewidth - 264;
$espathway = $templatewidth - 264;
$bodyroundleft = $templatewidth - 264;
}
if ( mosCountModules('right')) {
$bodywrapper = $templatewidth - 56;
$espathway = $templatewidth - 56;
$bodyroundleft = $templatewidth - 256;
}
if (mosCountModules('left') && mosCountModules('right')) {
$bodywrapper = $templatewidth - 264;
$espathway = $templatewidth - 264;
$bodyroundleft = $templatewidth - 464;
}

if (mosCountModules('left') + mosCountModules('right') ==0) {
$bodywrapper = $templatewidth-56;
$espathway = $templatewidth - 56;
$bodyroundleft = $templatewidth - 56;
}
// tab slider width calculation


if ( mosCountModules('user21') >= 1 ) $u21 = 1;
else $u21 = 0;
if ( mosCountModules('user22') >= 1 ) $u22 = 1;
else $u22 = 0;
if ( mosCountModules('user23') >= 1 ) $u23 = 1;
else $u23 = 0;
if ( mosCountModules('user24') >= 1 ) $u24 = 1;
else $u24 = 0;
if ( mosCountModules('user25') >= 1 ) $u25 = 1;
else $u25 = 0;
if ( mosCountModules('user26') >= 1 ) $u26 = 1;
else $u26 = 0;
if ( mosCountModules('user27') >= 1 ) $u27 = 1;
else $u27 = 0;
if ( mosCountModules('user28') >= 1 ) $u28 = 1;
else $u28 = 0;
if ( mosCountModules('user29') >= 1 ) $u29 = 1;
else $u29 = 0;
if ( mosCountModules('user30') >= 1 ) $u30 = 1;
else $u30 = 0;
if ( mosCountModules('user31') >= 1 ) $u31 = 1;
else $u31 = 0;
if ( mosCountModules('user32') >= 1 ) $u32 = 1;
else $u32 = 0;
if ( mosCountModules('user33') >= 1 ) $u33 = 1;
else $u33 = 0;
if ( mosCountModules('user34') >= 1 ) $u34 = 1;
else $u34 = 0;
if ( mosCountModules('user35') >= 1 ) $u35 = 1;
else $u35 = 0;

if ($u21 + $u22 + $u23 == 3 ) { $tab1 = "32%"; }
if ($u21 + $u22 + $u23 == 2 ) { $tab1 = "49%"; }
if ($u21 + $u22 + $u23 == 1 ) { $tab1 = "100%"; }

if ($u24 + $u25 + $u26 == 3 ) { $tab2 = "32%"; }
if ($u24 + $u25 + $u26 == 2 ) { $tab2 = "49%"; }
if ($u24 + $u25 + $u26 == 1 ) { $tab2 = "100%"; }

if ($u27 + $u28 + $u29 == 3 ) { $tab3 = "32%"; }
if ($u27 + $u28 + $u29 == 2 ) { $tab3 = "49%"; }
if ($u27 + $u28 + $u29 == 1 ) { $tab3 = "100%"; }

if ($u30 + $u31 + $u32 == 3 ) { $tab4 = "32%"; }
if ($u30 + $u31 + $u32 == 2 ) { $tab4 = "49%"; }
if ($u30 + $u31 + $u32 == 1 ) { $tab4 = "100%"; }

if ($u33 + $u34 + $u35 == 3 ) { $tab5 = "32%"; }
if ($u33 + $u34 + $u35 == 2 ) { $tab5 = "49%"; }
if ($u33 + $u34 + $u35 == 1 ) { $tab5 = "100%"; }






//threemod width calculation
$threemodbotwith = $espathway - 20;

if ( mosCountModules('user10') >= 1 ) $threemod_1 = 1;
else $threemod_1 = 0;
if ( mosCountModules('user11') >= 1 ) $threemod_2 = 1;
else $threemod_2 = 0;
if ( mosCountModules('user12') >= 1 ) $threemod_3 = 1;
else $threemod_3 = 0;

if ($threemod_1 + $threemod_2 + $threemod_3 == 3 ) { $threemodbotwith_width = $threemodbotwith/3-16; }
if ($threemod_1 + $threemod_2 + $threemod_3 == 2 ) { $threemodbotwith_width = $threemodbotwith/2-16; }
if ($threemod_1 + $threemod_2 + $threemod_3 == 1 ) { $threemodbotwith_width = $threemodbotwith; }


//twomod width calculation
$twomodbotwith = $bodyroundleft - 20;

if ( mosCountModules('user13') >= 1 ) $twomod_1 = 1;
else $twomod_1 = 0;
if ( mosCountModules('user14') >= 1 ) $twomod_2 = 1;
else $twomod_2 = 0;

if ($twomod_1 + $twomod_2 == 2 ) { $twomodbotwith_width = $twomodbotwith/2-16; }
if ($twomod_1 + $twomod_2 == 1 ) { $twomodbotwith_width = $twomodbotwith; }

//twomod_b width calculation
$twomodbotwith_b = $bodyroundleft - 20;

if ( mosCountModules('user15') >= 1 ) $twomodb_1 = 1;
else $twomodb_1 = 0;
if ( mosCountModules('user16') >= 1 ) $twomodb_2 = 1;
else $twomodb_2 = 0;

if ($twomodb_1 + $twomodb_2 == 2 ) { $twomodbotwith_b_width = $twomodbotwith_b/2-16; }
if ($twomodb_1 + $twomodb_2 == 1 ) { $twomodbotwith_b_width = $twomodbotwith_b; }

// 4 bottom mod width calculation
$fourmodbotwith = $templatewidth - 76 ;

if ( mosCountModules('user17') >= 1 ) $botmod_1 = 1;
else $botmod_1 = 0;
if ( mosCountModules('user18') >= 1 ) $botmod_2 = 1;
else $botmod_2 = 0;
if ( mosCountModules('user19') >= 1 ) $botmod_3 = 1;
else $botmod_3 = 0;
if ( mosCountModules('user20') >= 1 ) $botmod_4 = 1;
else $botmod_4 = 0;

if ($botmod_1 + $botmod_2 + $botmod_3 + $botmod_4 == 4 ) { $botmodwidth = $fourmodbotwith/4-20; }
if ($botmod_1 + $botmod_2 + $botmod_3 + $botmod_4 == 3 ) { $botmodwidth = $fourmodbotwith/3-20; }
if ($botmod_1 + $botmod_2 + $botmod_3 + $botmod_4 == 2 ) { $botmodwidth = $fourmodbotwith/2-20; }
if ($botmod_1 + $botmod_2 + $botmod_3 + $botmod_4 == 1 ) { $botmodwidth = $fourmodbotwith; }


?>
<link rel="stylesheet" href="templates/estore_plazza/css/template_css.css" type="text/css" />
<link rel="stylesheet" href="templates/estore_plazza/css/sfish.css" type="text/css" />

<style type="text/css">
.tab1 {
width:<?php echo $tab1; ?>;
float:left;
margin-right:5px;

}
.tab2 {
width:<?php echo $tab2; ?>;
float:left;
margin-right:5px;

}
.tab3 {
width:<?php echo $tab3; ?>;
float:left;
margin-right:5px;

}
.tab4 {
width:<?php echo $tab4; ?>;
float:left;
margin-right:5px;

}
.tab5 {
width:<?php echo $tab5; ?>;
float:left;
margin-right:5px;

}
</style>

<!--<script type="text/javascript" src="templates/estore_plazza/js/cb.js"></script>-->

<script src="templates/estore_plazza/js/jquery-1.2.1.pack.js" type="text/javascript"></script>
<script src="templates/estore_plazza/js/jquery-easing.1.2.pack.js" type="text/javascript"></script>
<script src="templates/estore_plazza/js/jquery-easing-compatibility.1.2.pack.js" type="text/javascript"></script>
<script src="templates/estore_plazza/js/coda-slider.1.1.pack.js" type="text/javascript"></script>
<link rel="stylesheet" href="templates/estore_plazza/css/tabstyles.css" type="text/css" />

<script type="text/javascript">
jQuery.noConflict();
jQuery(window).bind("load", function() {
jQuery("div#slider1").codaSlider()
// jQuery("div#slider2").codaSlider()
// etc, etc. Beware of cross-linking difficulties if using multiple sliders on one page.
});
</script>



<!--[if lte IE 6]>
<link rel="stylesheet" href="templates/estore_plazza/css/ie6.css" type="text/css" />
<style type="text/css">
#topwrap_inner img {
behavior: url(templates/estore_plazza/js/iepngfix.htc);
}

</style>

<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" href="templates/estore_plazza/css/ie7.css" type="text/css" />
<![endif]-->

</head>
<body class="bodies">
<?php mosLoadModules ( 'bottom' ); ?>


<div id="wrapper" align="center">
<div id="pagewrapper" style="width:<?php echo $templatewidth; ?>px; " align="center">
<div id="contentwrapper" align="center" style="width:<?php echo $templatewidth; ?>px;">
<div id="topwrap">


...cannot add complete code - not allowed...

alexrjhb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Mar 11, 2008 9:00 pm

Re: Template does not load properly!!!

Post by alexrjhb » Thu Mar 13, 2008 7:29 pm

Got my host to sort it out....now working fine...

FireDog
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 13, 2007 12:53 pm
Location: Brazil
Contact:

Re: Template does not load properly!!!

Post by FireDog » Mon Jun 23, 2008 4:25 pm

Hey alexrjhb

im having the same problem with this template. i cant fix it to works fine, and i dont know css and php very well...

could you tell me how did you fix it?

thx a lot

tormenized
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Apr 19, 2010 3:21 am

Re: Template does not load properly!!!

Post by tormenized » Mon Apr 19, 2010 4:15 am

im having slighty the same thing with e-store plazza.

the frontpage doesnt show the Hot Item tab and user22.

but it came out if i opened other pages in the templates.

anyone???

ethan83
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jun 13, 2011 10:19 am

Re: Template does not load properly!!!

Post by ethan83 » Tue Jun 14, 2011 7:44 am

Ask me no questions, and I'll tell you no lies. Wordpress themes http://www.brillthemes.com


Locked

Return to “Templates & CSS - 1.0.x”