404 - Component not found

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

404 - Component not found

Post by Saamon » Wed Sep 03, 2008 12:50 pm

I get the following error when clicking some of my links, ever since I enabled "Search Engine Friendly URL's" :

404 - Component not found

You may not be able to visit this page because of:

1. an out-of-date bookmark/favourite
2. a search engine that has an out-of-date listing for this site
3. a mistyped address
4. you have no access to this page
5. The requested resource was not found.
6. An error has occurred while processing your request.

Please try one of the following pages:

* Home Page

If difficulties persist, please contact the System Administrator of this site.

Component not found



HELP!

Oh and PS: I want search engine friendly URL's. So dont tell me to just turn it off.

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Wed Sep 03, 2008 1:09 pm

Did you enable the mod_rewrite option as well?
Did you rename the htaccess.txt file to .htaccess (please note the dot in front of the filename!)

Olaf
Olaf Offick - Global Moderator
learnskills.org

Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

Re: 404 - Component not found

Post by Saamon » Wed Sep 03, 2008 2:22 pm

I've just done that now.

Now it just comes up with an Internal Server Error...

:(

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Wed Sep 03, 2008 2:35 pm

Well, then your .htaccess file seems to have something in there which is not supported by your Server. Can you change it so it only contains the following code:

Code: Select all

RewriteEngine on
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
Olaf
Olaf Offick - Global Moderator
learnskills.org

Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

Re: 404 - Component not found

Post by Saamon » Wed Sep 03, 2008 2:40 pm

Hasnt helped sorry to say :(

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Wed Sep 03, 2008 2:50 pm

Which means that your Provider/server doesn't allow mod_rewirtes. You might want to ask your provider to enable mod_rewirte for you or you might want to try to install an extension like sh404sef which might work without mod_rewrite.

Olaf
Olaf Offick - Global Moderator
learnskills.org

Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

Re: 404 - Component not found

Post by Saamon » Wed Sep 03, 2008 5:01 pm

Thanks for the help.

What confuses me is that fact that only 2 of the links arent working..

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Wed Sep 03, 2008 7:45 pm

Could you tell us a little bit more about your system by using the Forum Post Assistant?

Do you have any SEF extension like sh404sef? or any other SEF extension which might have a URL Cache as well?

Olaf
Olaf Offick - Global Moderator
learnskills.org

Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

Re: 404 - Component not found

Post by Saamon » Wed Sep 03, 2008 7:53 pm

I have found the problem, I just dont know how to fix it.

Basically the menu item that is not working, is in a sub menu. And when it simplifies the link, it puts it as /news/link.html, When it should just be link.html... This is because News is the parent menu item...

This is definitly the issue, as I have moved the menu item to a normal menu item instead, and it worked fine.

info-mediation
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jun 03, 2008 2:15 pm

Re: 404 - Component not found

Post by info-mediation » Thu Sep 04, 2008 2:41 am

I'm having the same problem. Parent menu items work but sub-menus do not with mod rewrite on and joomla's htaccess in place.

Here's the diagnostic




Diagnostic Information
Joomla! Version: Joomla! 1.5.6 Production/Stable [ Vusani ] 12-August-2008 22:00 GMT
configuration.php: Not Writable (Mode: 444 ) | RG_EMULATION: N/A
Architecture/Platform: FreeBSD 6.1-RELEASE-p12 ( i386) | Web Server: Apache/1.3.37 (Unix) mod_psoft_traffic/0.1 Vortech_PHP/0.1.0-p0 mod_throttle/3.1.2 mod_ssl/2.8.28 OpenSSL/0.9.7e-p1 ( d20551054.i134.info-me.net ) | PHP Version: 5.2.2
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 4.1.22 ( mysql10.info-me.net via TCP/IP )

Saamon
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Wed Jun 11, 2008 8:56 am

Re: 404 - Component not found

Post by Saamon » Thu Sep 04, 2008 2:28 pm

I've found a solution. Works perfectly now.

For anyone else having the problem this is what I did:

I copied the menu item that doesnt work, to a hidden menu. Then put the submenu item that doesnt work as a link to the items on the hidden menu. Works fine :)

User avatar
jasonhoblin
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Fri Jan 25, 2008 2:09 am
Location: SoCal
Contact:

Re: 404 - Component not found

Post by jasonhoblin » Thu Nov 06, 2008 2:29 am

info-mediation wrote:I'm having the same problem. Parent menu items work but sub-menus do not with mod rewrite on and joomla's htaccess in place.
i have this same problem on several of my joomla sites. sumenus appear ok without any SEF. when i enable joomla SEF(and apache mod_rewrite), the urls are ok, but submenus do not appear. please advise.
^jasonhoblin

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Thu Nov 06, 2008 9:25 am

i have this same problem on several of my joomla sites. sumenus appear ok without any SEF. when i enable joomla SEF(and apache mod_rewrite), the urls are ok, but submenus do not appear. please advise.
Can you tell us a little bit more about your system? Which Joomla version do you have? Do you use any thrid party SEF Extension? etc...

Olaf
Olaf Offick - Global Moderator
learnskills.org

User avatar
jasonhoblin
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Fri Jan 25, 2008 2:09 am
Location: SoCal
Contact:

Re: 404 - Component not found

Post by jasonhoblin » Thu Nov 06, 2008 10:01 pm

use menu aliases
^jasonhoblin

lwheinrichs
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Oct 30, 2008 10:51 pm

Re: 404 - Component not found

Post by lwheinrichs » Sun Nov 16, 2008 1:30 am

I am having the same issue...

When I set SEF on, I receive "404 - component not found" errors on menu items. I have tried adding the html suffix by turning on that third button, but it doesn't seem to make a difference.

I am using Joomla 1.5.1, Apache server, PHP v 5.2.5, db v 5.0.67-109.

The website is at http://www.win-healthinstitute.com/CMS

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Sun Nov 16, 2008 10:48 am

lwheinrichs wrote:I am using Joomla 1.5.1, Apache server, PHP v 5.2.5, db v 5.0.67-109.
Please update to Joomla 1.5.8 as your Joomla version is very old and the new version patches a lot of security problems.

Regarding your error:

Please rename the file htaccess.txt to .htaccess (please note the dot in front of the file)
And search in that file for the following line:

Code: Select all

# RewriteBase /
and replace it with the following:

Code: Select all

RewriteBase /CMS
Olaf
Olaf Offick - Global Moderator
learnskills.org

lwheinrichs
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Oct 30, 2008 10:51 pm

Re: 404 - Component not found

Post by lwheinrichs » Mon Nov 17, 2008 2:38 pm

Thanks. I made the indicated changes and found that if the SEF indicator is ON, I still receive the same 404-component not found error. With all three SEF indicators set to ON, I receive a system 404 error. Should .htaccess be in the root directory, instead of the root of Joomla?

As you have doubtless noticed, I am new to Joomla. A third party hosting company loaded 1.5.7 and so I am not quite sure how to upgrade to 1.5.8. Is that a "Joomla Install", or does it need to be loaded from the server console?

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: 404 - Component not found

Post by ooffick » Mon Nov 17, 2008 2:53 pm

lwheinrichs wrote:Thanks. I made the indicated changes and found that if the SEF indicator is ON, I still receive the same 404-component not found error. With all three SEF indicators set to ON, I receive a system 404 error. Should .htaccess be in the root directory, instead of the root of Joomla?
Can you try the leave the secend SEO Option (Mod_rewrite) off.
lwheinrichs wrote: As you have doubtless noticed, I am new to Joomla. A third party hosting company loaded 1.5.7 and so I am not quite sure how to upgrade to 1.5.8. Is that a "Joomla Install", or does it need to be loaded from the server console?
Are you using 1.5.1 or 1.5.7? You can find a step by step tutorial here:
http://docs.joomla.org/Upgrading_1.5_fr ... 5x_version

Olaf
Olaf Offick - Global Moderator
learnskills.org

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22330
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: 404 - Component not found

Post by pe7er » Mon Mar 29, 2010 3:42 pm

I have the same problem with a client's website:
With SEF fully ON (all three options) + .htaccess I get nice URLs.
The parent menu items can be viewed, but submenu's result in 404 errors.

It could be the PHP version (same version as info-mediation used above) or maybe mod_rewrite has not been installed.
I will look some more, and contact the hosting provider...
JTS-post Diagnostic Information wrote:Joomla! Version: Joomla! 1.5.15 Stable [ Wojmamni Ama Mamni ] 05-November-2009 04:00 GMT
configuration.php: Not Writable (Mode: 444 ) | Architecture/Platform: Linux 2.6.18-ovz028stab035.1-smp ( i686) | Web Server: Apache/1.3.37 (Unix) PHP/5.2.2 mod_ssl/2.8.28 OpenSSL/0.9.8a mod_perl/1.29 FrontPage/5.0.2.2510 | PHP Version: 5.2.2
PHP Requirements: register_globals: Enabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5 or above): Yes | iconv Support (1.5 or above): Yes | save.session_path: Not Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 4.1.12-standard ( Localhost via UNIX socket )
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22330
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: 404 - Component not found

Post by pe7er » Mon Mar 29, 2010 7:47 pm

I've added the website's URL in global configuration:

Code: Select all

var $live_site = 'http://www.yoursite.com';
and now full SEF + .htaccess works ok for submenus too...
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content


Locked

Return to “Extensions for Joomla! 1.5”