Advertisement

Login Problem / Migrate Topic is solved

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 6:16 am

I have to update an old website. It is still running but I can not log in to the backend, I always get the Error message in the backend login form as well as in the error log:

"Joomla FAILURE: Username and password do not match or you do not have an account yet."

I searched google for solution. I opened DB in phpMyAdmin and opened users database. I manually tried to provide valid user with username and password and tried to log in again but it still fails.

Can anyone provide help? What can I do to log in and update / migrate to current Joomla version? The (current and lowest) php Version of my provider is 5.3.

I attached a screenshot from the users table from phpMyAdmin. The table prefix is "globe".
You do not have the required permissions to view the files attached to this post.

Advertisement
User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 25083
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Login Problem / Migrate

Post by pe7er » Fri Jun 07, 2024 6:35 am

Welcome to Joomla forum!

Is your Authentication Plugin enabled?
Is your "User - Joomla" plugin enabled?
Check in the database the #__extensions table.
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 8:11 am

pe7er wrote: Fri Jun 07, 2024 6:35 am Welcome to Joomla forum!

Is your Authentication Plugin enabled?
Is your "User - Joomla" plugin enabled?
Check in the database the #__extensions table.
Hi, and thanks :-)

From my understanding, it says "enabled" = "1", means, "Users" and "authentication" plugin is enabled, as far as I understand. Screenshot attached.
You do not have the required permissions to view the files attached to this post.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 25083
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Login Problem / Migrate

Post by pe7er » Fri Jun 07, 2024 9:17 am

Ok, that's good because you need those two.

When you created the password for the new "admin2" Super Admin account, did you add the MD5 hash?
Or did you add a plain password and save it with option "MD5" so it became a hashed string?

Could you give more info about your server/site?
Please use Forum Post Assistant: https://forumpostassistant.github.io/docs/
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 10:33 am

I just edited the field in the mentioned db users table without worrying about MD5 / Strings whatsoever. I entered new values with phpMyadmin.

I then uploaded fpa to the site as you mentioned. When I open that very file in browser the screen is empty. When I open that files source code, same. I changed "Berechtigungen" (what s that in english) to "777" I think you know what I mean. I opened it again in Browser, same result. See attached screenshot.

I seemingly found out the Joomla Version if I am correct in a joomla.xml file. It says it is Joomla 2.5.19
You do not have the required permissions to view the files attached to this post.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 25083
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Login Problem / Migrate

Post by pe7er » Fri Jun 07, 2024 11:07 am

justahacker wrote: Fri Jun 07, 2024 10:33 am I just edited the field in the mentioned db users table without worrying about MD5 / Strings whatsoever. I entered new values with phpMyadmin.
The password needs to be md5 hashed, otherwise you cannot log in.
I then uploaded fpa to the site as you mentioned. When I open that very file in browser the screen is empty. When I open that files source code, same. I changed "Berechtigungen" (what s that in english) to "777" I think you know what I mean. I opened it again in Browser, same result. See attached screenshot.

I seemingly found out the Joomla Version if I am correct in a joomla.xml file. It says it is Joomla 2.5.19
Berechtigungen = Permissions.
PHP 5.3 is very old, Maybe the Forum Post Assistant script needs a higher PHP version?
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 11:41 am

pe7er wrote: Fri Jun 07, 2024 11:07 am
justahacker wrote: Fri Jun 07, 2024 10:33 am I just edited the field in the mentioned db users table without worrying about MD5 / Strings whatsoever. I entered new values with phpMyadmin.
The password needs to be md5 hashed, otherwise you cannot log in.
I then uploaded fpa to the site as you mentioned. When I open that very file in browser the screen is empty. When I open that files source code, same. I changed "Berechtigungen" (what s that in english) to "777" I think you know what I mean. I opened it again in Browser, same result. See attached screenshot.

I seemingly found out the Joomla Version if I am correct in a joomla.xml file. It says it is Joomla 2.5.19
Berechtigungen = Permissions.
PHP 5.3 is very old, Maybe the Forum Post Assistant script needs a higher PHP version?
I can log in now. I will try to update my site to newer Joomla Version now. I entered new password with MD5 via phpmyadmin / by sql similar how it is describes here:

https://stackoverflow.com/questions/253 ... dmin-4-1-6

Thank you!

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 5:18 pm

I now created copy / test environment of the Site.
Also Update from 2.5.19 to Joomla! 2.5.28 Stable. Worked fine so far.

Now I worked through recipie how to update / migrate from 2.5.28 to 3.X.

Did all steps and also uninstalled all third party extensions except the one that were not possible to uninstall due to multiple reasons which are: PHPMailer, SimplePie, Akeebabackup, CodeMirror, TinyMCE and J51_Oxygen Template.

But still it shows "No updates available - You already have the latest Joomla! version, 2.5.28.", where es the Migration DOC says it should now provide possibilty to update to Joomla 3.x from within.

Did I make a mistake? Is there still a possibility to "migrate / update" correctly? By the way, new try in executing the fpa-en.php still delivers empty screen / empty source code.

Or should I otherwise rather install a fresh new Joomla 3.9 as some recommend and use a tool like J2XML 3.9 to import articles / menu / content to the new J3.9 site? And set up new the rest later?

What do you recommend. Thanks again in advance!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44251
Joined: Sat Apr 05, 2008 9:58 pm

Re: Login Problem / Migrate

Post by Webdongle » Fri Jun 07, 2024 8:06 pm

If you can't login to admin then you can;t use j2xml to port
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Fri Jun 07, 2024 8:10 pm

As I mentioned in my post above here today at Fr Jun 07, 2024 1:41 pm, thanks to the help of peter and stackoverflow.xyz I could fix that issue.

Now I am trying to work out how to update best from J!2.5.28 to J!.current, with the issues mentiones above.

justahacker
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jun 07, 2024 6:04 am

Re: Login Problem / Migrate

Post by justahacker » Mon Jun 10, 2024 8:41 am

Just to let you know. I could not figure out how to update from 2.5.x ot J! 4 or 5. Everything I tried didn't work out.

I now did the following:

1. Use MD4 hash SQL command to enter new password in phpMyAdmin, then login possible again.
2. Install J2xml 3.3 (!) to export all content from the obsolete Joomla 2.5 site to xml
3. Install Joomla 5.1.1
4. Install J2xml 3.9 on the new Joomla page to import all content.

Works fine, over 100 articles imported, even the links work 99% on the new site.

Now I am continuing to work on the design but as I have updated other pages in the past, I know that you have to to this anyway even when you update the "standard" way.

Thanks for the help especially to Peter.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 25083
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Login Problem / Migrate

Post by pe7er » Mon Jun 10, 2024 9:41 am

You're welcome! Good to hear that it's working now.
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 31163
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Login Problem / Migrate

Post by Per Yngve Berg » Mon Jun 10, 2024 12:26 pm

Get the 3.4.7 Upgrade Package and install as an extension. This is the last version you can do that with.

User avatar
AMurray
Joomla! Master
Joomla! Master
Posts: 10003
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Login Problem / Migrate

Post by AMurray » Mon Jun 10, 2024 10:04 pm

you need to update from 3.10 to 4 then 4 to 5 - no other migration path.
Regards - A Murray
General Support Moderator

Advertisement

Post Reply

Return to “General Questions/New to Joomla! 1.5”