Page 1 of 1

Weird letters added to URLs upon first visit.

Posted: Thu May 01, 2008 5:40 pm
by jguzman
Greetings

I'm having issues with joomla adding some weird letters to urls upon first visit with IE6 and IE7.

For example Ill have a link like this:
http://mywebsite.com/example-website

be turned into something like this:
http://mywebsite.com/example-website?ac ... a1e2c6fb67

is there anyway I can turn off that "?ac9a796026e807069c2683b221efb607=f1023cf6f0cbde6ebd8ce2a1e2c6fb67" part? It seems to be causing some trouble with some plugins I have.

Re: Weird letters added to URLs upon first visit.

Posted: Thu May 01, 2008 10:17 pm
by pe7er
What Joomla 1.5 version do you have? 1.5.3?
What 3rd party extensions did you install?

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 1:09 pm
by jguzman
Greetings

thanks for replying pe7er

My joomla version: Joomla! 1.5.3 Production/Stable [ Vahi ] 22-April-2008 22:00 GMT

Third party plugins installed are:
  • Editor Button - Article Linker (Author linker)
  • Authentication - jfusion (Author Jfusion)
  • User - Jfusion (Author Jfusion)
Third Party Modules installed are:
  • mod_jumi (Author Martin Hajek)
  • mod_jfusionlogin (Author JFusion Development Team )
Components
  • Jfusion (Author JFusion Development Team )
  • Linkr (Author Frank )
You can take a look at my website here at http://www.infoboda.com

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 1:52 pm
by jguzman
Greetings pe7er

I did a search in the SQL database for the second half of the mystery string:
(ac9a796026e807069c2683b221efb607=f1023cf6f0cbde6ebd8ce2a1e2c6fb67)

and found that f1023cf6f0cbde6ebd8ce2a1e2c6fb67 corresponded to the session_id in the session table. Is it normal for joomla to do something like this? I also noticed it shows in firefox as well, not just in IE6 and IE7.

thanks

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 1:57 pm
by pe7er
jguzman wrote:and found that f1023cf6f0cbde6ebd8ce2a1e2c6fb67 corresponded to the session_id in the session table. Is it normal for joomla to do something like this? I also noticed it shows in firefox as well, not just in IE6 and IE7.
I think that it's not normal behaviour to have the session ID included in the URL.
Maybe the extension jfusion includes this session ID?

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 2:17 pm
by jguzman
Greetings pe7er

I will try to replicate this behavior in my test server. I found a thread here on this subject http://groups.google.com/group/joomla-d ... f73b6fef75 it seems it has already been addressed. I'll do some reading in the jfusion forum to see if this is a normal behavior of the plugin.

I'll let you know as soon as I find something more about this pe7er

Again, thanks for all the help.

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 8:27 pm
by jguzman
Greetings pe7er

I found out the source of the problem, it's my PHP.ini, there's some type of setting in it that is making joomla add the session_id to all my URLs. My webhosting provider gives me the option to put my own php.ini to overide the default one. By deleting/renaming my php.ini I was able to have joomla working well again. I'm not that knowledgeable with the PHP.ini , so maybe someone in the future that might be experiencing this same problem will be able to track down what exactly what setting might be causing this.

Thanks for all your help pe7er

Re: Weird letters added to URLs upon first visit.

Posted: Fri May 02, 2008 8:30 pm
by pe7er
Good to hear that you've solved it!
Thanks for sharing this info as it might be very useful for other users who experience the same problem!

Re: Weird letters added to URLs upon first visit.

Posted: Wed May 07, 2008 1:59 pm
by isant
Hi i have the same problem, what can i change in my php.ini ? thanks!

Re: Weird letters added to URLs upon first visit.

Posted: Wed May 07, 2008 10:14 pm
by kenmcd
isant wrote:Hi i have the same problem, what can i change in my php.ini ? thanks!
Does your web site code validate?
Please post a link to the site.

Re: Weird letters added to URLs upon first visit.

Posted: Mon Jun 02, 2008 4:53 pm
by benske
I've the same problem but my I can't remove the PHP.ini by my webhoster.
Thanks for your help!

Re: Weird letters added to URLs upon first visit.

Posted: Mon Jun 02, 2008 5:04 pm
by benske
benske wrote:I've the same problem but my I can't remove the PHP.ini by my webhoster.
Thanks for your help!
I found something:
insert this code:
ini_set('session.use_cookies', '1');
ini_set('session.use_only_cookies', '1'); // PHP >= 4.3
ini_set('session.use_trans_sid', '0');
ini_set('url_rewriter.tags', '');

into you session.php file (/plugins/system/legacy/) (just after <?php)

or insert :
php_flag session.use_trans_sid off
in your HTACCESS
On my site it works now (www.mess-land.be) and i've not this problem anymore... can somebody try this?

Re: Weird letters added to URLs upon first visit.

Posted: Sat Jun 21, 2008 3:06 pm
by BigBadBurrow
benske,

I tried the items in your post but they didn't seem to make any difference. I also tried entering the line in my htaccess file and that didn't work.

So I asked my host to provide my own php.ini file, and I changed:

session.use_trans_sid = 1
to
session.use_trans_sid = 0

and that did work.