Internet Explorer/Flash

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
sglindo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Nov 21, 2008 10:19 pm

Internet Explorer/Flash

Post by sglindo » Fri Nov 21, 2008 10:46 pm

I'm not sure if I"m in the right place for this question since I'm a bit new to the Joomla experience but here's the situation. I'm using version 1.5.7 with JCE 1.5.1 as the editor along with AVR Media to embed my flash video-in an article btw. When I insert my swf file this is the code that's given: {swf width="200" height="200"}NOML_Asthma{/swf}. Now in FF the video plays flawlessly, however in IE7 it loads briefly and then disappears and leaves me with a white box the height and size of the video. Interestingly when I right click on that area I see information about two flash players; JW Flash player 3.16 and of course Adobe Flash Player 9. I think the JW player came with AllVideos Reloaded-I just didn't expect the two players to load at the same time... Hmmm..

I've seen some posts in here where people have had their swf's not load at all. That's not the case with me. Mine every now and then will load, but if I refresh the browser it won't reload or it pulls that vanishing act.

If you have some insight it would be much appreciated...

User avatar
findshare
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 102
Joined: Thu Jul 26, 2007 5:04 pm
Location: Spain
Contact:

Re: Internet Explorer/Flash

Post by findshare » Fri Nov 21, 2008 11:14 pm

Although i can't help you at all with this question, keep this site for reference. it enables you to see how your website loads in various browsers. Well worth the look.
http://browsershots.org/
Chaos and disorder? Yep, I have finished my work!!
http://eyestyle.net

User avatar
davetanguay
Joomla! Hero
Joomla! Hero
Posts: 2511
Joined: Fri Sep 22, 2006 6:21 pm
Location: Orlando, FL
Contact:

Re: Internet Explorer/Flash

Post by davetanguay » Sat Nov 22, 2008 6:35 am

Have you tried posting this on the JCE forum at http://www.joomlacontenteditor.net/forum/index.php ?
CPanel Web Hosting Services http://interactiveonline.com/shared-web-hosting
Follow us on Twitter @interactiveo

sglindo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Nov 21, 2008 10:19 pm

Re: Internet Explorer/Flash

Post by sglindo » Sat Nov 22, 2008 12:34 pm

Thanks for the info findshare... Didn't know about the JCE forum Dave. I'll post over there as well. Thanks...

sanelv
Joomla! Intern
Joomla! Intern
Posts: 58
Joined: Mon Oct 06, 2008 4:35 pm
Location: Sri Lanka
Contact:

Re: Internet Explorer/Flash

Post by sanelv » Sat Nov 22, 2008 5:15 pm

What is the method that was used to embed the flash in to the site. Check the "Page source" and you'll see. Is it <embed> or <script>
Sanjaya Elvitigala
Freelancer
Web Design Guy : http://www.mclanka.com

sglindo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Nov 21, 2008 10:19 pm

Re: Internet Explorer/Flash

Post by sglindo » Mon Nov 24, 2008 1:13 pm

I think it's an embed option... Here's the code:


<p><!-- AllVideos Reloaded Plugin (v1.2.4.1054) starts here
--><ins><noscript><div style="background-color:red;color:white;width:160px"><strong>JavaScript is disabled!</strong><br/>To display this content, you need a JavaScript capable browser.</div></noscript></ins><span id="avreloaded0" class="allvideos"><ins><div id="warnflashavreloaded0" style="background-color:red;color:white;width:160px;visibility:hidden"><strong>Adobe Flash Player not installed or older than 8.0.39!</strong><br/><a href="http://www.adobe.com/go/getflashplayer" onclick="window.open(this.href);return false;" onkeypress="window.open(this.href);return false;"><img src="/joomla15/plugins/content/avreloaded/160x41_Get_Flash_Player.jpg" alt="Get Adobe Flash Player here" style="border:0" /></a></div></ins></span><script type="text/javascript">
swfobject.embedSWF('/joomla15/plugins/content/avreloaded/mediaplayer.swf','avreloaded0','200','200','8.0.39','/joomla15/plugins/content/avreloaded/expressinstall.swf',
{file:'http://localhost/joomla15/images/storie ... gits:'true',
showdownload:'false',usefullscreen:'true',backcolor:'0xFFFFFF',frontcolor:'0x000000',
lightcolor:'0x000000',screencolor:'0x000000',overstretch:'false'}
,{allowscriptaccess:'always',seamlesstabbing:'true',allowfullscreen:'true',wmode:'window',bgcolor:'#FFFFFF',menu:'true'},
{id:'p_avreloaded0',styleclass:'allvideos'});

</script><script type="text/javascript">window.addEvent("domready",function(){var s = "warnflashavreloaded0"; if ($(s)){$(s).setOpacity(1);}});</script><!--
AllVideos Reloaded Plugin (v1.2.4.1054) ends here --></p>

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19704
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Internet Explorer/Flash

Post by leolam » Mon Nov 24, 2008 1:38 pm

Latest JCE-Editor is as many sowftare (not only Joomla) affected by 'fancyuploader' issue created with the intro of flash10. This will not be resolved before Joomla 1.6

A lot has been written and I posted a temp solution as add-on here: http://forum.joomla.org/viewtopic.php?p ... 9#p1466599

(read the entire thread=interesting)

Leo ;-)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

sglindo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Nov 21, 2008 10:19 pm

Re: Internet Explorer/Flash

Post by sglindo » Tue Nov 25, 2008 5:49 pm

I think I've put my finger on the issue. It's not a Joomla issue but one of the JW flash Player and IE not being so chummy. Apparently if you open a new browser IE will show and play the swf-which is exactly what's happening with me-but then it caches it and that's where the problem lies. IE somehow doesn't cache the entire swf parameters and all such that when the browser is refreshed the swf file doesn't return. I found that if I used the developers tool in IE to clear the browser cache, my swf reappeared every time. Not too practical for the end user.

I've seen some code work arounds that are supposed to eliminate that problem, however, I haven't been able to figure out how to integrate them into the code posted above such that it will work. In the meantime I'm using the classic <object></object> tags to embed the swf. It works fine though my file isn't wrapped in a skin like JW Flash Player did. I just added some rudimentary player controls to the original fla file which will get me over until I can figure what to do next.

I tell ya that IE sometimes....

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19704
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Internet Explorer/Flash

Post by leolam » Wed Nov 26, 2008 9:59 am

Well you have not precisely put the finger on the issue. The sisue is very well documented in the large thread where i pointed at. Adobe has release Flash10 and all software (!) that uses the fancyuploader is affected. This counts for thousands of programs including Joomla. You can blame IE for many things but this is not related. The message is simple wait till it will be resolved hopefully in Joomla 1.6 or roll back as explained to Flash9

Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services


Locked

Return to “General Questions/New to Joomla! 1.5”