Page 1 of 1

Error code: ssl_error_rx_record_too_long

Posted: Sat Aug 15, 2009 10:22 am
by shiggydiggy
is what I get when i try to log in as admin (only have one user so I haven't tried any others yet).
is my host playing up?

Re: Error code: ssl_error_rx_record_too_long

Posted: Sat Aug 15, 2009 10:37 am
by ccauth
This usually means the implementation of SSL on your server is not correct. The error is usually caused by a server side problem which the server administrator will need to investigate.

Below are some things that are worth trying.

- Ensure that port 443 is open and enabled on your server. This is the standard port for https communications.

- If SSL is using a non-standard port then FireFox 3 can sometimes give this error. Ensure SSL is running on port 443.

- If using Apache2 check that you are using port 443 for SSL. This can be done by setting the ports.conf file as follows

— clip —
Listen 80
Listen 443 https
— clip —

- Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.

- If using Apache2 check your vhost config. Some users have reported changing <VirtualHost> to _default_ resolved the error.

Of course, if your site should not be running with SSL enabled, then you need to disable it on the server side. You may also check to see if you can access your site from a different computer (on a different network than the one giving you the error) as it could be a local proxy config issue as well...

Re: Error code: ssl_error_rx_record_too_long

Posted: Sat Aug 15, 2009 10:40 am
by ccauth
you should also check to make sure (if you are not supposed to be using ssl) that inside global configuration, under the server section that force ssl is set to none and MORE IMPORTANTLY, go to MODULE MANAGER >> LOGIN FORM (or whatever login module you are using) and make sure that "ENCRYPT LOGIN FORM" is NOT enabled....

Re: Error code: ssl_error_rx_record_too_long

Posted: Mon Nov 15, 2010 6:10 pm
by adam20
Hi everyone, this is my first entry on the Joomla! forums.

I am also having this problem, but this error message only shows up on the one computer, which I suspect means it is the config proxy settings mentioned above.

Does anyone know how to reset these?

Re: Error code: ssl_error_rx_record_too_long

Posted: Mon Nov 15, 2010 7:08 pm
by adam20
To elaborate a little more, I was trying to configure the ftp layer in joomla!, which wasn't working. I tried using the force SSL as an option, which then started this error occurring.

I have since changed my configuration.php file to not use the ftp layer, which has sorted the problem for other computers, but not the one I'm working on.

I've looking into addressing the local problem, and have flushed the dns. I understand that this problem should resolve anyway within an hour, but it has been nearer 4 now with no change.

Any suggestions would be greatly appreciated.


Thanks

Re: Error code: ssl_error_rx_record_too_long

Posted: Mon Nov 15, 2010 8:04 pm
by adam20
Problem solved, the dns flush must have worked. I just needed to close and reopen my browsers as well.