Page 1 of 1

Joomla Text Editor inserts hyphens into script tags

Posted: Wed Jan 19, 2011 4:25 am
by webedge
I've got a problem with plain text editor in Joomla, happening in both modules and articles.

When trying to insert a script it is automatically inserting two hyphens and breaking the script:

<S-CRIPT LANGUAGE="JavaScript" TYPE="text/j-avascript">

I delete the hyphens, hit apply, and they reappear. Happens in all modules or articles.

Joomla 1.5.22.

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Wed Jan 19, 2011 5:50 am
by webedge
Installed Sourcerer to see if that fixed the issue. Using [[ instead of < fixed the hyphen in the <S-CRIPT part, but the forward slash seems to be causing issues for text/j-avascript. If I remove the forward slash the hyphen does not get added.

What could be causing this?

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Mon Jan 23, 2012 8:13 pm
by wileybob
didja ever get a solution to this? im having the same issue...

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Wed Nov 28, 2012 3:11 pm
by webxsposure
my problem was rsfirewall, the latest version (v46) I have placed a ticket with support and hopefully this will get fixed asap. I uninstalled rsfirewall and everything went back to normal.

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Fri Nov 30, 2012 8:11 am
by archangelweb
If you have RSFirewall installed, go to Components>RSFirewall!>Firewall Configuration.

Click "Active Scanner" tab.

Make sure "Enable Active Scanner in the /administrator section" is set to NO.

Save.

You will have to go back and re-enter/re-paste the code that was being changed, but following these steps worked for me.

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Tue Sep 03, 2013 6:59 pm
by Spell
Thanks archangelweb — I had the exact same problem. Specifically, RS Firewall was messing up the code to display the Authorize.Net Verified Merchant Seal. This solved the problem. Much obliged.

Re: Joomla Text Editor inserts hyphens into script tags

Posted: Thu Jun 09, 2016 3:35 pm
by numinousmedia
This solved my issue as well, with adding some custom JS to a template. Thanks for that recommendation!