Joomla 1.5 in php 5.6

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
stavroch
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Wed Feb 15, 2006 10:23 pm

Joomla 1.5 in php 5.6

Post by stavroch » Wed Jul 27, 2016 8:11 am

The site is Joomla 1.5 and the php version is 5.6
I get error in public_html/libraries/joomla/application/module/helper.php

Have you any solution of how can I make the site to work right?
Last edited by toivo on Wed Jul 27, 2016 8:22 am, edited 1 time in total.
Reason: mod note: moved, not related to Performance

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11165
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK

Re: Joomla 1.5 in php 5.6

Post by toivo » Wed Jul 27, 2016 8:42 am

What is the actual error message?

If it is just a PHP notice or warning, you can filter them by changing the error reporting option in Global Configuration to 'None'.

Joomla 1.5 is unsupported and vulnerable to attacks. Its last update 1.5.26 was released in March 2012. There is plenty of documentation how to migrate to a supported version.
Toivo Talikka, Global Moderator

stavroch
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Wed Feb 15, 2006 10:23 pm

Re: Joomla 1.5 in php 5.6

Post by stavroch » Wed Jul 27, 2016 12:35 pm

I have already set the Global Configuration to None, but I can understand that it is not the right way.

mbabker
Joomla! Hero
Joomla! Hero
Posts: 2199
Joined: Sun Feb 28, 2010 8:26 pm

Re: Joomla 1.5 in php 5.6

Post by mbabker » Wed Jul 27, 2016 2:59 pm

Joomla 1.5's code base is truly last compatible with PHP 5.3. With changes in PHP 5.4 and later, there's no way to get it to run "error free" without just silencing all errors and there actually are a couple of classes that will fatal error on PHP 5.5 or 5.6.

For reference, Joomla 1.5 is PHP 4 compatible and as such has a lot of structures that are considered "bad" with more recent PHP versions. So a lot of the strict standards and PHP warning messages you end up getting come from the fact that the code is using PHP 4 structures (i.e. no visibility scopes, no static keyword, etc.)

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3377
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Joomla 1.5 in php 5.6

Post by ribo » Wed Jul 27, 2016 3:30 pm

The best way is to migrate your joomla 1.5 to joomla 3.6.0
chat room spontes : http://www.spontes.com


Locked

Return to “General Questions/New to Joomla! 1.5”