SSL in Joomla 1.5 breaks my site

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

SSL in Joomla 1.5 breaks my site

Postby djslue » Wed Nov 01, 2017 8:55 pm

I have 2 websites, I'm in the process of moving my 1.5 one to a new 3.8 one. When I enable SSL on the 1.5 site it "Breaks" my site. The layout goes to all text and the site is a mess.



Anyone know how to fix it until I can get the new site complete?

Thanks
Steve

Here is an image of it.
Capture.PNG
You do not have the required permissions to view the files attached to this post.
Last edited by toivo on Wed Nov 01, 2017 9:35 pm, edited 2 times in total.
Reason: mod note: moved from the 3.x forum - please post to the correct forum

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Wed Nov 01, 2017 8:56 pm

Capture.PNG
You do not have the required permissions to view the files attached to this post.

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1544
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: SSL in Joomla 1.5 breaks my site

Postby fcoulter » Thu Nov 02, 2017 11:40 am

It is likely an issue with your template, it uses images and stylesheets that are loaded over http, so your browser is blocking them.

You can solve this by editing your template so that https is used, probably the code loading the stylesheets will be in the head of the template index.php file.

Or switch to another template.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator
VEL team member
"Wearing my tin foil hat with pride"

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Thu Nov 02, 2017 12:11 pm

I would like to keep this template as I'm moving to a new site in a month or so. I'll check that template file.

Thanks for the info!

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Thu Nov 02, 2017 12:13 pm

I found that index.php file Just wondering what exactly I should be looking for

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1544
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: SSL in Joomla 1.5 breaks my site

Postby fcoulter » Thu Nov 02, 2017 12:27 pm

css files, or anything with an http url.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator
VEL team member
"Wearing my tin foil hat with pride"

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Thu Nov 02, 2017 12:34 pm

So any css files and anything under the template?

User avatar
day
Joomla! Explorer
Joomla! Explorer
Posts: 394
Joined: Tue Mar 14, 2006 12:20 pm

Re: SSL in Joomla 1.5 breaks my site

Postby day » Thu Nov 02, 2017 1:18 pm

Try adding the following somewhere at the top of .htaccess (after a backup):

RewriteEngine on
RewriteCond %{SERVER_PORT} !^443$
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [QSA,R=301,L]
<IfModule !mod_ssl.c>
Redirect permanent / https://yoursite.com
</IfModule>

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Thu Nov 02, 2017 1:34 pm

Backup the whole site or just that file?

User avatar
day
Joomla! Explorer
Joomla! Explorer
Posts: 394
Joined: Tue Mar 14, 2006 12:20 pm

Re: SSL in Joomla 1.5 breaks my site

Postby day » Thu Nov 02, 2017 1:38 pm

djslue wrote:Backup the whole site or just that file?

Just the .htaccess file.
Last edited by day on Thu Nov 02, 2017 1:46 pm, edited 2 times in total.

djslue
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 148
Joined: Thu Oct 22, 2009 4:42 am

Re: SSL in Joomla 1.5 breaks my site

Postby djslue » Thu Nov 02, 2017 1:43 pm

Thanks, I'll try that

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 34161
Joined: Sat Apr 05, 2008 9:58 pm

Re: SSL in Joomla 1.5 breaks my site

Postby Webdongle » Tue Dec 12, 2017 9:20 pm

Your other site uses upper case for folders and files. If this site does also then that may cause a problem


Return to “General Questions/New to Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 7 guests