Page 1 of 1

backward compatibile templates?

Posted: Sun Mar 18, 2018 10:24 am
by Daedric1991
So i have been asked by my boss to develop a new template for his website running 1.5.26 and i can't get it to run on my system because dif versions and so im running the latest of XAMPP(windows) and MAMP(on mac) but the 1.5.26v wont run.

If i grab the new joomla and build a template on that is it possible to use that template on 1.5.26? or am i going to have to chase down an older v of the server host and downgrade my stuff just to build a template for him?

i get this error when i try and load the page for the first time

Code: Select all

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in G:\XAMPP\htdocs\CoastlineNewsDev\includes\framework.php:21 Stack trace: #0 G:\XAMPP\htdocs\CoastlineNewsDev\index.php(22): require_once() #1 {main} thrown in G:\XAMPP\htdocs\CoastlineNewsDev\includes\framework.php on line 21
i read this means i have a newer version of php and it wont work with joomla 1.5.26

Re: backward compatibile templates?

Posted: Sun Mar 18, 2018 10:42 am
by Per Yngve Berg
Migrate the hole site to the present version of Joomla (3.8.6).
It's unsafe to run a version of Joomla that have not been supported for 10 years.

https://docs.joomla.org/Planning_Migrat ... a_1.5_to_3


PS. 1.5.26 run on php 5.6, but not on 7.0, 7.1 and 7.2