Page 1 of 1

Website not working

Posted: Wed Mar 13, 2019 9:40 am
by kcirtapsnimmuc
Hi

We have a website called southdublinswans.com and it doesn't seem to be working.

When I go into southdublinswans.com/administrator it looks all weird.

It is like the css is all wrong.

Would you know anything about this?

Re: Website not working

Posted: Wed Mar 13, 2019 2:44 pm
by mjparadac
Hello kcirtapsnimmuc, welcome to the forum.

Could you give details about the site?
Any recent changes, updates, new extensions?

Regards,

Re: Website not working

Posted: Wed Mar 13, 2019 4:35 pm
by kcirtapsnimmuc
No changes have been made to the site in over a year and it was working a few months ago when I last checked it.

Have no idea what is wrong with it, just getting blank page when going to url

Re: Website not working

Posted: Wed Mar 13, 2019 5:15 pm
by dragonrider
Looks like it's lost some files, possibly someone has been causing issues. Couldn't suggest fix other than perhaps to check your server to see if there are extra files, or permissions have been changed from 644 (files) 755 (directories).
Also check the configuration.php file to see if anything has been added to it.

Re: Website not working

Posted: Wed Mar 13, 2019 10:21 pm
by john-doe
dragonrider wrote:
Wed Mar 13, 2019 5:15 pm
Looks like it's lost some files, possibly someone has been causing issues. Couldn't suggest fix other than perhaps to check your server to see if there are extra files, or permissions have been changed from 644 (files) 755 (directories).
Also check the configuration.php file to see if anything has been added to it.
If you see some gibberish-name.php Be aware because your server has been compromised.
ensure as well that the index.php does not carry suspicipus lines on the first lines of the file.

Re: Website not working

Posted: Thu Mar 14, 2019 9:53 pm
by AMurray
Is the site mission-critical or just a hobby site?

If it's a year out of date.....you have serious catching up on Joomla core updates to do.

Following on from @john-doe's comments, suggest you try the myjoomla.com service; it audits your site for security and other issues. First audit is free, but it is a subscription service, and may be well worth your time and money. It explains most problems is easy to understand language, and takes you through steps to resolve the problems (in many cases, just click a button to fix them)

It will at least advise if there's serious issues with the site in terms of it being compromised (or suspected of such).

This is a lesson learned; make sure Joomla is up to date including third-party extensions. It doesn't matter if the site is a hobby site, or your bread-and-butter.

I can see on the largely white screen just the login form . Front end is no better, with completely white screen.

I think the first thing to do is turn on the error reporting - in configuration.php file (open in a text editor) and turn on the option there. Also, in your hosting account admin panel (not joomla), there should be an error reporting option there, or you can add it to the php.ini file. (You may want to refer to your hosting's support - either contact them or refer to their knowledge-base, forums or FAQ resources, whichever they have available) for info on how to turn on PHP error reporting).

Also it would help us to help you, if you can run the Forum Post Assistant - download it from the link inthe read box, top of this page. viewtopic.php?f=806&t=969442. It's not a Joomla extension, it is a single file script, upload it to the joomla folder, and run it from your browser. Generate the report, and post ther esults to a reply on the forum here.

If the site is hacked (not saying yours is), there is only one solution - a complete deletion and restore of the site. viewtopic.php?f=714&t=946026

Re: Website not working

Posted: Thu Mar 14, 2019 10:17 pm
by PhilTaylor-Prazgod
You are running Joomla 1.5 in 2019 as evidenced by this in your source code.

Code: Select all

<meta name="generator" content="Joomla 1.5" />
Your webhost is SiteGround, so probably running modern PHP 7

Simple. Your website is not fit for production use in 2019. Its been SEVEN YEARS since Joomla 1.5 was officially end of life.

Get real and delete your site from the internet. And start again from scratch.