1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
limo2005
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 03, 2008 12:44 pm

1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by limo2005 » Thu Apr 03, 2008 1:45 pm

Release version: Joomla_1.5.2-Stable-Full_Package
Shared Host
System Information: Versions: Perl 5.008005, MySQL 5.0.45, ASP 4.0.2L, PHP 4.4.8, PHP5 5.2.5
OS: Vista

Database Configuration STEP 4
THE PROBLEM: I am attempting to install JOOMLA 1.5.2 and I get the following message : -
The MYSQL Database name must start with a letter and be followed by only letters, numbers or underscores
.
dberror2.png
Database Type
MySQL |This is probably MySQL
Host Name
localhost |This is usually localhost or a host name provided by the hoster
User Name
web99-mydbname |This can be the default MySQL username root or a username provided by the hoster, or one that you have created whilst setting up your database server.
Password
********* |For site security using a password for the MySQL account is mandatory. This is the same password used to access your database. This may again be preset by your hoster.
Database Name
web99-mydbname |Some hosts allow only a certain DB name per account. If this is the case use the table prefix option in the following Advanced Parameters section to distinguish more than one Joomla! site.
dberror1.png
I have Successfully installed a number of Joomla and mambo sites in the past and most recently installed 1.5.1 to the same host using the same Database name format.

What I have tried to solve the issue:
1)Thought about installing earlier release and upgrading.
2)Contacted Host - cannot change format of database name. Their Response is :
Can I rename my database getting rid of the 'web-' part if the name?
Unfortunately this isn't possible as the convention is required for backing up the data on the web servers.
.

3)Tried to omit the "-" from the database name and its accepted although its not the correct name for the database. The issue seems to be the "-" in the database name not being accepted by the installation!

What searches I have done/information that may be related: Read simiar post on forum but not resolved. viewtopic.php?f=429&t=280580

Is there anything I have missed here?

Thank you!

UPDATE 3rd April 2008 17:29
I have used another domain that I have with the same Host and installed Joomla_1.5.1 quite sucessfully using the same database format has that detailed above. The site is fully installed at this time and with all intents and purposes, seems to be working just fine!
MY CONCLUSION - Seems there is an issue with the database name containing the character "-" in Joomla_1.5.2. preventing the software from installing and configuring the database.
You do not have the required permissions to view the files attached to this post.
Last edited by limo2005 on Thu Apr 03, 2008 4:35 pm, edited 1 time in total.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Thu Apr 03, 2008 4:11 pm

Hi,
This intrigued me so did some digging around

the change appears to have been made in SVN10116 in response to a bug tracker 10055.

It relates to installation>installer>models>model.php
the particular code can be found at lines 320 +

Code: Select all

	//return JInstallationView::error($vars, JText::_('emptyDBName'), 'dbconfig');
		}
		if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_]*$#', $DBPrefix )) {
			$this->setError(JText::_('MYSQLPREFIXINVALIDCHARS'));
			$this->setData('back', 'dbconfig');
			$this->setData('errors', $errors);
			return false;
		}
		if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_]*$#', $DBname )) {
			$this->setError(JText::_('MYSQLDBNAMEINVALIDCHARS'));
			$this->setData('back', 'dbconfig');
			$this->setData('errors', $errors);
			return false;
		}
		if (strlen($DBPrefix) > 15) {
			$this->setError(JText::_('MYSQLPREFIXTOOLONG'));
			$this->setData('back', 'dbconfig');
			$this->setData('errors', $errors);
			return false;
		}
		if (strlen($DBname) > 64) {
			$this->setError(JText::_('MYSQLDBNAMETOOLONG'));
			$this->setData('back', 'dbconfig');
			$this->setData('errors', $errors);
			return false;
		}
and:

installation>template>tmpl>dbconfig.html lines 21 and 35-46

and language file

It seems that there is now a constraint on the digits that can be used for the database name. whether you can simply add your hyphen to the first two blocks of code above I don't know but I don't see why not. (I am not a programmer!!) Otherwise would suggest raising an issue in the 1.5 Q&T forum.
hth

Andy

edit to add file names

limo2005
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 03, 2008 12:44 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by limo2005 » Thu Apr 03, 2008 4:55 pm

Andy,

Thank you very much for your prompt response and Investigation. :) I have installed 1.5.1 on another domain (Same Host) with success so My next move is to attempt the same and then Upgrade to 1.5.2!

I did have a look at the code and its much easier to try the upgrade path from 1.5.1.

Thanks for the time!

Limo!

User avatar
island2007
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Sun Apr 01, 2007 5:33 am
Location: Gibraltar
Contact:

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by island2007 » Sun Apr 06, 2008 12:12 pm

I had the same problem - amending the code by adding a "-" works eg :

Code: Select all

if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {
on installation>installer>models>model.php (lines 322 & 328

& also on installation>template>tmpl>dbconfig.html line 21

Code: Select all

var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;
Stuart
Stuart.

http://www.tradetaxfree.com/cms/private ... t-programs - Placement Programs Investments & Trading

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Sun Apr 06, 2008 12:20 pm

Stuart
Thanks for the confirmation - I am trying to find out the importance, if any, of the change that was made and will report back

Andy

limo2005
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 03, 2008 12:44 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by limo2005 » Sun Apr 06, 2008 2:31 pm

island2007 wrote:I had the same problem - amending the code by adding a "-" works eg :

Code: Select all

if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {
on installation>installer>models>model.php (lines 322 & 328

& also on installation>template>tmpl>dbconfig.html line 21

Code: Select all

var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;
Stuart
Stuart
You explained that so well! Thanks!

Resolved the issue for me.... :)

Michael

ozeire
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Mar 07, 2008 1:31 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by ozeire » Sun Apr 06, 2008 4:42 pm

Great work Stuart

Have tried a few installs of Joomla 5.1.2 with your fix and working great

I had the same problem - amending the code by adding a "-" works eg :

Code: Select all
if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {



on installation>installer>models>model.php (lines 322 & 328

& also on installation>template>tmpl>dbconfig.html line 21

Code: Select all
var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;

Stuart
Alan

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Tue Apr 08, 2008 10:55 am

This relates to tracker 10055 issue with admin logins - Ihave added further comment to this item and raised a query in the 1.5 Q&T forum http://forum.joomla.org/viewtopic.php?f ... 2#p1262811

Andy

Sweeps
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Apr 10, 2008 6:29 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by Sweeps » Thu Apr 10, 2008 8:21 pm

I had the same problem - amending the code by adding a "-" works eg :

Code: Select all
if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {

on installation>installer>models>model.php (lines 322 & 328

& also on installation>template>tmpl>dbconfig.html line 21

Code: Select all
var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;

Stuart
I have the same problem and tried the above but with no joy. I'm with Fasthosts and have run their database test which conects with the same details that I put into Joomla and it reports there are no problems. My server name is mysql-219-89 if that is of any help. I'm at my wits end so I hope someone can point me in the right direction.

Many thanks,

Paul.

User avatar
tbm2020
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Wed Jun 21, 2006 7:53 am
Location: UK
Contact:

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by tbm2020 » Tue Apr 15, 2008 5:40 pm

Awesome work :)

cheers that's saved alot of trouble and time.

Gd work ;D

Tim

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Tue Apr 15, 2008 6:32 pm

Sweeps wrote: I have the same problem and tried the above but with no joy. I'm with Fasthosts and have run their database test which conects with the same details that I put into Joomla and it reports there are no problems. My server name is mysql-219-89 if that is of any help. I'm at my wits end so I hope someone can point me in the right direction.
Paul,
Do you receive the same error message as the original poster? If so recheck the code you have edited in both files and make sure both are identical.
This is the fudge fix for the reported problem pending a more permanent patch from developers.

Andy

User avatar
tbm2020
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Wed Jun 21, 2006 7:53 am
Location: UK
Contact:

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by tbm2020 » Tue Apr 15, 2008 6:37 pm

Sweeps wrote:
I have the same problem and tried the above but with no joy. I'm with Fasthosts and have run their database test which conects with the same details that I put into Joomla and it reports there are no problems. My server name is mysql-219-89 if that is of any help. I'm at my wits end so I hope someone can point me in the right direction.

Many thanks,

Paul.
double check you've changed it on 2 lines in the model.php file and 1 line in the dbconfig file. Just an idea.

Tim

vanedge
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Apr 20, 2008 3:16 am

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by vanedge » Sun Apr 20, 2008 3:18 am

This thread SAVED MY LIFE!!!
The solution worked. I'm a newbie and never edited code before.
THANKS!!!!!!! :)

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Sun Apr 20, 2008 10:12 am

Glad it helped.

Andy

User avatar
ased
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Oct 02, 2006 9:33 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by ased » Wed Apr 23, 2008 2:02 pm

island2007 wrote:I had the same problem - amending the code by adding a "-" works eg :

Code: Select all

if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {
on installation>installer>models>model.php (lines 322 & 328

& also on installation>template>tmpl>dbconfig.html line 21

Code: Select all

var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;
Stuart
------------------------------
would you mind please if you show me where to add the "-".
Thanks

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Wed Apr 23, 2008 10:54 pm

if (!preg_match( '#^[a-zA-Z]+[a-zA-Z0-9_-]*$#', $DBPrefix )) {

var regex=/^[a-zA-Z]+[a-zA-Z0-9_-]*$/;

It is already in the examples shown at ...0-9_-]

it just does not show up particularly clearly on forum

Andy

User avatar
ased
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Oct 02, 2006 9:33 pm

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by ased » Thu Apr 24, 2008 12:27 pm

Thank you very much for your help , it seems that the latest rel (1.5.3) fixed this issue .
thanx again

stormdevil
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Sep 28, 2007 6:33 am

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by stormdevil » Wed Apr 30, 2008 12:42 pm

Thanks for the fix, though after dozens of Joomla installs, I wasn't expecting this to fail!

Toni
Toni (http://www.qivva.com)

Visit http://extensions.qivva.com for the latest Calendar module for EventList

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: 1.5.2 Install problem - STEP 4 DATABASE CONFIGURATION

Post by humvee » Fri May 02, 2008 12:20 am

If you install/upgrade to 1.5.3. the issue is fixed as ased said.

Andy


Locked

Return to “Installation 1.5”