Use the Correct Version of XAMPP!

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
PhilD
Joomla! Hero
Joomla! Hero
Posts: 2734
Joined: Sat Oct 21, 2006 10:20 pm
Location: Wisconsin USA
Contact:

Use the Correct Version of XAMPP!

Post by PhilD » Fri Aug 14, 2009 2:03 am

There have been numerous posts recently scattered on the Joomla forums. The issue is Joomla is NOT currently compatible with php 5.3.x which is the current down-loadable version available from XAMPP's download page.

Here is where to go and what to do to get the proper version.
Like the Apache friends page says here: http://www.apachefriends.org/en/xampp-windows.html

Download older versions of XAMPP (even the "old" WAMPP) directly from Source Forge.

The older files are here:
http://sourceforge.net/projects/xampp/files/

Go to XAMPP Windows and click to open the dropdown

Scroll down to the bottom of the page and find the 1.7.0 dropdown

Open the dropdown and select the first file which is named xampp-win32-1.7.0-installer.exe

Completely remove the XAMPP version you currently have including any directories. and then install this version.

The 1.7.0 version is the version I'm using without problems. It uses php 5.2.8
PhilD -- Unrequested PM's and/or emails may not get a response.
Security Moderator

stealthnh
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat May 12, 2007 2:49 pm

Re: Use the Correct Version of XAMPP!

Post by stealthnh » Fri Aug 14, 2009 2:31 am

I'm using 1.7.1 and it has PHP 5.2.9 so you could get that as well right?
However I'm also having other issues, but I think its probably user error: http://forum.joomla.org/viewtopic.php?f=429&t=430352

User avatar
PhilD
Joomla! Hero
Joomla! Hero
Posts: 2734
Joined: Sat Oct 21, 2006 10:20 pm
Location: Wisconsin USA
Contact:

Re: Use the Correct Version of XAMPP!

Post by PhilD » Fri Aug 14, 2009 3:20 am

Yes, anything less than 5.3.x should work. I know for a fact though that the xampp version I suggested works fine and was why I suggest it.
PhilD -- Unrequested PM's and/or emails may not get a response.
Security Moderator


Locked

Return to “Installation 1.5”