Joomla and Plesk CAN co-exist !

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
m3lvm
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sun Jun 14, 2009 3:57 pm

Re: Joomla and Plesk CAN co-exist !

Post by m3lvm » Sat Feb 23, 2013 8:49 pm

Now this has been causing some really late night /early mornings.
Having a 1 & 1 dedicated server for multiple clients running Centos 6 and plesk 11, with error 500 server errors all of the time when installing most forum components and bridges using FastCgi.
This is what I have done to resolve the situation, it should be the same with a virtual server.
If you have sites on the server back them up now as you will loose them.
do a complete re image of the server so it is reset to default.
Now this is important do not add domains in the control panel just yet it will cause alot of messing about later
login to the server via shh using putty

Type these instructions into the terminal

wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh

// Now I know you should do an yum update but this will replace the files like mysql and apache. Which if your not sure on what you are doing can cause issues with the server not working correctly//

Now
type

vi/etc/php.ini

this will bring the php,ini file into a text editor ( while in the editor do not use the numeric keypad it will mess up the file)

search the file for these lines and change the settings

allow_url_fopen=On
upload_tmp_dir = "/tmp"
session.save_path = "/tmp"
output_buffering = On
zlib.output_compression = On
max_execution_time = 120
max_input_time = 120
memory_limit = 256M
error_reporting = E_COMPILE_ERROR|E_RECOVERABLE_ERROR|E_ERROR|E_CORE_ERROR
display_errors = Off
register_long_arrays = Off
post_max_size = 32M
session.gc_maxlifetime = 3600
magic_quotes_gpc = On
upload_max_filesize = 32M

// if you are new to vi these are the commands you need to work with vi //
i will let you insert text into the file at the end of the selected line
the arrow keys will let you search through the file
to exit and write to the file use this sequence esc shift+: then w enter
then shift+: then q enter to quit the editor
to quit the editor without writing to the file esc shift+: then q! press enter
By changing theses settings now all new domains created using fastcgi will have these setting in the default php.ini file for that domain.

While we have the terminal open we might as well install some other modules that Joomla might need
yum install php-mbstring php-pear php-xml php-soap php-suhosin php-xmlrpc mod_dav_svn php-bcmath
yum install ImageMagick ImageMagick-devel ImageMagick-perl
yum install php-ioncube-loader php-eaccelerator
yum install php-zend-guard-loader

//these setting are optional use at your own risk //

XCache is also easy to install, you can get from http://xcache.lighttpd.net/pub/Releases ... 3.0.tar.gz.
To install

1.wget http://xcache.lighttpd.net/pub/Releases ... 3.0.tar.gz
2.tar zxvf xcache-1.3.0.tar.gz
3.cd xcache-1.3.0
4.phpize./configuremakemake install

Check the place where the xcache.so is installed (some lib directory)
Then copy from xcache-1.3.0/xcache.ini into /etc/php.d/axcache.ini (use axcache to avoid problems with any zend extensions (Ioncube, Zend etc))
Edit /etc/php.d/axcache.ini and correct the path for xcache.so (to load from correct place).
Restart apache and check with php -v if is loaded.

If apache not restarting, see if the problem is not with Zend Optimizer and XCache.

IMPORTANT: After restart Apache, and execute php -v you may get error messages like "Failed loading /usr/local/Zend/lib/Optimizer-3.3.0/php-5.2.x/ZendOptimizer.so: /usr/local/Zend/lib/Optimizer-3.3.0/php-5.2.x/ZendOptimizer.so: cannot restore segment prot after reloc: Permission denied".

You will need to execute like this, just change the correct path to SO files.
view source
print?
1.chcon -t texrel_shlib_t /usr/lib/php/zend/ZendOptimizer-5.2.so
2.execstack -c /usr/local/Zend/lib/Optimizer-3.3.0/php-5.2.x/ZendOptimizer.so php -v

If you fo is not getting any errors, the problem is solved. In some cases also SELinux can create problems, we always disable it and use ASL.

install mailparse

01.pecl download mailparse
02.tar xvzf mailparse-XXX.tgz
03.cd mailparse-XXX
04.phpize
05../configure
06.make
07.make install
08.echo "extension=mailparse.so" >; /etc/php.d/mmailparse.ini
09.service httpd restart

Note that I've called the ini file 'mmailparse.ini' as the php.d ini files are loaded in alphabetical order. Mailparse needs mbstring so it needs to be loaded firstor else you will get a warning like ......PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mailparse.so' - /usr/lib64/php/modules/mailparse.so: undefined symbol: mbfl_name2no_encoding in Unknown on line 0

it is also recommend to install a new PECL module, installprogress (http://pecl.php.net/package/uploadprogress). This is very used in the last period.

pecl install uploadprogress

Add more Courier-IMAP connections

Plesk comes configured with a limit of 4 connections per IP address and a limit of 40 connections total. Modern IMAP clients such as Mozilla Thunderbird use mailbox caching to open up multiple connections to increase performance. In the case of Thunderbird, it opens up 5 connections by default which is already 1 connection more than Courier-IMAP's default restriction. Add another few family or corporate computers behind a firewall and those additional users won't be able to connect at all since a single Thunderbird client is already utilizing all 4 connections. This can increase the load of the server, but also is a must to not have complains from clients that they cannot connect to the server to get mails. You can raise this numbers depending on your server memory (our suggestion is for 2GB memory)
view source
print?
1.vi /etc/courier-imap/imapd
2.MAXDAEMONS=100
3.MAXPERIP=40

Backup your server

We suggest to setup a backup system to your server. This mean that in 99% of the cases, datacenters offer a backup place. Use that and backup your important files. Read how to do this at page - Automated Remote FTP Backup shell script

Avoid Dr.Web update notifications

In latest plesk version (plesk 9.5 upwards) following notifications generated from plesk and send to plesk administrator which irritate sometimes. You can stop such notifications by applying following fix on server.

Please open file /etc/cron.d/drweb-update using an editor and add '>/dev/null 2>&1' at the end of the line. In this case no email will be generated.

*/30 * * * * drweb /opt/drweb/update.pl >/dev/null 2>&1

Install mod-pagespeed for APACHE.

Thismodule can speed up your pages a lot.

yum install at
rpm -Uhv https://dl-ssl.google.com/dl/linux/dire ... x86_64.rpm

If all goes well, the module is already installed now, just restart apache. You can check if exist /etc/httpd/conf.d/pagespeed.conf Also you can play with this conf file as you like to test the best performance. I prefer to deactivate ModPagespeedStatistics OFF





Now once all this has been done remember most is at the risk of having to re-image if you are not too sure on what you are doing......
I wouldnt do install mailparse or ModPagespeed.
re boot the server

When you create you first domain and mysql database
you might want to up load a sql file via phpmyadmin
the import max upload is set at 2 meg
you have to change a different php.ini file
this one runs the plesk panel
so we
vi /usr/local/psa/admin/conf/php.ini


And change the file so it reads like this

short_open_tag = On
y2k_compliance = Off
output_buffering = Off
allow_call_time_pass_reference = On
max_execution_time = 600
max_input_time = 600
memory_limit = 128M
max_file_uploads = 99999

error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
log_errors = On
display_errors = Off
warn_plus_overloading = Off
expose_php = Off

variables_order = "ECGPS"
register_argc_argv = On
auto_globals_jit = Off
post_max_size = 32M
magic_quotes_gpc = Off
magic_quotes_runtime = Off

include_path = "/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin:/usr/local/psa/admin/smb:/usr/local/psa/admin/smb/application/library:/usr/local/psa/admin/plib/pear:/usr/local/psa/admin/compat"
upload_tmp_dir = "/tmp"
upload_max_filesize = 32M
Broadcast message from root@s16772837.onlinehome-server.info
apc.stat(unknown) at 2:14 ...
apc.shm_size = 40M
The system is going down for reboot NOW!
apc.enabled = 1

swkey.repository_dir = "/etc/sw/keys"

psasem.semfile = "/usr/local/psa/var/psasem.sem"


That sorts the phpmyadmin upload restrictions.


To complie this post was to help others that have issues with cgi issues and was created after alot of research on the net.
Thanks to http://www.grafxsoftware.com/faq.php/ho ... erver/1/4/
I have condensed what they were explaining to a fail safe fix.
If you wish to go further and are prepared to do more homework follow their tutorial to the letter and good luck

Kev
Last edited by m3lvm on Sun Feb 24, 2013 1:41 am, edited 1 time in total.

FrankA3
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Thu Feb 14, 2008 11:19 am

Re: Joomla and Plesk CAN co-exist !

Post by FrankA3 » Sun Feb 24, 2013 1:10 am

This really useful thread needs moving to 2.5 forum as it is independant of Joomla version and doomed to get lost here...

genegun
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Sat Oct 01, 2011 1:55 pm

Re: Joomla and Plesk CAN co-exist !

Post by genegun » Fri Mar 01, 2013 7:40 am

Thanks for that post!! I was banging my head against the walls with that blody plesk!

Samith
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Aug 12, 2009 12:24 pm
Location: Melbourne, Australia
Contact:

Re: Joomla and Plesk CAN co-exist !

Post by Samith » Thu Jul 04, 2013 4:24 am

Yes, definitly agree with FrankA3, this should be moved or duplicated on 2.5 forum as well.
Cheers!
Sam
SEO & SEM Management Specialist from Melbourne
www.seocity.com.au


Locked

Return to “Installation 1.5”