Problem with massive outdated site

Need help installing Joomla! 1.5? For all Joomla! 1.5 installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
dvharrison
Joomla! Intern
Joomla! Intern
Posts: 96
Joined: Sat Jul 05, 2008 7:10 pm

Problem with massive outdated site

Post by dvharrison » Tue Jan 15, 2013 7:08 am

Hi

I am in the process of upgrading a website that originated from 1.0 and has in the past been upgraded to 1.5.

Luckily for me I'm installing this on my XAMPP localhost as it is in one heck of a state! However, I am getting the following Fatal error:
Fatal error: Cannot re-assign auto-global variable _FILES in C:\xampp\xxxxx\xxxxxxx\components\com_fpss\fpss.class.php on line 345
Can anyone offer any insight into how I can resolve this? I am aware that this particular message is from the Front Page slideshow component.

I have a feeling this is going to be one of many problems with this site. :eek:

Thanks in advance.

User avatar
ranwilli
Joomla! Master
Joomla! Master
Posts: 19110
Joined: Sun Feb 19, 2006 6:47 pm
Location: Toledo, OH
Contact:

Re: Problem with massive outdated site

Post by ranwilli » Tue Jan 15, 2013 1:29 pm

disable the offending extension
Don't HACK the Joomla! core. Extend and Override.
Stay ON the update path.
http://harpervance.com

User avatar
dvharrison
Joomla! Intern
Joomla! Intern
Posts: 96
Joined: Sat Jul 05, 2008 7:10 pm

Re: Problem with massive outdated site

Post by dvharrison » Thu Feb 14, 2013 7:31 am

Thanks for your reply.

I cannot even access the administrator panel to disable anything.

I have gone to PHPmyadmin and disabled it from there (I assume its 1 - enables and 0 - disabled)?

User avatar
dvharrison
Joomla! Intern
Joomla! Intern
Posts: 96
Joined: Sat Jul 05, 2008 7:10 pm

Re: Problem with massive outdated site

Post by dvharrison » Sun Jul 14, 2013 8:38 am

Ok well 6 months down the line (Ican't explain) and I have disabled the extension in php my admin, but I now get the following error:

Code: Select all

Fatal error: Cannot re-assign auto-global variable _FILES in C:\xampp\htdocs\xxxxxxxx\components\com_fpss\fpss.class.php on line 345
I can also get the login screen for administrator, but as soon as I log in I get:

Code: Select all

Fatal error: Call to a member function Quote() on a non-object in C:\xampp\htdocs\xxxxxxx\administrator\components\com_jfusion\plugins\phpbb3\user.php on line 35
Please could anyone suggest what I need to do? Everyone seems to have the problem but no solution.

User avatar
dvharrison
Joomla! Intern
Joomla! Intern
Posts: 96
Joined: Sat Jul 05, 2008 7:10 pm

Re: Problem with massive outdated site

Post by dvharrison » Mon Jul 15, 2013 6:14 am

Ok. No one offered advice so instead I will tell everyone what I did to change this:

The front end issue, was solved by changing the line

Code: Select all

function uploadMedia(&$_FILES, $name, $option, $subfolder="", $width=200, $quality=80) {
To

Code: Select all

function uploadMedia($files, $name, $option, $subfolder="", $width=200, $quality=80) {
http://www.jfusion.org/index.php/docs/d ... =fix;login

http://stackoverflow.com/questions/1495 ... l-variable

The admin issue was resolved by running the following SQL query:

Code: Select all

UPDATE jos_plugins SET published = 1 WHERE element ='joomla' and folder = 'authentication';
UPDATE jos_plugins SET published = 1 WHERE element ='joomla' and folder = 'user';
UPDATE jos_plugins SET published = 0 WHERE element ='jfusion' and folder = 'authentication';
UPDATE jos_plugins SET published = 0 WHERE element ='jfusion' and folder = 'user';
I just hope this helps someone else. :pop

garlof
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 27, 2015 8:57 pm

Re: Problem with massive outdated site

Post by garlof » Fri Mar 27, 2015 8:59 pm

It helped me, 7 years after you posted it. i'm working on an even older site, THANK YOU A LOT

minhkien46
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Apr 03, 2015 7:18 am

Re: Problem with massive outdated site

Post by minhkien46 » Fri Apr 03, 2015 7:24 am

dvharrison wrote:Ok. No one offered advice so instead I will tell everyone what I did to change this:

The front end issue, was solved by changing the line

Code: Select all

function uploadMedia(&$_FILES, $name, $option, $subfolder="", $width=200, $quality=80) {
To

Code: Select all

function uploadMedia($files, $name, $option, $subfolder="", $width=200, $quality=80) {
http://www.jfusion.org/index.php/docs/d ... =fix;loginxvideos

http://stackoverflow.com/questions/1495 ... l-variable

The admin issue was resolved by running the following SQL query:

Code: Select all

UPDATE jos_plugins SET published = 1 WHERE element ='joomla' and folder = 'authentication';
UPDATE jos_plugins SET published = 1 WHERE element ='joomla' and folder = 'user';
UPDATE jos_plugins SET published = 0 WHERE element ='jfusion' and folder = 'authentication';
UPDATE jos_plugins SET published = 0 WHERE element ='jfusion' and folder = 'user';
I just hope this helps someone else. :pop

I also encountered a similar error, thank you very much


Locked

Return to “Installation 1.5”