Strict standards error when restoring Joomla 1.5 site

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
suchart_p
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Mar 27, 2018 3:07 am

Strict standards error when restoring Joomla 1.5 site

Post by suchart_p » Tue Mar 27, 2018 3:29 am

Hi, I've got the same problem when restoring joomla 1.5 (.jpa) on a new server. I know it is end of life but I need some information from that site back. Appreciated if anyone can help.

The jpa backed up from FreeBSD 6.2 Apache 2.2.4 MySQL 4.1.21 PhP 5.2.9
The new server is FreeBSD 11.1 Apache24 2.4.26 MySQL56-5.6.36 PhP56-5.6.31

Do I need to prepare the new site with all old version packages?
Last edited by toivo on Tue Mar 27, 2018 6:37 am, edited 1 time in total.
Reason: mod note: split from someone else's topic - please create your own topics in the future

SharkyKZ
Joomla! Ace
Joomla! Ace
Posts: 1258
Joined: Fri Jul 05, 2013 10:35 am
Location: Unknown

Re: Strict standards error when restoring Joomla 1.5 site

Post by SharkyKZ » Tue Mar 27, 2018 6:59 am

Joomla 1.5 is incompatible with PHP 5.6. You can disable or lower error reporting to remove the warnings but chances are you'll run into some fatal errors as well.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24870
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Strict standards error when restoring Joomla 1.5 site

Post by Per Yngve Berg » Tue Mar 27, 2018 11:37 am

Core 1.5.26 runs on php 5.6. Check each extension. Turn off error reprting.


Locked

Return to “Installation 1.5”