Joomla! 1.5 to 3 migration

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
dorsa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Jul 29, 2013 5:46 am

Joomla! 1.5 to 3 migration

Post by dorsa » Thu Aug 15, 2013 5:59 pm

Hey guys ive searched everywhere i can think of for a relatively simple solution for this :

K so the predicament is as follows:

I basically need to go from Joomla 1.5 to Joomla 2.5 or 3 (whichever is easier) i didnt build the site originally but i did google my template and it does say that it is compatible with the newer versions of joomla.

is there any free way to do this migration and what pitfalls am i going to have to be ready for?

i have looked into sp upgrade(paid) and JUpgrade is also paid?

what are my options? im hoping all my plugins will also be compatible as there are no complex plugins installed only gallery and the normal stuff...somebody must have had to do this before?

Thanks for the help in advance.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22277
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Joomla! 1.5 to 3 migration

Post by pe7er » Thu Aug 15, 2013 8:46 pm

dorsa wrote:I basically need to go from Joomla 1.5 to Joomla 2.5 or 3 (whichever is easier)
I would upgrade to 2.5 first. If it works ok, you can usually upgrade to 3 easily.
Documentation: http://docs.joomla.org/J2.5:Migrating_f ... Joomla_2.5
dorsa wrote:i didnt build the site originally but i did google my template and it does say that it is compatible with the newer versions of joomla.
I doubt that. In general Joomla 1.5 templates are not compatible with J2.5/3.
I suppose that the template developer has a Joomla 2.5/3 version that you need to buy.
dorsa wrote:is there any free way to do this migration and what pitfalls am i going to have to be ready for?
i have looked into sp upgrade(paid) and JUpgrade is also paid?
SPUpgrade = paid,
JUpgrade = free.
dorsa wrote:what are my options? im hoping all my plugins will also be compatible as there are no complex plugins installed only gallery and the normal stuff...somebody must have had to do this before?
Usually the developers of 3rd party extension have documentation on their website about how to migrate the content of their component to newer versions.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

dorsa
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Jul 29, 2013 5:46 am

Re: Joomla! 1.5 to 3 migration

Post by dorsa » Fri Aug 16, 2013 5:12 pm

Thanks pe7er This is all the info, I try to do a careful study.

almarjin
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Thu Nov 29, 2007 9:02 am
Location: Port Lux
Contact:

Re: Joomla! 1.5 to 3 migration

Post by almarjin » Tue Sep 17, 2013 12:23 pm

Hi pe7er,

I have successfully upgraded my Joomla 1.5.26 to Joomla 1.7 and installed the mtwmigrator-0.2.1.zip, but I'm having 404 error on Configuration and Start Migration! pages.

Thanks,

User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: Joomla! 1.5 to 3 migration

Post by dpacadmin » Tue Sep 17, 2013 2:13 pm

If I am not mistaken mtwmigrator is a Joomla 1.0 to 1.5 migrator, you need jUpgrade to go from 1.7 to 2.5

almarjin
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Thu Nov 29, 2007 9:02 am
Location: Port Lux
Contact:

Re: Joomla! 1.5 to 3 migration

Post by almarjin » Wed Sep 18, 2013 7:57 am

Hi dpacadmin,

I used jUpgrade to migrate from 1.5.26 to 1.7 and I tried it on the 1.7 version but I can't install it.

I'm having this error:
JInstaller: :Install: File does not exist D:\xampp\htdocs\projects\mysite\tmp\install_5239584be7ad9\com_jupgrade\install.php
Component Install: Could not copy PHP install file.

I tried com_jupgrade-1.2.1 and com_jupgrade-2.5.2 but both doesn't work.

I found some posts to copy the install.php from /admin but then after the installation I got this error when clicking the component link:
jupgrade\administrator\components\com_jupgrade\views\cpanel\view.html.ph

On Joomla 1.5.26 I can only see 1.6 and 1.7 option to migrate, there's no 2.5 or any other versions.

Thanks,

User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: Joomla! 1.5 to 3 migration

Post by dpacadmin » Wed Sep 18, 2013 4:36 pm

Go back to your 1.5 install and try with the latest version of jUpgrade, I'm pretty sure there is a 2.5 option there. You might also want to try posting in the 2.5 migrating and upgrading forum at this point.

almarjin
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Thu Nov 29, 2007 9:02 am
Location: Port Lux
Contact:

Re: Joomla! 1.5 to 3 migration

Post by almarjin » Thu Sep 19, 2013 7:28 am

Hi dpacadmin,

your suggestion works. I used this version of jUpgrade 'com_jupgrade-2.5.2.zip'. my site is now 2.5.

I encountered a problem not downloading the 2.5 files and when placing the package in the /tmp folder the jUpgrade can't read it. I manually uploaded the uncompressed files in the jUpgrade folder and in the jUpgrade parameter I skip check, download and decompress and the installation was successful.

I found the solution here(hans #131184): http://redcomponent.com/forum/92-jupgra ... -not-found

Thanks for the big help :)


Locked

Return to “Migrating and Upgrading to Joomla! 1.5”