After shop migration Zend Optimizer doesn't supported

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
1van
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Aug 31, 2013 5:21 pm

After shop migration Zend Optimizer doesn't supported

Post by 1van » Sat Aug 31, 2013 5:24 pm

Hello to all,

I had to migrate Joomla 1.5.25 with VirtueMart 1.1.6 stable to a new web server. Old web server configuration was:
Server version: Apache/2.2.3
Server built: Nov 14 2009 11:01:06

PHP 5.2.0-8+etch16 (cli) (built: Nov 24 2009 06:58:21)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
with the ionCube PHP Loader v3.1.34, Copyright (c) 2002-2009, by ionCube Ltd., and
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
with Suhosin v0.9.12, (C) Copyright 2006, by Hardened-PHP Project
and new one is:
Server version: Apache/2.2.22 (Debian)
Server built: Mar 4 2013 22:05:16

PHP 5.4.4-14+deb7u3 (cli) (built: Jul 17 2013 14:54:08)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies
I get error in Apache error log: "Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.".
And in user log:

"[Sat Aug 31 18:34:18 2013] [error] [client 78.30.172.88] PHP Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects 5 in /var/www/httpdocs/phpcipher.bin on line 0, referer: index.php?page=checkout.index&checkout_last_step=1&option=com_virtuemart&Itemid=69
"

In php.ini i add this:
zend_optimizer.optimization_level=1
zend_extension=/usr/lib/php5/ZendGuardLoader.so
zend_extension=/usr/lib/php5/ZendOptimizer.so
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.obfuscation_level_support=3
ZendOptimizer.so is copied from old server.

Can you give me some tip is it possible to resolve this? Or hove to migrate to another version?

Thanks,
Ivan

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11342
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: After shop migration Zend Optimizer doesn't supported

Post by toivo » Sun Sep 01, 2013 6:51 am

Which extension in the old server required Zend Optimizer? Resolving this problem will not be straightforward if the author of that extension does not have a version for Joomla 1.5 which supports Zend Guard Loader or ionCube Loader. Have you checked if the extension is available without proprietary obfuscated code, in other words under a GPL licence, for Joomla 2.5 or 3.1?
Toivo Talikka, Global Moderator

1van
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Aug 31, 2013 5:21 pm

Re: After shop migration Zend Optimizer doesn't supported

Post by 1van » Sun Sep 01, 2013 9:55 am

Thanks, it is a problem in cciDEAL extension.


Locked

Return to “Migrating and Upgrading to Joomla! 1.5”