Page 1 of 1

Will upgrading php affect Joomla 1.5 site?

Posted: Fri Sep 20, 2013 9:19 am
by dancingkazzaf
Hi,
A client of mine has an existing site built in Joomla 1.5 which we are going to rebuild in Joomla 3. To do this we need to migrate to a more up-to-date server on which we can run php version 5.3.1.
My question is:
If we upgrade php version from 5.2.17 to 5.3.1, will it affect the existing Joomla 1.5 site as the last thing I want is for that site to go down before we have built the new one.
Thanks.

Re: Will upgrading php affect Joomla 1.5 site?

Posted: Fri Sep 20, 2013 4:01 pm
by toivo
Going from PHP 5.2 to PHP 5.3 should not cause too many problems. Version 5.3 introduces E_DEPRECATED warning which you may have to suppress in the error reporting settings of PHP or Joomla.

One thing to watch out is non-GPL extensions which obfuscate the PHP source code using Zend Optimizer but Zend Optimizer is supported only up to 5.2.

You should start planning to migrate to Joomla 2.5 soon to improve security. Joomla 2.5 is a Long Term Support release, whereas there is no support or security updates available for 1.5.

Re: Will upgrading php affect Joomla 1.5 site?

Posted: Sat Sep 21, 2013 8:42 am
by dancingkazzaf
Thank you.
Yes we are planning to build a complete new site in Joomla 3 anyway, but didn't want the existing site to go down before it's ready.
Thanks.

Re: Will upgrading php affect Joomla 1.5 site?

Posted: Sun Sep 22, 2013 2:08 am
by Markstein
Just adding a note. Make sure you are running the latest version of Joomla 1.5 (which is 1.5.26 along with the recent security fix located at http://joomlacode.org/gf/project/joomla ... m_id=31626).

Versions earlier than 1.5.15 are not compatible with PHP 5.3.

Mark

Re: Will upgrading php affect Joomla 1.5 site?

Posted: Mon Sep 23, 2013 8:10 am
by dancingkazzaf
Thank you I will check.