Menu problems after migration

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
acrepc
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 01, 2014 12:47 am

Menu problems after migration

Post by acrepc » Thu May 01, 2014 1:01 am

I have migrated a joomla site to a new server. The migration was a copy and a database import due to the limited support from the previous host.
The problem is the main menu

The menu is visible and has all the links , when you click on a link I get 404 page not found (link goes to site.com/about_us instead of site.com/index.php?option=com_content&view=article&id=5.
The link is correct in the admin pages but incorrect when live.

I have tried un-publishing and re-publishing the menu to no avail.

Can someone please help me resolve this

Thanks in advance

 
User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: Menu problems after migration

Post by dpacadmin » Thu May 01, 2014 1:20 am

Looks like SEF was enabled, in the Global Configuration settings disable the SEF settings.
SEF link
site.com/about_us

no-SEF link
site.com/index.php?option=com_content&view=article&id=5

acrepc
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 01, 2014 12:47 am

Re: Menu problems after migration

Post by acrepc » Thu May 01, 2014 2:01 am

Awesome. Thank you.

 

Locked

Return to “Migrating and Upgrading to Joomla! 1.5”