Can't open webiste ERROR 500 Topic is solved

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
aspcsharp9
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 01, 2020 1:16 pm

Can't open webiste ERROR 500

Post by aspcsharp9 » Wed Apr 01, 2020 1:20 pm

Before some day all is working fine, today I get mysite.comm is currently unable to handle this request. HTTP ERROR 500

I use 1.5.26 Joomla version and php version is PHP 7.2 FastCGI

I'm try disable plugin over table set to published = 0 but nothing.
Also I'm try in configuration.php set var $error_reporting = 'maximum';

.htaccess file I don't see in root I'm create this file and copy/pase from htaccess.txt but nthing.

Any solution for this problem?

 
User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12426
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Can't open webiste ERROR 500

Post by toivo » Wed Apr 01, 2020 2:42 pm

Welcome to the forum!

Did your host upgrade PHP all of a sudden? Joomla 1.5 is not compatible with PHP 7. It will simply not run.

Your best option is to ask your host to downgrade PHP temporarily back to 5.3, if it is still possible. PHP 5.6 might also work but the level of error reporting in Joomla may have to be set to 'none'.

If you have a recent backup of the website from for example Akeeba Backup, you could install Wampserver on your Windows workstation and host a copy of your site on localhost for testing. It would then be possible to install an older version of PHP and test updateing the test site to Joomla 2.5 and 3.9.16, the current version.

The upgrade process has several steps, including an audit of the third party or custom extensions, finding their updates or replacements and identifying a template to be used. It is best done by an expert familiar with upgrading Joomla websites.
Toivo Talikka, Global Moderator

aspcsharp9
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 01, 2020 1:16 pm

Re: Can't open webiste ERROR 500

Post by aspcsharp9 » Wed Apr 01, 2020 3:38 pm

toivo wrote:
Wed Apr 01, 2020 2:42 pm
Welcome to the forum!

Did your host upgrade PHP all of a sudden? Joomla 1.5 is not compatible with PHP 7. It will simply not run.

Your best option is to ask your host to downgrade PHP temporarily back to 5.3, if it is still possible. PHP 5.6 might also work but the level of error reporting in Joomla may have to be set to 'none'.

If you have a recent backup of the website from for example Akeeba Backup, you could install Wampserver on your Windows workstation and host a copy of your site on localhost for testing. It would then be possible to install an older version of PHP and test updateing the test site to Joomla 2.5 and 3.9.16, the current version.

The upgrade process has several steps, including an audit of the third party or custom extensions, finding their updates or replacements and identifying a template to be used. It is best done by an expert familiar with upgrading Joomla websites.
Thanks for answer,
Did your host upgrade PHP all of a sudden?
I don't know. In attachment is my cpanel settings.

Can I change to PHP 5.6 FastCGI for this domain I use google gmail (connect google with gmail). Will I have any problems after the changes PHP version with my email?
You do not have the required permissions to view the files attached to this post.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12426
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Can't open webiste ERROR 500

Post by toivo » Wed Apr 01, 2020 3:57 pm

aspcsharp9 wrote:Can I change to PHP 5.6 FastCGI for this domain
Probably, if it is available in the options. It would be useful to know which PHP version was previously in use.

aspcsharp9 wrote:I use google gmail (connect google with gmail). Will I have any problems after the changes PHP version with my email?
Difficult to tell, but if Joomla was using Gmail as its SMTP server before, it may work. Only testing will tell but it is likely that a fair amount of troubleshooting will need to be done.

This tutorial shows how to configure Joomla to use Gmail SMTP server: https://docs.joomla.org/How_do_I_use_Gm ... _server%3F.

However, I'd recommend that you look at the options to upgrade from the End Of Life (EOL) version of Joomla to a currently supported version. If you need expert assistance in planning the upgrade, post your requirements to the Professional Development Services forum so that interested developers can contact you.
Toivo Talikka, Global Moderator

aspcsharp9
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 01, 2020 1:16 pm

Re: Can't open webiste ERROR 500

Post by aspcsharp9 » Wed Apr 01, 2020 4:25 pm

Code: Select all

Difficult to tell, but if Joomla was using Gmail as its SMTP server before, it may work. Only testing will tell but it is likely that a fair amount of troubleshooting will need to be done.
On website I don't have any contact form for sending email this is simple old site. Only my domain is related to google gmail. Hopefully changing the php version won't problem with sending and recive emails?

aspcsharp9
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 01, 2020 1:16 pm

Re: Can't open webiste ERROR 500

Post by aspcsharp9 » Wed Apr 01, 2020 7:04 pm

I’m add in .httaccess below line and site is now ONLINE

AddHandler fcgid-script .php
FCGIWrapper “/dh/cgi-system/php56.cgi” .php

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2182
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Can't open webiste ERROR 500

Post by JAVesey » Wed Apr 08, 2020 3:11 pm

aspcsharp9 wrote:
Wed Apr 01, 2020 7:04 pm
I’m add in .httaccess below line and site is now ONLINE

AddHandler fcgid-script .php
FCGIWrapper “/dh/cgi-system/php56.cgi” .php
This is good news but you're only delaying the day when you have to migrate your site from the current version. PHP5.6 has been end of life for quite a while, likewise earlier versions of PHP7.

The sooner you do it the easier it will be.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.19 and PHP7.3.x

 

Post Reply

Return to “Administration 1.5”