Calendar.setup: Nothing to setup ERROR when submitting article from front end

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
IceBrain
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Jun 13, 2011 7:57 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by IceBrain » Tue Jan 01, 2013 8:55 pm

yitwail wrote:Well, this will probably fix everyone's problem. It requires editing a core file,
libraries/joomla/html/html.php

in the version I'm using, it's at line 290, inside function calendar

Code: Select all

$document->addScriptDeclaration('window.addEvent(\'domready\', function() {Calendar.setup({
this needs to be changed to:

Code: Select all

$document->addScriptDeclaration('window.addEvent(\'load\', function() {Calendar.setup({
I have a similar problem but this time its in the home page of JomSocial just a blank page after the error message

The above fix didn't work Any ideas?

Ice

It's well known that the domready event does not work reliably in any version of Internet Explorer. It's very disillusioning that a core joomla file attempts to use that event.

If this doesn't fix your problem, you have a component/module/plugin that tries to display a calendar this way, so look for domready & change it to load

 
yumpa
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Mar 15, 2007 2:07 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by yumpa » Sun Jan 13, 2013 8:39 pm

Hi. I was getting this JS error at MailChimp component at Joomla 1.5 while importing the users. I found an answer here:

http://www.joomlamailer.com/topic.html?id=334
Another user had the same problem. In his case he didn't have a list set up in MailChimp and as soon as he did this error was resolved. If you don't have a list set up please login to mailchimp.com and create one (Lists have to be created in MailChimp directly because it is not supported via the API).
Hope it helps somebody.

pepemj
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Thu Nov 13, 2008 3:42 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by pepemj » Wed Feb 13, 2013 5:19 pm

Hello, I solved this problem in my site http://www.lepoint.com.pe with that suggestion http://network.convergenceservices.in/f ... cialq.html.

Thanks :D
Pp

Cydonian
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jan 12, 2009 12:43 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by Cydonian » Wed May 29, 2013 3:56 pm

mavex wrote:I had the same problem. Solution is pretty simple go into User-Profile plugins settings and change settings for Date of Birth to 'Disabled'.

Not sure if that is a solution for anyone, but it worked for me.
I had the same problem when a user clicks on "register" button on my web site (Joomla 2.5), it gave an error saying "Calendar.setup: Nothing to setup (no fields found). Please check your code"

But after doing mavex's fix, error disappeared :D
Here is the detailed info:
Login to your web site's admin panel, click Extensions => Plug-in Manager
Find User-Profile plugin and click on it and you will see settings for that plugin, disable " Date of Birth: " and click "Save & Close"! That is all! Good luck!

spk063
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Aug 20, 2013 1:28 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by spk063 » Fri Oct 03, 2014 11:17 am

I have solved this error. It's due to the Missing of DOB field in the Registration form or Missing of field that is used to select the date using a calendar. :D If you use K2, you will get this error..

frostybot
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jul 24, 2015 6:55 pm

Re: Calendar.setup: Nothing to setup ERROR when submitting

Post by frostybot » Fri Jul 24, 2015 7:04 pm

I had this same problem today.

Setup:
* Joomla 3.x, 3.4.3
* Module: Articles Placed Anywhere 1.1.6
* Template: custom from scratch

I was getting the calendar.setup error because I didn't have the <jdoc:include type="component" /> on the page (as I was using the Article placed anywhere module).

To fix this I created an "edit" page within my template index.php file. Something like this:

Code: Select all

 
<?php
$layout   = $app->input->getCmd('layout', '');
 if ( $layout == 'edit') { ?> 
        <div class="container"><jdoc:include type="component" /></div>
    <?php } else { ?>
<!-- existing code with no component -->
I hope this helps someone out.

 

Locked

Return to “Administration 1.5”