JFTP::store: Bad response Warning! - Failed to move file

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by matchdesigns » Fri Jul 22, 2011 7:40 pm

Hi All what worked for me was putting the www. in the configuration.php file see below:

var $ftp_host = 'www.yourdomain.com';

 
punktea
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Sep 07, 2011 11:45 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by punktea » Thu Sep 08, 2011 12:51 am

I finally figured out how to resolve my problem on Joomla 1.5.23. This link http://docs.joomla.org/Cannot_save_Glob ... on_changes provides the background for my solution.

JFTP::store: Bad response means Joomla has tried to use FTP update a file, in this case configuration.php, and the update is unsuccessful. There are 2 things that can go wrong:
- ftp host or username or password is wrong and Joomla cannot login using ftp
- the path to configuration.php is wrong and Joomla cannot find the file configuration.php

To fix, use ftp or cpanel to download configuration.php to your PC, edit the following fields then upload back:
var $ftp_enable = '1':
var $ftp_host = '<hostname of your website>';
var $ftp_port = '21';
var $ftp_user = '<ftp username>';
var $ftp_pass = '<ftp password>';
var $ftp_root = '<path to configuration.php relative to ftp account path ';

Some explanation:
var $ftp_enable = '1':
1. first, find out the ownership of file configuration.php
2. if it is nobody or apache or www-data, you must set $ftp_enable to '0' . You have now told Joomla to
use php to update configuration.php instead of ftp. In this mode, the owner of file configuration.php
must match the owner of web server process, which is normally nobody or apache on a linux host.
If $ftp_enable is set to '0', you no longer need to fill out the rest of ftp parameters
3. if it is your ftp username, you must set $ftp_enable to '1'
4. if you have root access, you can configure either way but update via ftp is the recommended way

var $ftp_root = 'relative path to configuration.php':
In cpanel, use file manager and browse to configuration.php. The path name in upper left corner is
the relative path, usually public_html. if you use other means to browse to configuration.php, just
make sure that:
<absolute path to configuration.php> = <ftp account base path> + <relative path set in var $ftp_root>
As an example for my case, my whole joomla directory is uploaded to /home/punktea/public_html/web,
the base directory is /home/punktea when I login using ftp so I set var $ftp_root to 'public_html/web

aaanativearts
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 203
Joined: Fri Aug 04, 2006 12:38 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by aaanativearts » Sun Oct 23, 2011 2:20 am

iamthezio wrote:Have any of you changed browsers when uploading?

I get all these errors when using Safari and Firefox.

But no errors when using IE.

Makes me wonder.

Steve
I couldn't install Joomla 1.7.2 with IE9 or Firefox. It would go to the first page where you set the language, and then just hang. But it installed fine in Google Chrome. But now I have the ownership problem, even though I can chmod files via ftp. They show the correct permissions, but still I get
JFTP: :store: Bad response
Warning: Failed to move file!
JFTP: :mkdir: Bad response
JFTP: :chmod: Bad response
Unable to create destination
when I try to install contribs with the Extension Manager. I installed one template using the upload the files, then Discover and Install method, but now it won't do that for any other contribs, either.

I created a new configuration.php file and uploaded it. Did not fix it for me.

aaanativearts
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 203
Joined: Fri Aug 04, 2006 12:38 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by aaanativearts » Sun Oct 23, 2011 2:29 am

punktea wrote: the base directory is /home/punktea when I login using ftp so I set var $ftp_root to 'public_html/web
Thanks, that solved it for me. I had my path written as 'public_html/web/ When I removed the trailing slash, it then worked as it should.

Darkmandosa
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Mar 11, 2012 9:20 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by Darkmandosa » Sun Mar 11, 2012 9:29 pm

Ok guys. I got already 13 hours of reading each of the clues that each of you posted in here.

I really can't fix it. I can't even upload and install the catalyst for 2.5 joomla template because now it's giving me error:
Unable to write entry
However i made the whole ftp folder called httpdocs with all of the folders from in it as 777 and still doesn't work.


Note: "I am a noob when I talk about php things." I tried all of the infos posted in here, but maybe i really miss something.

I tried in this way also:
1. I unzipped the catalyst template and uploaded in /tmp folder.
2. I tried to Install it from: "Install from Directory"
but its appearing this error and i thought its cuze it can't be read. And i simply gaved 777 for permissions and still this error:
Copy failed
JInstaller: :Install: Failed to copy file /var/www/vhosts/war0nline.net/httpdocs/httpdocs/Joomla_2.5.2-Stable-Full_Package/tmp/yoo_catalyst_j25/checksums to /var/www/vhosts/war0nline.net/httpdocs/httpdocs/Joomla_2.5.2-Stable-Full_Package/templates/yoo_catalyst/checksums
Anyone please help..:|.

Thanks in advance, Mike.

By the way, i tried also with Internet explorer to upload and install and still the same error:
Unable to write entry

When I enable ftp which means '1' in configuration.php, and trying to Upload&Install i get these errors using both firefox and ie.
JFTP: :store: Bad response
Warning: Failed to move file!
JFTP: :mkdir: Bad response
JFTP: :chmod: Bad response
Unable to create destination

After 2 hours of hoping that some1 would read my issue and trying to help me with this kind of problem, and playing around a bit thru ftp, I found only this errors now:
JFolder::create: Infinite loop detected
Warning: Failed to move file!
Thanks in advance.

Darkmandosa
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Mar 11, 2012 9:20 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by Darkmandosa » Mon Mar 12, 2012 8:39 pm

Ok never mind. I fixed it alone.

It was the PHP "safe_mode" on. And i had to turn off by calling my providers.

Now I got this problem and I hope that you could advice me on how to solve it.
It appears to be a joomla issue.

This is my website http://www.war0nline.net/beta and In the Forum, when appears the subcategories, Try to press one of those.

Appears this error and no1 spoke about it actually.

Code: Select all

Web link not found
Can some1 please advice me about this problem?

Thanks in advance.

JimRockford
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Mon Jun 04, 2012 1:21 am

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by JimRockford » Sun Jun 17, 2012 2:43 am

I realize this thread is a little old, but I just ran across this error when I was trying to make changes to Site>Global Configuration in Joomla 2.5. In my case it was because the configuration.php file was set to read only (444). Using the FTP client, I changed the settings to 777, made my changes, and then set it back to 444.

Hopefully this will help someone else.

Thanks for all the great posts.

JimRockford
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Mon Jun 04, 2012 1:21 am

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by JimRockford » Fri Jul 06, 2012 8:21 pm

[spam] wrote:JimRockford thanks its work for me

thank you very much

Awesome! I'm glad I was able to help.

Thanks for letting me know. :)

Eric West
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jul 17, 2012 11:49 am
Location: Georgewest,TX
Contact:

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by Eric West » Thu Aug 02, 2012 12:27 pm

I also was having this issue, I was able to fix the issue by enabling the FTP layer and inputting the required information.

ayero
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Aug 29, 2012 11:27 am

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by ayero » Wed Aug 29, 2012 11:29 am

public $ftp_enable = '0'; is what saved me...

rupertj
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri May 17, 2013 10:37 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by rupertj » Fri May 17, 2013 10:39 pm

Thanks a lot tbm2020!

rupertj
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri May 17, 2013 10:37 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by rupertj » Fri May 17, 2013 10:43 pm

public $ftp_enable = '0' it was this simple. Thank you.

konnekttek
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Mar 19, 2013 3:28 pm

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by konnekttek » Thu Aug 29, 2013 8:13 pm

ayero wrote:public $ftp_enable = '0'; is what saved me...
This worked for me, too.

bsyap86
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Mar 06, 2014 1:42 am
Location: Malaysia

Re: JFTP::store: Bad response Warning! - Failed to move fil

Post by bsyap86 » Wed Mar 12, 2014 10:56 am

Hi Everyone

“JFTP::write: Bad response” usually occurred when Joomla! is working in FTP Enabled mode. This article, FTP Layer-Hints is very useful if you wish to run Joomla! with FTP enabled. If you still getting JFTP error message after implement above, please make sure the FTP details is filled-in correctly, especially the

Code: Select all

public $ftp_root = 
, it can be tricky if you install Joomla in subdirectory. If you still getting the same error message, you may want to consider other solutions.

Should you have any error saving the changes in global configuration after clicked the save button, please check on Cannot save global configuration. I have this problem and i cannot solve it. Temporary, i have to manually change the configuration.php and re-upload to server which is quite tedious for me. I have posted a topic regard it. If anyone has similar problem and managed to solve it, please post the solution in above topic. Any help would be appreciated.

Of course, turn off FTP layer should always solve above error because now Joomla! is running with web server process identity, not FTP login any more.
Go to /configuration.php, find

Code: Select all

public $ftp_enable = '1';
and change it to

Code: Select all

public $ftp_enable = '0';
save and upload the file to your server by using any ftp program, or you may upload it using cpanel.
OR
you may change it from Administrator back-end
Adminstrator->Global Configuration->Server[Tab]->FTP Settings[Group]->Check OFF
"Sharing makes you bigger that you are.
The more you pour out, the more life will be able to pour in."

 

Locked

Return to “Administration 1.5”