# JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
mahogg
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Apr 04, 2009 11:38 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by mahogg » Sat Apr 04, 2009 11:42 pm

I had this same problem. I fixed it by specifying the full path of my temp directory instead of "./tmp". I use a Windows hosting provider and I noticed that all the zip files that I was uploading were showing up in a higher level tmp directory, outside of the Joomla installation. Once I corrected this, everything worked fine.

BTW, I am running on 1.5.8

 
mcottier
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sun Sep 28, 2008 2:43 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by mcottier » Wed May 06, 2009 9:09 pm

Correcting the temp directory worked for me also. I installed the website on another server, then transferred it and forgot to change that one thing. Also, changing the root directory and other stuff you guys were talking about can be done from the admin backend, there is no need to mess around with the file.
Signature rules: Literal URLs only - http://forum.joomla.org/viewtopic.php?f=8&t=65

Goanna
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Feb 10, 2006 12:45 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by Goanna » Wed May 20, 2009 5:38 pm

I have tried every solution listed in this thread and others and I still cannot get the FTP layer to work properly. When I first installed joomla 1.5.x this worked fine, then about two weeks later it just stopped working and I began getting the JFTP errors.
  • I have created an FTP user that has access to the same directory that Joomla is in.
  • I had my hosting company grant file access to that user for all files and I don't use the default login anymore as to not create ownership conflicts.
  • I set the FTP directory to "/" since the user has access only to the folder Joomla is in (Howver, to make sure I did try the full FTP path as well as just the folder it's in, nothing worked)
  • All of the FTP connection information is correct. I have checked it repeatedly.
  • TMP and Log directories are correctly specified in the configuration file.
  • I tried manually editing the configuration file and setting FTP to "0", that didn't work either.
What else could this be? I really dont want to have to make everything CHMOD 777 and go back to the old way, as I have already had that lead to attacks on older J 1.0 sites.

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Wed May 20, 2009 5:54 pm

Sounds frustrating. All I can say is check everything over and over. Start with the tmp directory because I have a suspicion that it is the root of this whole issue.

The few times this issue has arisen for me, I've tried multiple paths for the tmp directory, some of which I could swear were the right ones, but they weren't.

riccardosl
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Tue Jan 06, 2009 7:28 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by riccardosl » Wed May 20, 2009 10:25 pm

How can i find the exact TMP directory path? :eek:

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Wed May 20, 2009 10:59 pm

The tmp path could really vary from server to server.

Most of the time it's ok with:

/tmp

But sometimes it's different, like:

/client/home/domainname/docs/tmp


Sometimes you can find the right path by going to the "help" tab in the joomla backend, and clicking the "php information" tab. Once, for me it was with a variable called "path_translated" but that variable doesn't appear to be on all servers. Do a search for the word "path" and see if any promising looking paths turn up - try them all.

Probably the best way would be to email your host and ask them the absolute path for your website. Try different combinations of the absolute path.

Goanna
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri Feb 10, 2006 12:45 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by Goanna » Thu May 21, 2009 1:00 pm

verticalgrain wrote:The tmp path could really vary from server to server.

Most of the time it's ok with:

/tmp

But sometimes it's different, like:

/client/home/domainname/docs/tmp


Sometimes you can find the right path by going to the "help" tab in the joomla backend, and clicking the "php information" tab. Once, for me it was with a variable called "path_translated" but that variable doesn't appear to be on all servers. Do a search for the word "path" and see if any promising looking paths turn up - try them all.

Probably the best way would be to email your host and ask them the absolute path for your website. Try different combinations of the absolute path.
I had the full path, which I know is the correct path to my server, but I tried just /tmp and /logs and now I dont get the JFTP errors, however I am getting the message "Unable to find install package" now after I attempt to upload any new extension.

Here's what I have now,

Code: Select all

var $ftp_root = '/demo';
var $log_path = '/logs';
var $tmp_path = '/tmp';
I also tried leaving ftp_root as just '/' or blank, and the same error results. But, it may still be a step in the right direction as the JFTP errors are gone now.

The FTP username that Joomla is using only has access to the demo folder, nothing below it, so putting the full path shouldn't be necessary.

When I login with the same username via an FTP program, the root path shown int he explorer bar is just "/".

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Thu May 21, 2009 3:53 pm

You're getting closer! Awesome!

That's strange about the package install. It should work even without ftp, as most packages can install without the ftp layer turned on (although it's a better idea to do it with ftp layer turned on if you can, since it usually ensures permissions are set properly).

I'm sure you tried a number of combinations for the ftp root path. Have you tried just / ? On the project I'm currently working on the ftp root path is /docs/ (the full root path is /client/home/domainname/docs/ ).

I wonder if it could also be your ftp username. I've noticed that on some servers Joomla accepts the username like this:

username

but on other servers it accepts it only accepts it like this:

username@domain.com

So in summary, keep trying multiple options - eventually one of them will work for you.

riccardosl
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Tue Jan 06, 2009 7:28 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by riccardosl » Tue May 26, 2009 10:39 am

I try multiple paths like /tmp , full server path etc and nothing works with FTP Layer Enable.

I also notice on my PHP info... SAFE MODE Local Value= OFF Master Value= ON

Can be a problem "Master Value" option? :eek:

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Tue May 26, 2009 1:59 pm

Hmmmm I don't know what that is. I wouldn't think it would be a problem but who knows?

deleted user

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by deleted user » Tue May 26, 2009 8:42 pm

Every time there are problems with the Joomla installer, there are a few common causes, and a few common solutions. More than one of these may apply at the same time:

1) Standard installation by HTTP fails because:

1A) You have the tmp directory path wrong in configuration.php.

SOLUTION: use the correct path. [Take special care if you are using virtualized hosting such as media temple where the usual ruls do not apply. MediaTemple has Joomla covered well in its knowledgebase and you can find relevant discussion of setting up with them in the forum here.]

1B) The package you are trying to upload is damaged/not formed properly, or it is not compatible with Joomla 1.5 native or possibly legacy mode if you have it turned on. Some packages that would install before Joomla 1.5.10 will not install after 1.5.10 without correcting the way their internal installation files and folders are organized.

SOLUTION: fix or get corrected file package

2) Installation via FTP layer fails because:

2A) you have the FTP path and/or other FTP settings wrong in configuration.php

SOLUTION: use the correct path/settings

2B) you have shared hosting and PHP is run as an Apache module (mod_php) so that Joomla as an Apache process operates under a different owner group than your root user and any FTP accounts it has.

SOLUTION: ask your host to examine the problem and see if it is possible to have your account changed or moved to run su_php or use CGI or FCGI. (Search these forums for those terms and search Google for them to learn a bit more.) If you host insists the cure is for you to open all read/write permissions to the world (CHMOD 777), tell your host to reconsider and send them links to relevant posts here and elsewhere about the performance and security benefits of doing things right. if they will not change, tell them to get bent and move to a host that supports Joomla and other PHP applications properly. Then give the old host a detailed review at numerous hosting sites and use other such means to help other people avoid this host when they want to do something other than play with frontpage.

jamus78
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Jun 18, 2008 8:17 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by jamus78 » Wed Jun 10, 2009 10:11 am

Just a quick note - in my case I was missing the trailing slash at the end of the path "/"
Added it and everything was good.

User avatar
carsten888
Joomla! Ace
Joomla! Ace
Posts: 1224
Joined: Sat Feb 11, 2006 8:32 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by carsten888 » Fri Jun 12, 2009 12:15 pm

I read this whole thread, tried everthing in this tread and still get :


* JFTP::login: Unable to login
* JFTP::write: Unable to use passive mode

when trying to save the config.
login details are correct cos they work fine in filezilla.

another thing:
Why do all those directories need to writeable for the ftp-layer to work? Ftp itself does not use those rights.
Isn't the whole idea of the ftp-layer to be able to install/uninstall stuff no matter how directory rights, safe mode and timeouts are set?
http://www.pages-and-items.com my extensions:
User-Private-Page, Redirect-on-Login, Admin-Help-Pages, Dynamic-Menu-Links, Admin-Menu-Manager, plugin load module in article, plugin pure css tooltip and more...

lydianp18
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 21, 2009 4:52 am

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by lydianp18 » Wed Aug 05, 2009 8:39 pm

I had the same problem installing components/modules/plugins/templates - however my solution was a lot easier... For some reason on the original install the PATH TO TEMP FILE that Joomla saved was completely screwy. I corrected that and that solved all my problems.

To check your path to temp folder go to GLOBAL CONFIGURATION > SERVER>

Normally you can find the path to your web directory either in your hosting control panel, in your welcome letter from your host, or by contacting them. Just add /tmp to the end of it to make it the path to your temp file (if you have Joomla installed in a sub-directory it would be /joomla_dir/tmp (joomla_dir would be your joomla directory name).

Lydia

User avatar
chuckl
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat Aug 30, 2008 12:02 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by chuckl » Tue Sep 01, 2009 10:30 pm

Like so many before me, this issue has become a huge source of frustration. I have scoured the forums and many external forums and have not been able to resolve this issue. Originally when I looked at the Admin:Help:System Info:Directory Permissions all directories were writable with the exception of the logs and tmp directories. After following a previous suggestion and using a script that used the getcwd() function, I changed my configuration.php file to reflect the results, that is previously I had the paths set to:

/www.example.com/web/content/tmp
/www.example.com/web/content/logs

afterwords I changed them to:

/mnt/xyz03/12345/23344/www.example/web/content/tmp
/mnt/xyz03/12345/23344/www.example/web/content/tmp

and the log and tmp files now were writable.

But alas, I still cannot install extensions, components, etc. I continue to get the following errors or something similar.

* JFTP::mkdir: Bad response
* JFTP::write: Bad response
* Unable to write entry

I have made a gazillion changes and tried virtually everything I can think of including using a script to change all of the directories to 777 permissions which is of course a bad thing. I am really tired of messing with this but really have no recourse but to continue to try to get this resolved.

I find it very disconcerting that (from looking at posting dates) this problem has been around for nearly five years, perhaps more, and to date, no one has truly come up with a resolution that will work for everyone. Here are a few points that need to be addressed:

1. Not everyone has the capability or permissions to modify php or apache configurations,
2. Not everyone has access to cPanel or anything like it,
3. Not everyone has the choice of who is hosting their site,
4. Often there is very limited information as to the actual environment that Joomla! is installed on,
5. Most of the suggested solutions are:
a. limited to specific environments and platforms,
b. work for some subset of users but not everyone,
c. vary wildly without any apparent true understanding of what the problem really is,
d. are not feasible given the limitations of the user's environment, and
e. often are far to general to be useful at all,
6. I haven't found any (perhaps I have missed a few) responses from the Joomla! development
team that offer any indication that they believe this is a problem that needs to be addressed
(after all it has been around for over five years now.)
7. This is a huge problem, period. It needs a concrete and sustainable solution.

In some instances, I have been able to actually add extensions by extracting them locally and then ftping them to the site, and manually installing them. This works (although it is not my first choice) for simple modules, plugins, etc. but for anything complex is far too difficult to attempt.

I guess this is a simple plea for help from the Joomla! development team or anyone else for that matter to work on a solution that is more universal and less complicated than what now exists.
Chuck

deleted user

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by deleted user » Tue Sep 01, 2009 11:29 pm

You're using shared hosting and paying under $10/mo for it, yes?

User avatar
brad
Joomla! Master
Joomla! Master
Posts: 13419
Joined: Fri Aug 12, 2005 12:38 am
Location: Sydney - Australia
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by brad » Tue Sep 01, 2009 11:38 pm

Are you sure you even need to have the FTP layer enabled?
Brad Baker
https://xyzulu.hosting
https://www.joomlatutorials.com <-- Joomla Help & Tutorials

deleted user

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by deleted user » Wed Sep 02, 2009 2:15 am

Good point from Brad.

On the other stuff:

If you don't have even .htaccess control, let alone php.ini, cpanel, etc. it's bad hosting even for shared hosting. The middle man not giving you that control is a huge problem. If you don't know what to do with that control if you had it, then you are the problem. But that's OK, because you can control you--learn and get control, or walk away.

How can you possibly not have control of who is hosting YOUR site?

I think the question is, can you get control, are you motivated to learn what need, and then will that be enough? If not, you'll have to ship out to another host.

Want to know the environment: phpinfo. Available through the Joomla administrator backend.

These problems really sound like they are on your end, or more that you don't have control over your end. That is on you, and people here can give you advice on how to deal with those problems, but please don't blame Joomla and the dev team for not making a complex application that will run itself anywhere in the most unknown godawful hosting environment without someone with some basic knowledge and most importantly ACCESS setting it up.

I have seen and used Joomla and similar apps on some pretty cheap shared hosts, and it is possible. Say what you will about Fantastico installs, but if a host has Joomla in there, it is a good sign things will work as far as installing Joomla and adding extensions. The rest is a matter of assessing the host environment and locking down the stuff that needs locking down. If you get that far, we can help you. In fact, I wrote a long article just for you (and others in your position) to accomplish just that.

The problems you are having are ones I have seen on hosts where they are running mod_php (php as an apache module) with whacked out permissions, everything wide open, or maybe safe mode on. That is just insurmountably BAD, and yes, some people have committed to BAD as their host and you have to work with it.

But if it's YOUR site, why can't you walk away and go somewhere else? If it is a cpanel system a lot of other hosts using cpanel will migrate you lock stock and barrel for free if you buy in with them, and some will credit you the time remaining on the existing account.

That said, as of this year I am thinking that shared hosting (or many shared hosting providers) may have reached the end of the line for any advanced SQL apps or any users with expectations for any kind of security and performance quality above F+. (0%-59% or "1" on the international baccalaureate grading system. #FAIL!!!) It is coming down, more and more, to getting what you pay for.

PM me if you want to get technical or ask "dumb" questions (none are dumb if it means you learn something) or get some frank hosting recommendations. Or check the threads on hosting here. Lots of people can level with you about what works.

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 5:08 pm

Hi everyone, I am still having this problem after re-installing. The annoying thing is my Joomla setup works for one website but not on another.

I have tried most of what has been posted but I am unable to get the output from this:
<?php
//Gets the document root
$root = getenv("DOCUMENT_ROOT") ;
Echo $root;
?>

Though I can when using:
<?php
echo getcwd();
?>

Which gives me this:
e:\domains\<my_domain>.co.uk\wwwroot

Is that right? Anyway, added to the config file for the root but still no joy.

When reviewing the permissions directories:
Log Directory ($log_path) /var/logs/
Temp Directory ($tmp_path) /tmp/

Both are unwriteable. I try and change to 777 which seems to go through via cuteftp without error but this does not change the status in Joomla.

If I try and install a mod the files can be found in the /tmp directory so surely it can be seen OK?

On my site the Joomla install is in wwwroot which is the home dir of the FTP account so do I leave as '/' or '/wwwroot' ? Either way does not work.

My config file supplied below with obvious bits < ommitted >

I can give admin where necessary. Ta muchly (thanx).

<?php
class JConfig {
var $offline = '0';
var $editor = 'tinymce';
var $list_limit = '20';
var $helpurl = 'http://help.joomla.org';
var $debug = '0';
var $debug_lang = '0';
var $sef = '0';
var $sef_rewrite = '0';
var $sef_suffix = '1';
var $feed_limit = '10';
var $feed_email = 'author';
var $secret = '<**********>';
var $gzip = '0';
var $error_reporting = '-1';
var $xmlrpc_server = '1';
var $log_path = '/var/logs';
var $tmp_path = '/tmp';
var $live_site = '';
var $force_ssl = '0';
var $offset = '0';
var $caching = '0';
var $cachetime = '15';
var $cache_handler = 'file';
var $memcache_settings = array();
var $ftp_enable = '1';
var $ftp_host = '<xxx.xxx.xxx.xxx>';
var $ftp_port = '21';
var $ftp_user = '<ftp_admin_acct>';
var $ftp_pass = '<password>';
var $ftp_root = '/';
var $dbtype = 'mysql';
var $host = '<xxx.xxx.xxx.xxx>';
var $user = '<user_acct>';
var $db = '<db_name>';
var $dbprefix = 'jos_';
var $mailer = 'mail';
var $mailfrom = <email_addy>;
var $fromname = '<my_name>';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '0';
var $smtpsecure = 'none';
var $smtpport = '25';
var $smtpuser = '';
var $smtppass = '';
var $smtphost = 'localhost';
var $MetaAuthor = '1';
var $MetaTitle = '1';
var $lifetime = '15';
var $session_handler = 'database';
var $password = '<password>';
var $sitename = '<stuff>';
var $MetaDesc = '<stuff>';
var $MetaKeys = '<stuff>';
var $offline_message = 'This site is down for maintenance. Please check back again soon.';
}
?>

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Fri Sep 04, 2009 5:56 pm

Sounds like you're on the right path Davegas, keep plugging away. For me the problem was finally fixed after I finally set the right path for the tmp directory. I'd advise making a list of 15 possible paths for that directory, such as:

e:\domains\<my_domain>.co.uk\wwwroot
e:\domains\<my_domain>.co.uk\wwwroot\
<my_domain>.co.uk\wwwroot

etc. and try using all of these paths as the tmp directory. Some of them might not seem logical but try them anyway.

I'm sure you've tried a lot of these already but maybe you will get lucky and the "proper" file path has not been tried yet.

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 6:54 pm

Thanks for the reply vg.

Yeah, went through everything I can think of. Leaving the trailing backslash kills it with a php error on line 33.

Still no joy....but what gets me is that the files are placed in the tmp folder so the error seems to be when processing them out into the correct locations. :(

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 7:11 pm

Here's a new one:

JFTP::write: Unable to use passive mode
Unable to write entry

After changing the logs & tmp. Have left the root empty.

Let's see what I can find about that EM... :eek:

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Fri Sep 04, 2009 7:11 pm

I think that was happening for me too when I had this problem - the files were appearing in the tmp folder but was still getting the error. Keep plugging away and keep us posted.

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 9:56 pm

Grrrrrrrr. Well been on this for hours now VG. Soon time to hit the sack as been on this most of the day.

var $log_path = 'e:\domains\<my_domain>.co.uk\wwwroot\logs';
var $tmp_path = 'e:\domains\<my_domain>..co.uk\wwwroot\tmp';
and
var $ftp_root = 'e:\domains\<my_domain>.co.uk\wwwroot';

Atfer this I look at the folder permission under help and everything is writeable (first time tonight) so Iwas like 'cool, this is going to work' but alas, it was not to be.

Tried the install again of the mod and the following is what I am getting the following now:

JFTP::store: Bad response
Warning! Failed to move file.
JFTP::mkdir: Bad response
Unable to create destination

This is with the latest version of Joomla, details:
PHP Built on: Windows NT HTTP4 5.2 build 3790
Database Version: 5.0.24a-community-nt
Database Collation: utf8_general_ci
PHP Version: 5.1.6
Web Server: Microsoft-IIS/6.0
Web Server to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.5.14 Stable [ Wojmamni Ama Naiki ] 30-July-2009 23:00 GMT
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET CLR 1.1.4322)

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Fri Sep 04, 2009 10:39 pm

Glad the permissions are sorted - I think you're getting closer.

I just checked the site that I had had this same probem on. The tmp path that finally worked on it is:

E:/domainname.ca/directoryname/tmp

Have you tried capitalizing the E and making the slashes forward slashes instead of backslashes?

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 11:03 pm

Nope - still not working. With the back slashes as forward slashes it knocks out the permission.

I think it is definately some sort of ftp permission problem. It's like the account used cannot create elsewhere through the site (but I know it can as it is the account used for all admin icluding the install).

Just resetting permissions on ALL folders throughout the site.

Failing that I may need to look for another host but using a linux server as I have more success with them as opposed to Windows (spit) (says an MCSE NT4 & 2000) :-)

Cheers for broadening my mind so far vg.

Dave

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Fri Sep 04, 2009 11:38 pm

I'd be curious to know if anyone's had this problem on a linux server.

One last thought, I once had a really odd permissions issue on a windows hosted joomla build. The module couldn't create thumbnails of images because the folder wasn't writeable, even though permissions showed as 777. After contacting the host it turned out there was some kind of permission set on their end which was preventing it. Maybe you would know more about this since you are an MCSE :)

davegas666
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sat Mar 14, 2009 9:29 pm

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by davegas666 » Fri Sep 04, 2009 11:51 pm

I've re-posted this at the root of this forum to try and get wider exposure as it appears there's only you subscribed to this thread.

The mods will love me ;)

The old MCSE eh. Studied for the upgrade exam for 2003 but never took it but concentrating on MOM 2005, Ops Mgr 2007 and SQL 2005. Rolled out APF/ADS before Windows Deployment Services kicked off but now Joomla got in the way of everything lol.

verticalgrain, thanks for all of your time and input today. It has certainly opened my eyes to the issues one can face with a tricky J! install.

As I said earlier, installed on other Linux OS without any issues. Was given some free space to host and now I know why it was so cheap lol.

I will keep you updated.

Dave

User avatar
verticalgrain
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Mon Dec 01, 2008 4:16 am
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by verticalgrain » Sat Sep 05, 2009 12:00 am

No problem, hope you're able to solve the issue. I'm glad you reposted it, I think this issue needs more exposure. Keep me posted!

stuffdone
Joomla! Guru
Joomla! Guru
Posts: 510
Joined: Tue Oct 28, 2008 11:06 pm
Location: NE Florida
Contact:

Re: # JFTP::mkdir: Bad response # JFTP::chmod: Bad response # JF

Post by stuffdone » Thu Sep 24, 2009 9:51 pm

ooffick wrote:Can you try the following:
  1. Login to the admin interface
  2. Click on Help
  3. Click on System Info
  4. Click on Directory Permissions
  5. You will see a list of Directories which are writable/unwritable
  6. Can you check each one which is unwritable and set it's permission to 777
Or you can follow the steps here:
http://docs.joomla.org/How_to_solve_Ins ... on_Manager

Olaf
Some how leaving so many directories wide open is just asking to be hacked. Isn't there a better way?

I finally gave up too. I can turn of the FTP layer and install stuff just fine. Problem is that permissions are then given to apache and I have to get my server admin to go change them back to the site so I can edit stuff. A real pain....but it is the only thing that works.
--- http://www.Stuffdone.com ---
Web Design and Hosting since 1995

 

Locked

Return to “Administration 1.5”