Remove FORCE SSL for Admin login

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
AndieB
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Jan 25, 2009 7:55 pm
Location: Skövde
Contact:

Remove FORCE SSL for Admin login

Post by AndieB » Mon Jan 26, 2009 10:48 am

Hi all,


I mistakenly managed to click something called "Force SSL" for Administration login. And now I discovered that my QNAP TS-209 on which Joomla! is installed, does not support SSL (HTTPS) connections for websites other than the QNAP's own login page.

Anyone knows HOW I can disable this, since I am not able to logon to the Jooml! Administrator pages..

ahab71
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Apr 21, 2007 9:36 pm

Re: Remove FORCE SSL for Admin login

Post by ahab71 » Wed Aug 05, 2009 7:03 am

Open your configuration.php file and edit the line:
var $force_ssl = '2';
to:
var $force_ssl = '0';

The variable will be set to '2' if you had set Force SSL to Entire Site or '1' if you'd set it to Administrator Only.

This is a little late I know but maybe it will be helpful to someone else.

nori tarou
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue May 10, 2011 1:51 am

Re: Remove FORCE SSL for Admin login

Post by nori tarou » Tue May 10, 2011 1:56 am

Thanks for the tips! I fell into the same situation as you and this post really helps me to access back to my homepage. :D

MoneerK
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jun 11, 2011 6:49 am

Re: Remove FORCE SSL for Admin login

Post by MoneerK » Sat Jun 11, 2011 6:51 am

Thanks so much, you saved my day.

Backing up, just in case....

giemomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Mon Jun 20, 2011 7:45 am

Re: Remove FORCE SSL for Admin login

Post by giemomi » Fri Jun 08, 2012 2:18 am

Thanks a million guys!!!!

Also, if anyone needs few more tips.
I wasn't able to edit the configuration.php file to start with. I had to change file permission to read and write for the user. Then edited the file and changed the permissions back to read only.
Then clear your browser history and voila!!!!

Good luck to all peeps out there with that!!

SAMSON15
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Mar 27, 2015 9:24 am

Re: Remove FORCE SSL for Admin login

Post by SAMSON15 » Sat May 09, 2015 3:52 am

helpful :)

lumptolaughter
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jul 07, 2017 10:26 pm

Re: Remove FORCE SSL for Admin login

Post by lumptolaughter » Fri Jul 07, 2017 10:33 pm

ahab71 wrote:Open your configuration.php file and edit the line:
var $force_ssl = '2';
to:
var $force_ssl = '0';

The variable will be set to '2' if you had set Force SSL to Entire Site or '1' if you'd set it to Administrator Only.

This is a little late I know but maybe it will be helpful to someone else.
giemomi wrote:Thanks a million guys!!!!

Also, if anyone needs few more tips.
I wasn't able to edit the configuration.php file to start with. I had to change file permission to read and write for the user. Then edited the file and changed the permissions back to read only.
Then clear your browser history and voila!!!!

Good luck to all peeps out there with that!!
How did you get to the configuration.php file? I am at my index page but cannot access any files

lumptolaughter
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jul 07, 2017 10:26 pm

Remove FORCE SSL for Admin login

Post by lumptolaughter » Fri Jul 07, 2017 10:37 pm

How did you access the configuration.php file. I cannot access anything. And I see a note above also to change the file permission to read and write for the user, but I need to know how to get to that also. I am an amateur for sure. I turned on the force SSL and now the site is completely disappeared.


Post Reply

Return to “Administration 1.5”