All menu items disappear

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
helalf
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Apr 12, 2007 4:31 pm
Contact:

All menu items disappear

Post by helalf » Fri Oct 30, 2009 10:54 pm

Hi, I have a simple site with a main menu and a user menu (for registered users). Yesterday the main menu was gone. I checked in the administrator and none of the items ("frontpage", "news" etc.) in the menu did show, neither in the user menu. I checked the database in phpmyadmin and all the items are there and it looks OK.

I tried to add a new menu item, but it does not show (but I find it in the database). I tried to move the menu to another part of the site with no luck.

Any suggestions are welcome.

I use Joomla 1.5.12 in Legacy mode.

Håkon

 
User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27490
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: All menu items disappear

Post by imanickam » Fri Oct 30, 2009 11:11 pm

These are all symptoms for PHP 5.3.0. Are you using PHP 5.3.0? Joomla! is not certified to work with PHP 5.3.0.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

helalf
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Apr 12, 2007 4:31 pm
Contact:

Re: All menu items disappear

Post by helalf » Sat Oct 31, 2009 6:38 pm

Yes, I am using PHP 5.3.0. Is there a workaround?

vikingsfan19
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Oct 31, 2009 6:54 pm

Re: All menu items disappear

Post by vikingsfan19 » Sat Oct 31, 2009 7:16 pm

I see that I am on PHP 5.3.0 also but I don't see it listed as a problem in the documentation. I don't see a list of certified PHP version either. I'm probably just overlooking it but it would be appreciated if someone would point it out.
helalf wrote:Yes, I am using PHP 5.3.0. Is there a workaround?
I just have this on WAMP server right now and to get another verison of PHP all you have to do is click the WAMP icon -> PHP -> Version -> Get more and then download a different version. I would assume that a LAMP server should have a similar option.

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27490
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: All menu items disappear

Post by imanickam » Sat Oct 31, 2009 7:22 pm

(a) If you are using XAMPP, uninstall the current version of 1.7.2. Download XAMPP 1.7.1 from http://sourceforge.net/projects/xampp/files/ and install it. It should solve your problem.

(b) If you are using WAMP Server, review discussion http://forum.joomla.org/viewtopic.php?f=428&t=430194 about how to accomplish this.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

helalf
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Apr 12, 2007 4:31 pm
Contact:

Re: All menu items disappear

Post by helalf » Sat Oct 31, 2009 11:56 pm

I found a work-around, or my ISP did.

open modules/mod_mainmenu/helper.php
change "function buildXML(&$params)" to "function buildXML($params)" on line 31

the menu items still don't show on the administrator site, though - they are working on it and I will post the solution here as soon as I can.

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27490
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: All menu items disappear

Post by imanickam » Sun Nov 01, 2009 1:24 pm

I am glad that your ISP could offer a solution to your problem. Hope they help you on the Administrator side as well.

As for as the documentation is concerned, the incompatibility of Joomla! with PHP 5.3.0 is documented at http://www.joomla.org/about-joomla/tech ... ments.html.

Review the discussion http://forum.joomla.org/viewtopic.php?f=428&t=455646. I do not know whether this may be of use to you. Be informed that it is not an official solution provided by Joomla!

Alternatively, you could try to test the version of Joomla that is patched to work with PHP 5.3.0:
http://community.joomla.org/blogs/commu ... p-530.html
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

vikingsfan19
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Oct 31, 2009 6:54 pm

Re: All menu items disappear

Post by vikingsfan19 » Sun Nov 01, 2009 6:08 pm

Thanks for the requirements post

asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 138
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Re: All menu items disappear

Post by asearle1 » Wed Oct 28, 2015 9:03 pm

Bravo! This fixed my "disappearing menu" problem with Joomla 1.5. Many thanks!

GET_1NE
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jan 07, 2016 3:41 pm

Re: All menu items disappear

Post by GET_1NE » Thu Jan 07, 2016 3:45 pm

Was seeing if this was ever resolved. Im also having the same issue. Using Joomla 1.5.3.

I'm currently running with PHP 5.3.4. I found that this should be compatible here http://joomla.stackexchange.com/questio ... 5-will-run

However I did have some PHP issues that I resolved with this link: http://stackoverflow.com/questions/1229 ... ot-showing

After doing this I was able to see the menu items show up correctly for my site. However in the Menu Item Manager inside the Joomla admin the errors listed below are thrown when debugged. Menu items will not display at all and the list is blank. What is causing these errors to be thrown and not display my menu items in the Joomla Admin yet display on the website perfectly?

Warning: Parameter 4 to JHTMLMenu::treerecurse() expected to be a reference, value given in D:\Inetpub\wwwroot\libraries\joomla\html\html.php on line 87

Warning: array_slice() expects parameter 1 to be array, null given in D:\Inetpub\wwwroot\administrator\components\com_menus\models\list.php on line 143

Warning: Invalid argument supplied for foreach() in D:\Inetpub\wwwroot\administrator\components\com_menus\models\list.php on line 147 Notice: Only variable references should be returned by reference in D:\Inetpub\wwwroot\administrator\components\com_menus\views\list\view.php on line 198

Warning: Invalid argument supplied for foreach() in D:\Inetpub\wwwroot\administrator\components\com_menus\views\list\view.php on line 66

GET_1NE
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jan 07, 2016 3:41 pm

Re: All menu items disappear

Post by GET_1NE » Thu Jan 07, 2016 7:54 pm

I found that these files from github were to be stable. Although it was recommended to replace all Joomla files with the ones found here https://github.com/PhilETaylor/Joomla1.5.999

I only replaced the following to resolve my issue:

helper.php - found here modules\mod_mainmenu
html.php - found here libraries\joomla\html
view.php - found here administrator\components\com_menus\views\list

 

Locked

Return to “Administration 1.5”