500 Internal Server error in Godaddy server.

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
nirmalgyanwali
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Dec 01, 2008 11:08 am
Location: Sydney, Australia
Contact:

500 Internal Server error in Godaddy server.

Post by nirmalgyanwali » Sat May 29, 2010 3:54 am

Hello frens,

I got internal server error message in my site www.nirmal.com.np from a
month. It's hosted in godaddy. I have mailed them for support many times. But they said it's script error and they don't give support for script.

Actually the problem is, It is displaying error in static pages.That's
why i have disabled SEF urls from joomla global config.
But all my pages are tracked in google as static
pages. When i disable it it works fine. i have replaced
..htaccess many times. There are 5/6 domains hosted in my shared server. Others are working fine. But why it's only shwoing error.

I have also checked the error logs in godaddy server. There is no errors found.

Please check this url: http://www.nirmal.com.np/about.html. It shows 500 internal server error. In normal condition it shows 404 erorr not found.

Please, i am looking forward to your help.
Joomla, Web design blog: http://www.nirmal.com.np
Joomla Web Developer Sydney, Australia: http://www.nirmal.com.au

christofff
Joomla! Explorer
Joomla! Explorer
Posts: 333
Joined: Sat Jan 10, 2009 11:46 am
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by christofff » Sat May 29, 2010 4:39 pm

Hi nirmalgyanwali.

500 Internal server error is often associated with syntax errors in the .htaccess file.

I see you mentioned that you replaced htaccess, but did you try removing it fully and disabling SEF URLS? You also mentioned that you 'replaced' it, but are you confident that the copy you replaced it with was a working version?

I'm not sure what you mean by 'static', do you mean friendly URL's?

Chris.

User avatar
nirmalgyanwali
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Dec 01, 2008 11:08 am
Location: Sydney, Australia
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by nirmalgyanwali » Mon May 31, 2010 3:39 am

Hello Chris,

Thank you for your reply.

i deleted .htaccess and off the SEF urls from global configuration. Now it's not showing the internal error.

But i want to enable SEF url. When i do that i shows the same error. My most of the pages are tracked in google as .html.

Do you have any idea for that?
Joomla, Web design blog: http://www.nirmal.com.np
Joomla Web Developer Sydney, Australia: http://www.nirmal.com.au

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18912
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by leolam » Mon May 31, 2010 4:56 am

Shows with .html since you have enabled the button in global config "add suffix to url"

Here are correct settings:
Search Engine Friendly URLs : yes
Mod_rewrite: yes
Suffix: yes (if you want to show with .html)

upload attached htacces.txt to your Joomla root folder and rename to .htaccess. Than issue should be resolved
htaccess.txt
Leo 8)
You do not have the required permissions to view the files attached to this post.
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
Member Joomla Bug Squad & Joomla CMS Release Team

ivan1718
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 14, 2010 8:41 am

Re: 500 Internal Server error in Godaddy server.

Post by ivan1718 » Mon May 31, 2010 2:05 pm

Hi to all,
I have exactly the same problem.
Shared linux hosting at Godaddy. Hosting more than one websites.
I have followed all the steps described in order to run sef.
I have turned all 3 options to yes changed the htaccess.txt to .htaccess and still ending up with “Error 500 – Internal Server Errors”
I have added " RewriteRule (.*) http://www.google.com/ " to the top of the .htaccess file.
I end up with 302 Found. Error message:
"Found

The document has moved here.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache Server at pokerrelax.com Port 80"


I did add the folder name to which the domain points after the RewriteBase line and changed it to RewriteBase /pokerrelax. Still not working

I wrote to Godaddy and this is what they answered:
"Unfortunately, because we do not provide coding support, we are unable to determine what specifically in .htaccess file may be causing the error. You may wish to review your code to determine if there are any issues, because it appears that is the most likely cause of the error. You may also wish to enable detailed error messages as a temporary diagnostic measure. The procedure for this will vary, depending on the scripting language being used. We also recommend consulting both the vendor's online documentation, as well as the large number of online forums dedicated to coding and scripting.

If you determine there is no issue with the code itself and believe the issue is server related, please reply with specific evidence of this and we will investigate the matter further."

I used the .htaccsess file attached by leolam in the previous post. Still not working?

The domain is: pokerrelax.com
It points to a file in my root directory called pokerrelax.
Running Joomla 1.5.15
PHP 5

I will appreciate any suggestions and help. Thank you,
Ivan

ivan1718
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 14, 2010 8:41 am

Re: 500 Internal Server error in Godaddy server.

Post by ivan1718 » Tue Jun 01, 2010 10:45 am

Hi All,
I think I have a solution for Godaddy users on shared linux hostings. Worked for me.
So,

Turn all the SEF options off.
Very important!!! GoDaddy does not process the .htaccess immediately.
Delete the existing .htaccess from the server.
Use the htaccess.txt file delivered with Joomla.
Edit the file as such:
Add the following lines at the top of the htaccess file:

AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

uncomment the “RewriteBase /” line in the .htaccess file( remove the #)
if you host more than one sites on a GoDaddy shared linux hosting account,
you have to change “RewriteBase /” as follows:

RewriteBase /the name of the file to which the domain points.

save the file as .htaccess and upload.

Once the SEF options are turned on, it should work fine. (Remember to allow at least one hour for changes to take place and clear local caches before thinking you’ve got an error)

I attached the .htaccess file that work for me.
please remove or replace the "pokerrelax" after “RewriteBase /”
You do not have the required permissions to view the files attached to this post.

User avatar
nirmalgyanwali
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Dec 01, 2008 11:08 am
Location: Sydney, Australia
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by nirmalgyanwali » Mon Jun 07, 2010 2:17 pm

Thanx fren,

Thank worked for me.

My problem is solved. Now, i am again running my site with SEF URLs.

Thank you very much frens.
Joomla, Web design blog: http://www.nirmal.com.np
Joomla Web Developer Sydney, Australia: http://www.nirmal.com.au

zbolt
Joomla! Apprentice
Joomla! Apprentice
Posts: 42
Joined: Wed Mar 04, 2009 5:39 pm

Re: 500 Internal Server error in Godaddy server.

Post by zbolt » Tue Jun 22, 2010 11:31 pm

Hello,

I am receiving the following error anytime I try to install a component through the joomla backend....

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


I have read the forums and tried everything. I have deleted the htaccess file, changed the htaccess file, etc. What is causing this and how can I fix it?

My site is hosted through GoDaddy, PHP5 and here is my htaccess file...

##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

Please help!

Thanks

User avatar
syhussaini
Joomla! Explorer
Joomla! Explorer
Posts: 402
Joined: Sat Jan 03, 2009 2:20 pm
Location: Hyderabad-India
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by syhussaini » Wed Jul 21, 2010 7:59 am

hmmm... Looks like there is a problem with the config,

give this a try:

1. Install a fresh copy of Joomla in a different location (ex: Sub folder)
2. Change the path of the installation folder (default is tmp) in the original Joomla installation
3. Copy the htaccess.txt file in your original joomla install from the fresh copy installed above
4. Now rename it to .htaccess

I hope this works out.

User avatar
dingbusan
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Sun Sep 21, 2008 3:13 pm
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by dingbusan » Sun Jul 25, 2010 4:43 am

after all the try, now I believe there's nothing to do with the ".htaccess" file. my solution as bellow, now the Internal server error never happen again. pls try this way:

1. Pls go to godaddy hosting control panel ,
2. Click Settings ->File Extension ->Default Extensions
3 Choose to edit ".php", change it run under to "php5.x"(the default is "PHP5.X FastCGI")
4. Enjoy ur fast website without "500 Internal Server error" now!!


Hope this is helpful for someone.
I just resolve this problem of my site: http://www.skyren-art.com

Courts
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Apr 01, 2010 11:12 am

Re: 500 Internal Server error in Godaddy server.

Post by Courts » Tue Jul 27, 2010 7:53 am

Thank you so much Ivan! You are a life saver!

Your instructions were really clear and concise to follow also. :)

marioVFX
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Jun 30, 2008 4:22 pm

Re: 500 Internal Server error in Godaddy server.

Post by marioVFX » Wed Sep 08, 2010 3:53 am

dingbusan wrote:after all the try, now I believe there's nothing to do with the ".htaccess" file. my solution as bellow, now the Internal server error never happen again. pls try this way:

1. Pls go to godaddy hosting control panel ,
2. Click Settings ->File Extension ->Default Extensions
3 Choose to edit ".php", change it run under to "php5.x"(the default is "PHP5.X FastCGI")
4. Enjoy ur fast website without "500 Internal Server error" now!!


Hope this is helpful for someone.
I just resolve this problem of my site: http://www.skyren-art.com
My options with godady server are:
python 2.2
ruby
perl

No ph5.x!

Any idea?

User avatar
dingbusan
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Sun Sep 21, 2008 3:13 pm
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by dingbusan » Wed Sep 08, 2010 7:56 am

the godaddy Linux hosting now have 2 kinds, "Grid or without grid". I think which u're using now is Grid linux hosting. the solution I posted is work on normal linux hosting only. not necessary when u use grid linux hosting.

RuLL809
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Oct 05, 2010 10:22 pm

Re: 500 Internal Server error in Godaddy server.

Post by RuLL809 » Tue Oct 05, 2010 11:03 pm

Ivan you r the best! Thanks bro

User avatar
chongkan
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Aug 26, 2008 4:33 am
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by chongkan » Fri Jan 21, 2011 3:58 pm

ivan1718

Thanks man, I was really worried for not getting it working at godaddy.. spent teh last 2 hrs trying..
Saludos,
--
Chongkan - Likan Development - Diseño Web y Desarrollo a la medida - http://www.likandevelopment.com

bembolbee
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Dec 15, 2010 8:57 pm

Re: 500 Internal Server error in Godaddy server.

Post by bembolbee » Fri Feb 25, 2011 5:24 pm

did what ivan says but still not getting it...i'm still having the internel server error

User avatar
nirmalgyanwali
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Dec 01, 2008 11:08 am
Location: Sydney, Australia
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by nirmalgyanwali » Tue Mar 01, 2011 3:00 am

dingbusan wrote:after all the try, now I believe there's nothing to do with the ".htaccess" file. my solution as bellow, now the Internal server error never happen again. pls try this way:

1. Pls go to godaddy hosting control panel ,
2. Click Settings ->File Extension ->Default Extensions
3 Choose to edit ".php", change it run under to "php5.x"(the default is "PHP5.X FastCGI")
4. Enjoy ur fast website without "500 Internal Server error" now!!

Hello fren,
I've only Python 2.2, per and ruby in my options?

is there any other solution to add php5.x?
Joomla, Web design blog: http://www.nirmal.com.np
Joomla Web Developer Sydney, Australia: http://www.nirmal.com.au

User avatar
nirmalgyanwali
Joomla! Intern
Joomla! Intern
Posts: 88
Joined: Mon Dec 01, 2008 11:08 am
Location: Sydney, Australia
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by nirmalgyanwali » Tue Mar 01, 2011 3:05 am

I am really confused with godaddy shared hosting. i changed plan to shared linux 4GH (4th generation hosting) plan as godaddy recommended it's faster and secure. But still it's showing the same 500 error. And sites are really slow.
And amazing thing is admin panel is also showing 500 internal server error.
Do u have any idea?
Joomla, Web design blog: http://www.nirmal.com.np
Joomla Web Developer Sydney, Australia: http://www.nirmal.com.au

mcdmedia
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Sep 08, 2010 8:37 pm

Re: 500 Internal Server error in Godaddy server.

Post by mcdmedia » Wed Oct 26, 2011 8:31 am

ivan1718 wrote:Hi All,
I think I have a solution for Godaddy users on shared linux hostings. Worked for me.
So,

Turn all the SEF options off.
Very important!!! GoDaddy does not process the .htaccess immediately.
Delete the existing .htaccess from the server.
Use the htaccess.txt file delivered with Joomla.
Edit the file as such:
Add the following lines at the top of the htaccess file:

AddHandler x-httpd-php5 .php
AddHandler x-httpd-php .php4

uncomment the “RewriteBase /” line in the .htaccess file( remove the #)
if you host more than one sites on a GoDaddy shared linux hosting account,
you have to change “RewriteBase /” as follows:

RewriteBase /the name of the file to which the domain points.

save the file as .htaccess and upload.

Once the SEF options are turned on, it should work fine. (Remember to allow at least one hour for changes to take place and clear local caches before thinking you’ve got an error)

I attached the .htaccess file that work for me.
please remove or replace the "pokerrelax" after “RewriteBase /”
You are the man! I was going crazy until I found this post. Thanks so much. Godaddy is such a pos! :D
Need help? Joomla Web Development http://www.mcdmedia.com

kurtmx
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jun 07, 2012 5:54 pm

Re: 500 Internal Server error in Godaddy server.

Post by kurtmx » Thu Jun 07, 2012 6:44 pm

Stop wasting your time, ivan1718's solution is working like a charm!

http://forum.joomla.org/viewtopic.php?p ... 6#p2160100

Thanx!

gyanuz
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Sat Jul 09, 2011 7:47 am

Re: 500 Internal Server error in Godaddy server.

Post by gyanuz » Mon Jun 25, 2012 2:48 am

ivan1718 is the best and savior of us.
Thank you man

irenepiq
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 06, 2013 10:45 am

Re: 500 Internal Server error in Godaddy server.

Post by irenepiq » Fri Sep 06, 2013 11:13 am

ivan1718 Thank you so much!

User avatar
Joe Daddy
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Tue Feb 23, 2010 8:59 pm
Location: Northern Colorado Front Range
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by Joe Daddy » Tue Aug 12, 2014 3:01 pm

I too use godaddy hosting (Linux with the new 2014 cpanel)
Some of my joomla modules caused error 500 internal server errors with SEO = Yes, while most worked fine. This was discovered when I moved the code.

Cause of my bug, the alias started with a Number (year). Changed it to a text and the internal errors went away.

Conclusion, sometimes these nefarious errors have nothing to do with php or the .htacess files.

Joe Baldwin aka Joe Daddy http://www.joe-daddy.com http://www.bmrc.info

jigmode
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Aug 21, 2014 8:28 am

Re: 500 Internal Server error in Godaddy server.

Post by jigmode » Thu Aug 21, 2014 9:07 am

Please help here, I am not using Linux, rather i am using windows, but i am getting this error 500 when i try to upload extensions;

HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.

will it help if i also change my htaccess.txt file with Ivan1718 code or it applies to those using shared linux hosting?

Please help i really need to install an extension on my livesite.

User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by dpacadmin » Fri Aug 22, 2014 9:04 pm

@jigmode
You should post this in the IIS forum;
http://forum.joomla.org/viewforum.php?f=543

deep552
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 12, 2014 2:03 pm

Re: 500 Internal Server error in Godaddy server.

Post by deep552 » Wed Sep 17, 2014 8:56 am

Hi every one..!
i got a solution for 505 error .
if you are developing joomla locally in windows xp. the latest version of xampp will not support
you need to download xampp old version and php5.0 will be downloaded.
change php version in your live hosting settings as php5.0.
make sure change the file name htaccess.txt as .htaccess

njoy :laugh:

traktap
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Nov 05, 2014 3:50 am

Re: 500 Internal Server error in Godaddy server.

Post by traktap » Wed Nov 05, 2014 3:54 am

Thanks dingbusan

Your suggestion worked perfectly.

Thanks Again.

User avatar
reggaebkk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Mon Jul 14, 2008 1:39 pm

Re: 500 Internal Server error in Godaddy server.

Post by reggaebkk » Tue Aug 04, 2015 7:10 pm

Hi,
I am having the same problem with one of my sites.

I am on a Linux Centos 5 Dedicated server and since I have upgraded to easyapache and latest php version I am having the 403 error, not every time, only about 20% of the times I open a page.
Forbidden
You don't have permission to access /index.phpmain/species-families/blue-purple on this server.
Additionally, a 500 Internal blah blah

I tried Ivan's solution above but then when I try to open it doesn't open anything, I tried with or without the RewriteBase on. It just downloads a 2k file that says:

Code: Select all

<?php
/**
 * @package    Joomla.Site
 *
 * @copyright  Copyright (C) 2005 - 2015 Open Source Matters, Inc. All rights reserved.
 * @license    GNU General Public License version 2 or later; see LICENSE.txt
 */

/**
 * Define the application's minimum supported PHP version as a constant so it can be referenced within the application.
 */
define('JOOMLA_MINIMUM_PHP', '5.3.10');

if (version_compare(PHP_VERSION, JOOMLA_MINIMUM_PHP, '<'))
{
	die('Your host needs to use PHP ' . JOOMLA_MINIMUM_PHP . ' or higher to run this version of Joomla!');
}

/**
 * Constant that is checked in included files to prevent direct access.
 * define() is used in the installation folder rather than "const" to not error for PHP 5.2 and lower
 */
define('_JEXEC', 1);
if (file_exists(__DIR__ . '/defines.php'))
{
	include_once __DIR__ . '/defines.php';
}
if (!defined('_JDEFINES'))
{
	define('JPATH_BASE', __DIR__);
	require_once JPATH_BASE . '/includes/defines.php';
}
require_once JPATH_BASE . '/includes/framework.php';
// Mark afterLoad in the profiler.
JDEBUG ? $_PROFILER->mark('afterLoad') : null;
// Instantiate the application.
$app = JFactory::getApplication('site');
// Execute the application.
$app->execute();

Of course I'm not on Godaddy, so other solutions won't apply to me I guess.
My .htaccess is the default joomla htaccess.txt and the website is running virtuemart.

Any idea?

User avatar
dpacadmin
Joomla! Champion
Joomla! Champion
Posts: 6029
Joined: Sat Aug 16, 2008 1:46 pm
Location: the Bat Cave
Contact:

Re: 500 Internal Server error in Godaddy server.

Post by dpacadmin » Tue Aug 04, 2015 7:45 pm

It looks like you are missing a trailing slash;
/index.phpmain/
should be;
/index.php/main/
Try posting to the appropriate Joomla form for the Joomla version you are using, it doesn't look like you are using a Joomla 1.5 version. It also looks like you are having an issue with a Virtuemart url so it could be a Virtuemart issue.

User avatar
reggaebkk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Mon Jul 14, 2008 1:39 pm

Re: 500 Internal Server error in Godaddy server.

Post by reggaebkk » Wed Aug 05, 2015 1:45 am

Actually the url was too long, I truncated it, but thanks, i will post elsewhere.


Post Reply

Return to “Administration 1.5”