Global Configuration setting won't save

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
slorduk
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 14, 2011 2:34 pm

Global Configuration setting won't save

Post by slorduk » Wed Apr 27, 2011 4:08 pm

Just completed a site and opened Global Config to alter the keywords and description. Clicked save, Joomla reports the save successful, but the changes haven't been saved. Anything I change in the Global Config does not save, even though Joomla says it's ok.

I'm quite new to Joomla, and this has really stumped me.

Thanks for any help.

System details below:-
PHP Built on: FreeBSD chromavision.co.uk 4.7-RELEASE-p22 FreeBSD 4.7-RELEASE-p22 #0: Thu i386
Database Version: 4.0.27-log
Database Collation: N/A (mySQL < 4.1.2)
PHP Version: 5.1.6
Web Server: Rapidsite/Apa/1.3.33 (Unix) FrontPage/5.0.2.2510 mod_ssl/2.8.22 OpenSSL/0.9.8d
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.22 Stable [ senu takaa ama woi ] 04-November-2010 18:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 (.NET CLR 3.5.30729)

baysaa
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Mar 03, 2008 2:44 pm

Re: Global Configuration setting won't save

Post by baysaa » Wed May 04, 2011 11:09 am

I've had this problem just now, and seem to have found the problem. The $live_site variable in the configuration.php was empty. I filled it in with the URL of my website, uploaded the configuration.php refreshed my configuration page on the admin area and tried the save again, and it worked. Hope this works for u too.

slorduk
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 14, 2011 2:34 pm

Re: Global Configuration setting won't save

Post by slorduk » Wed May 04, 2011 11:26 am

It is solved now, via the Joomlashack forum.

Briefly, I moved my whole site up one directory level, that's when the problem started. Joomla was writing the configuration.php file to the old, empty directory. In my global settings, I had ftp set to ON, pointing to the old, empty directory. After correcting this, everything was fine.

Thanks for the reply.

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: Global Configuration setting won't save

Post by PhilOSparta » Thu Jun 02, 2011 11:01 pm

I also had the same problem. Couldn't save anything with article editor, couldn't make changes to modules etc. etc.

Downloaded downloaded configuration.php and added site name in $live_site=
That fixed it.

Don't forget to change permissions on configuration.php for write permissions and then back to read only after saving.

Phil

stiaanvm
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jul 07, 2015 8:00 am

Re: Global Configuration setting won't save

Post by stiaanvm » Tue Jul 07, 2015 8:11 am

FINALLY! I just had the same problem with using localhost, XAMPP and Google Chrome. My solution: Open the Joomla Backend in Internet Explorer, saved global configuration there and it was reflected immediately. Hope this helps for you :)


Locked

Return to “Administration 1.5”