Joomla 1.5 and PHP 5.4

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
highjumper83
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Dec 29, 2008 7:47 am

Joomla 1.5 and PHP 5.4

Post by highjumper83 » Tue Apr 03, 2012 1:01 pm

Hello,

my webhoster informs me, that he want to change from php 5.2 to 5.4. So I have to check if my joomla is ready for 5.4.
I switcht from 5.2 to 5.4 and only errors, nothing works. That was with joomla 1.5.22. So I thougt "update to the newest 1.5-Version". I patched to 1.5.26, but there is the same problem.
Now my question, is it posible make joomla 1.5.26 runnning with php 5.4 or musst I upgrade my joomla to 2.5?

Regards!

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Joomla 1.5 and PHP 5.4

Post by tokenring » Tue May 15, 2012 11:59 pm

First of all... I can't believe that no one has helped you. This is a great question. I have a question for you. Can you explain how you migrated from 5.2 to 5.4?

Aaron

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Joomla 1.5 and PHP 5.4

Post by humvee » Mon Jun 04, 2012 11:47 am

There are currently issues with PHP 5.4 that are currently under investigation for Joomla 2.5.x and these may also impact on Joomla 1.5.x

tokenring
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 240
Joined: Sun Mar 22, 2009 11:42 pm

Re: Joomla 1.5 and PHP 5.4

Post by tokenring » Mon Jun 04, 2012 1:04 pm

humvee wrote:There are currently issues with PHP 5.4 that are currently under investigation for Joomla 2.5.x and these may also impact on Joomla 1.5.x
How do you make that change anyway? If you host supports it, how do you enable 5.4

User avatar
Slackervaara
Joomla! Ace
Joomla! Ace
Posts: 1006
Joined: Sat Aug 13, 2011 6:27 am

Re: Joomla 1.5 and PHP 5.4

Post by Slackervaara » Wed Jun 06, 2012 1:40 pm

humvee wrote:There are currently issues with PHP 5.4 that are currently under investigation for Joomla 2.5.x and these may also impact on Joomla 1.5.x
Very interesting! Important that webhost gets aware of that so they don't upgrade to 5.4 too quickly. Can you say more about this and how serious it is. Will you provide upgrades, so 1.5.26 will be PHP 5.4 compliant?

catalinjohn
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Nov 30, 2012 9:35 am

Re: Joomla 1.5 and PHP 5.4

Post by catalinjohn » Fri Nov 30, 2012 9:48 am

Hi,

I was wondering if anyone has found a way to make Joomla 1.5 work in PHP v5.4.

My webhost (1and1) just informed me that hey are upgrading to PHP 5.4 early next year, and that PHP 4 / 5.2 will be discontinued from their end. As they have the option to upgrade to PHP 5.4 earlier and revert (for testing purposes to see if websites continue to function properly), I saw that all instances of Joomla 1.5 stopped working in new PHP 5.4, so at the moment I continue sticking to php 5.2

I would upgrade to a newer version of Joomla, but as they all use some licensed components that I bought and that weren't developed for newer versions of Joomla, I am forced to stick to J 1.5.

So i was wondering if there is any patch for this issue or if someone has a solution.

Thank you,
John

Mily1000V
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Feb 14, 2013 11:41 am

Re: Joomla 1.5 and PHP 5.4

Post by Mily1000V » Thu Feb 14, 2013 11:46 am

Hello,
I'm new on this forum, and I'm a french native speaker so I hope I will do things properly. Has anyone found the solution ? I use Joomla 1.5.26 and my host is 1&1, under php5.4 as well.
I've had some problems with my Joomla administration when I moved to 1&1 so I wanted to reinstall Joomla, but I get many lines of error when I transfer the pack via ftp. Seems related to this php5.4 issue.
I hope that I'm clear and that I'll find some help... a bit tired of spending my whole days on that issue;
thanks !

lorenzofp
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Dec 17, 2007 6:39 pm

Re: Joomla 1.5 and PHP 5.4

Post by lorenzofp » Sat Feb 23, 2013 5:30 pm

Hello,

I CANT BELIEVE that nobody is helping with this issue.

My host still offers PHP 5.2, I am running joomla 1.5 on php 5.3 but I would like to start investigating php 5.4 compatibility!

So, anyone please can post here errors you receive in php 5.4 and eventually phpinfo of your site or any other information about your hosting and your site?

I REALLY HOPE that someone will start helping here... Joomla 1.5 is NOT so old, and MANY people are stuck on it, and PHP 5.4 is here already, so PLEASE, PLEASE, PLEASE, let me, let me, let me... let me get what I want this time, HELP WITH JOOMLA 1.5 AND PHP 5.4!!!

MrDutchy
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 20, 2011 8:22 am

Re: Joomla 1.5 and PHP 5.4

Post by MrDutchy » Tue Mar 12, 2013 1:23 pm

Sorry to revive an old thread but ..

On one site i still run Joomla 1.5.26 it works fine on PHP 5.3.22. It is a rather complex multilanguage site. I would very much like to remain using Joomla 1.5.x for at least another year.

I can delay the PHP 5.4.x. upgrade for a month or 6 (or more if I have to). However many people on shared hosting cannot.

humvee you said it's under investigation. Do you have any update on that? What are the findings so far? Will the 1.5.x branch see a PHP 5.4.x. compatibility patch?

nomorejoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Mar 20, 2013 8:19 pm

Re: Joomla 1.5 and PHP 5.4

Post by nomorejoomla » Wed Mar 20, 2013 8:29 pm

I have joomla running on PHP 5.4.3 for like a year. strange that people had so many problems getting it running. I cant say what I did special as it was a long time ago. I can post my php.ini if that will help someone.

Problem is that when i am upgrading now to the latest uniform server (my WAMP of choice) which is php 5.4.13, the site does not work. If i replace the php directory with php v 5.4.3 then everything works great.

Just wondering if anyone knew why that was??
Joomla is v1.5.26 as we are stuck on that because of no upgrade path :(

lorenzofp
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Dec 17, 2007 6:39 pm

Re: Joomla 1.5 and PHP 5.4

Post by lorenzofp » Wed Mar 20, 2013 8:45 pm

Hi.

I would really like to see your PHP.INI, I receive too many errors when running joomla 1.5.26 on php 5.4, maybe this could help us all.

thanks in advance for posting here your configuration.

nomorejoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Mar 20, 2013 8:19 pm

Re: Joomla 1.5 and PHP 5.4

Post by nomorejoomla » Wed Mar 20, 2013 8:50 pm

attached.

EDIT: i should also say that i now got 5.4.13 working! the uniserver version doesnt work, but using my ini file and downloading virgin PHP from php.net ( http://windows.php.net/download/#php-5.4 ) has solved the problem.

You might try going to the source directly, instead of who ever maintains your wamp /lamp as for me, this was the key! Also you need to use "thread safe" with apache.

EDIT2: I have now traced it down to php_apc.dll. my version which i think is APC 3.1.9 for PHP works, however the newest version 3.1.14 (2013) seems not to. Anyways loading the DLL from the old site makes everything work great.
You do not have the required permissions to view the files attached to this post.

MrDutchy
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 20, 2011 8:22 am

Re: Joomla 1.5 and PHP 5.4

Post by MrDutchy » Tue Apr 09, 2013 10:18 am

It is encouraging it seems to work just fine for you after all. Now it seems the issues in this thread were unrelated to the Joomla 1.5.x codebase.

Can anyone confirm Joomla 1.5.26 in it's current form is actually already suited for PHP 5.4.x?

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Joomla 1.5 and PHP 5.4

Post by Tonie » Tue Apr 09, 2013 12:08 pm

@MrDutchy. No, it isn't. Since 1.5 is not supported any more, there will be no Joomla 1.5.x release with PHP 5.4 support.

superbuck88
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Apr 09, 2013 5:28 pm

Re: Joomla 1.5 and PHP 5.4

Post by superbuck88 » Tue Apr 09, 2013 5:34 pm

Hi everyone,

I am very new on this forum and I read here and there that Joomla 1.5.26 will NOT work on PHP 5.4. So, I talked to my clients and told them that. But I decided to create a brand new server on AWS on Ubuntu 12.10 64 bits, with apache 2.2.22, PHP 5.4.6-1ubuntu1.2 and mySQL 5.5.29-0ubuntu0.12.10.1. I uploaded my Akeeba Backup from my PHP 5.3 server and I had only ONE error (cannot reassign auto-global variable _FILES in FPSS component).

Why is everyone says that Joomla 1.5.29 WILL NOT work on PHP 5.4?

nomorejoomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Mar 20, 2013 8:19 pm

Re: Joomla 1.5 and PHP 5.4

Post by nomorejoomla » Tue Apr 09, 2013 5:52 pm

my guess would be because its not "officially" supported. as i said i am running it now across 5 or 6 sites.

superbuck88
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Apr 09, 2013 5:28 pm

Re: Joomla 1.5 and PHP 5.4

Post by superbuck88 » Tue Apr 09, 2013 6:17 pm

That's horrible :-) I know that you need newer versions of PHP to run newer versions of Joomla, but old versions of Joomla run quite smoothly on newer PHP. Just access the error.log and see what you get.

rose_for_you
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Apr 20, 2013 1:46 pm

Re: Joomla 1.5 and PHP 5.4

Post by rose_for_you » Sat Apr 20, 2013 2:28 pm

I am using Joomla_1.5.3-Stable-Full_Package on IIS 8 with PHP 5.4.9

First I could even not install Joomla. After making some changes to PHP.ini I could install joomla. The changes I made was:

Original:

Code: Select all

error_reporting = E_ALL | E_STRICT
Changed to:

Code: Select all

error_reporting = E_ALL & ~E_STRICT
Original:

Code: Select all

display_errors = On
Changed to:

Code: Select all

display_errors = Off
But after install I recognize that my menus are not working. Altough I see menu items in "jos_menu" table, I could not see any on Joomla backend administrator "Menu Item manager" nor in my site. The menü group box is there with no menü items. Also trying to add new menü item seems working but after save the Menu Item Manager list is still empty. But looking to "jos_menu" table all newly added items are there. By searching I found some code changes and tried. On many forums they are talking about modifying two php files.

Many forums advice to modify "/libraries/joomla/html/html.php" line 87

original:

Code: Select all

return call_user_func_array( array( $className, $func ), $args );
to:

Code: Select all

return call_user_func_array( array( $className, $func ), &$args );
but this does not helped and stop working all the joomla site. So I get this line to original state.

but modifying "modules/mod_mainmenu/helper.php" line 31

original:

Code: Select all

function buildXML(&$params)
to:

Code: Select all

function buildXML($params)
worked for frontend menus are back. But still I could not see any menü item in Menu Item Manager.

anyone has a solution for this?
You do not have the required permissions to view the files attached to this post.

rose_for_you
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Apr 20, 2013 1:46 pm

Re: Joomla 1.5 and PHP 5.4

Post by rose_for_you » Sat Apr 20, 2013 5:11 pm

I guess many problems is becouse of the way parameter passing in functions.
Changing some functions parameters from referrance parameters to actual parameters or vice verca solves it.
Does anyone knows the key differences how PHP 5.2, PHP 5.3, PHP 5.4 handels parameter passing and is there an option to change the way?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26198
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 1.5 and PHP 5.4

Post by Per Yngve Berg » Sat Apr 20, 2013 5:54 pm

Use at least 1.5.26. Support for php 5.3 was added in 1.5.15.

The difference between 5.3 and 5.4 is covered here: http://no1.php.net/manual/en/migration54.php

hschneider
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Apr 21, 2013 8:55 pm
Contact:

Re: Joomla 1.5 and PHP 5.4

Post by hschneider » Sun Apr 21, 2013 9:06 pm

You need 3 patches to fix Joomla 1.5.x under PHP 5.4:

This one fixes missing menu checkboxes in the menu manager:
http://marketmix.com/de/wordpress-blog/ ... u-manager/

This fixes missing article checkboxes in the article manager:
http://marketmix.com/de/wordpress-blog/ ... -checkbox/

Finally this one fixes missing submenu items:
http://marketmix.com/de/wordpress-blog/ ... enu-items/

All patches have been tested with an 1und1 webspace running PHP5.4.

At least you'll have to update all extensions to their latest version.

-- Harald

User avatar
Slackervaara
Joomla! Ace
Joomla! Ace
Posts: 1006
Joined: Sat Aug 13, 2011 6:27 am

Re: Joomla 1.5 and PHP 5.4

Post by Slackervaara » Mon Apr 22, 2013 1:15 pm

hsneider,

I have Joomla 1.5.26 and PHP 5.4.6 on a local server on my PC and not a live site.
I have checkboxes both in menu manager and article manager. Unfortunately, I have no submenues so I can't check that.
Last edited by Slackervaara on Mon Apr 22, 2013 1:31 pm, edited 1 time in total.

hschneider
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Apr 21, 2013 8:55 pm
Contact:

Re: Joomla 1.5 and PHP 5.4

Post by hschneider » Mon Apr 22, 2013 1:26 pm

These Patches were tested with 1.5.8. Maybe this is already fixed in 1.5.26.

superbuck88
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Apr 09, 2013 5:28 pm

Re: Joomla 1.5 and PHP 5.4

Post by superbuck88 » Mon Apr 22, 2013 1:29 pm

Did not have to use these patches with 1.5.26.

vakil123
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Mon Jul 05, 2010 10:07 pm

Re: Joomla 1.5 and PHP 5.4

Post by vakil123 » Wed Oct 16, 2013 7:15 am

Is it possible to install php latest version on a subfolder of godaddy site and test it with latest version of Joomla 3.2 without upgrading php through godaddy since I have Joomla 1.5.23 version installed.

CNG New Media
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Oct 22, 2013 8:06 pm
Location: Kingston, ON
Contact:

Re: Joomla 1.5 and PHP 5.4

Post by CNG New Media » Tue Oct 22, 2013 8:16 pm

Hi

Cant access Joomla! Administration Login even with correct password....

I am adding this so that anyone searching for similar issues might find it useful.

My hosting support changed my re-seller accounts to php v 5.4 while fixing something else.

The result was a day wondering why I could not login to any of my Joomla 1.5 accounts even though the user name and password were correct.

Would seem that on my set up Jommla 1.5X and php 5.4 somehow stops that. My Joomla 2.3 and 3.x are ok

How i fixed it...

If you have cpanel access you can go to "Select PHP version", under the Software/Services area. You can (in my hosting setup at least), change the PHP version back to say 5.3. My setup allows 4.4, 5.2, 5.3, 5.4, 5.5 and native. Native is whatever the default is for the server.

Hope that helps someone.... :)

cufarolad
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 14, 2014 10:51 pm

Re: Joomla 1.5 and PHP 5.4 The solution

Post by cufarolad » Tue Jan 14, 2014 11:02 pm

My Solution:

If you can not access the php.ini file on your hosting,
They need to INSERT the following code in the file ''.htaccess'':

php_flag display_errors off
php_value error_reporting E_ALL

With that all errors should disappear.


(My Joomla installed 1.5.22 / The PHP 5.4 in my hosting server)

toplisek
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Tue Jul 06, 2010 10:04 am

Re: Joomla 1.5 and PHP 5.4

Post by toplisek » Mon May 05, 2014 12:07 pm

If I understand 5.4. PHP is not compatible with 1.5.18 if I understand but you just remove errros from website to be seen by visitors.

Example inside htaccess
php_flag display_errors off

ehmjade_07
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Sep 03, 2014 3:31 am

Re: Joomla 1.5 and PHP 5.4

Post by ehmjade_07 » Wed Sep 03, 2014 3:52 am

Hi! I'm having trouble with my website,. I am using joomla 1.5.25 and the web hosting company recently upgrade their php to php 5.4.28. And when I'm accessing the website, it has so many error, like these:

Strict Standards: Non-static method JLoader::import() should not be called statically in /home/sjcgov/public_html/libraries/joomla/import.php on line 29
Strict Standards: Non-static method JLoader::register() should not be called statically in /home/sjcgov/public_html/libraries/loader.php on line 71

hope someone can help me with the website's issue. thank you very much.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26198
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 1.5 and PHP 5.4

Post by Per Yngve Berg » Wed Sep 03, 2014 7:02 am

Why are you not running 1.5.26?

Turn off error reporting in Global Configuration.


Locked

Return to “Administration 1.5”