Page 1 of 1

Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 1:52 pm
by FoxTek
I have attempted to clear this error with my hosting service, GoDaddy, with no success. I've changed my htaccess.txt file to .htaccess also with no success. I'm working in version 1.5.26 and Admin Tools Core 2.2.5. I am able to still see all of the other pages/tabs within Joomla backend (such as Content) but not the Control Panel (index.php page will not load and keeps returning 500 Internal Server Error tab with error text

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Apache Server at www.foxteknology.com Port 80

Will an update to the Admin Core resolve this issue? I'm concerned that I will lose all of the pages and my site information.

How can I resolve this issue?

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 5:37 pm
by FoxTek
Any assistance or guidance is very appreciated as I've been unable to resolve this issues

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 6:35 pm
by Per Yngve Berg
Raise the Error Report Level in configuration.php, so you can see the error.

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 6:40 pm
by FoxTek
How do I raise the error report as suggested? Is the configuration.php in the hosting file manager? Specific instructions will be greatly appreciated.

As you may notice, I've not versed in hosting / website management... =(

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 6:56 pm
by FoxTek
I see that the file code in configuration.php in my hosting file manager is as follows:

var $error_reporting = '-1';

What value(s) are acceptable? A quick summary would be most helpful

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 7:50 pm
by Per Yngve Berg
Set it to 'maximum' or 'development'.

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 7:59 pm
by FoxTek
I've tried both and I'm still only getting the single error - tab label is 500 Internal Server Error; text is same as noted above

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
***** Manual signatures are NOT allowed ********** Manual signatures are NOT allowed ********** Manual signatures are NOT allowed ********** Manual signatures are NOT allowed *****
Apache Server at www.foxteknology.com Port 80

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 8:06 pm
by Per Yngve Berg
Enable Debug.

Re: Apache Server at www.mysite.com Port 80

Posted: Thu Jul 09, 2015 11:28 pm
by FoxTek
enabled debug in config file. Accessed Joomla login page and got following text on screen

Akeeba Backup Lazy Mode

Action: start
Last backup: 1436508816 (2015/07/09 23:13:36 GMT)
Adjusted last backup time: 1436425200 (2015/07/09 00:00:00 GMT)
Days frequency: 1
Backup time: 00:00 (0 seconds)
Next Backup: 1436511600 (2015/07/10 00:00:00 GMT)
Next Backup: 1436486400 (2015/07/09 17:00:00 LOCAL)
Time Now: 1436483815 (2015/07/09 16:16:55 LOCAL)
I will not start a new backup.

Profile Information
Application afterLoad: 0.002 seconds, 0.31 MB
Application afterInitialise: 0.084 seconds, 3.86 MB
Application afterRoute: 0.119 seconds, 5.17 MB
Application afterDispatch: 0.156 seconds, 6.72 MB
Application afterRender: 0.161 seconds, 6.81 MB
Memory Usage
7189852
0 queries logged.
Language Files Loaded

/home/content/58/6962758/html/administrator/language/en-GB/en-GB.ini 1
/home/content/58/6962758/html/administrator/language/en-GB/en-GB.plg_system_debug.ini 1
/home/content/58/6962758/html/administrator/language/en-GB/en-GB.com_login.ini 1
/home/content/58/6962758/html/administrator/language/en-GB/en-GB.mod_login.ini 1
/home/content/58/6962758/html/administrator/language/en-GB/en-GB.tpl_khepri.ini 1

Untranslated Strings Diagnostic

None

Untranslated Strings Designer

None

Re: Apache Server at www.mysite.com Port 80

Posted: Fri Jul 10, 2015 8:06 am
by Per Yngve Berg
Disable the Admin Modules, one by one.

Re: Apache Server at www.mysite.com Port 80

Posted: Fri Jul 10, 2015 12:33 pm
by FoxTek
Could you be more specific? Under what folder / file should I be looking?

Re: Apache Server at www.mysite.com Port 80

Posted: Fri Jul 10, 2015 12:45 pm
by FoxTek
I see the administrator folder under my File Manager, and under that folder is the modules of whihc there are about 19 modules, each with their own folder. Each then has its own css folder and two files, one with a .php extension, the other with an .xml extension.

So how do I specifically disable the module and what effect will this have?

Re: Apache Server at www.mysite.com Port 80

Posted: Fri Jul 10, 2015 3:15 pm
by FoxTek
I have to apologize as I'm just frustrated....

Any and all help is greatly appreciated!

Re: Apache Server at www.mysite.com Port 80

Posted: Sat Jul 11, 2015 1:59 pm
by FoxTek
Any help is greatly appreciated.

Re: Apache Server at www.mysite.com Port 80

Posted: Sun Jul 12, 2015 2:54 pm
by FoxTek
I'm still stuck...... :'(

Re: Apache Server at www.mysite.com Port 80

Posted: Sun Jul 12, 2015 3:31 pm
by Per Yngve Berg
Others have had problems with Admin tools. I don't have any expirence with the extension. Try to uninstall it.

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 1:44 pm
by FoxTek
How do I uninstall the Admin tools / module?

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 3:46 pm
by Per Yngve Berg
Extensions->Install/Uninstall

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 5:29 pm
by FoxTek
Completed the uninstall of Admin Tools. Logged out. Tried to log back in to the backend (index.php) and am still getting the 500 Internal Server Error, even used a different browser - used both Chrome and Mozilla, both return the error.

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 6:32 pm
by FoxTek
Since I am working in Joomla v1.5.26 is there a way to upgrade to the latest version and have all the content, images and pages I've created converted so they'll work in the updated program? Is this an option or will I be getting the same error message?

Comments, suggestions?

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 8:11 pm
by Per Yngve Berg

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 13, 2015 8:38 pm
by FoxTek
Thank you for all your help Per. It looks like the more questions I ask, the more I feel this is out of my area of comfort and expertise.

I think I'm going to need help and I'm not sure if there is someone out there in the Joomla community who has the expertise to help me out or make a recommendation, that would be much appreciated.

Re: Apache Server at www.mysite.com Port 80

Posted: Wed Jul 22, 2015 8:43 pm
by dpacadmin
If Admin Tools is the problem try removing these folders as per instructions at the bottom of this page;
https://www.akeebabackup.com/documentat ... lling.html

administrator/component/com_admintools
component/com_admintools
media/com_admintools
plugins/system/admintools

Try setting Error Reporting to "Maximum", if you do not have access to the Global Configuration/Server tab then set it in your configuration.php file(in the root of your site accessed via FTP) to;

Code: Select all

var $error_reporting = '30719';

Re: Apache Server at www.mysite.com Port 80

Posted: Sun Jul 26, 2015 9:52 pm
by FoxTek
I don't truly know if Admin tools is the problem.

SO, I'm going to take another route and rebuild my website in the latest version of Joomla with Virtue Mart extension which I believe is VirtueMart3.0.9_Joomla_2.5.28-Stable-Full_Package.zip, is that correct?

i'll need to set this up in a unique directory as to not conflict with my current version of 1.5 that I'm currently on. I Have downloaded this version and looked at the install documentation but am confused as to the correct steps. First, I want to be able to set this up as a "test version" and right now do not have a host selected as GoDaddy (my current host) only supports v2.5.14. How do I proceed?

Re: Apache Server at www.mysite.com Port 80

Posted: Sun Jul 26, 2015 11:12 pm
by dpacadmin
The latest versions are Virtuemart 3.0.6 and Joomla 3.4.3 . If GoDaddy doesn't list the latest versions in their script installer you will need to install manually. There are instructions here;
https://docs.joomla.org/J3.x:Installing_Joomla
You will need to create a new database for your new Joomla install to run from, look for instructions for doing that on GoDaddy's site.

Joomla 2.5 support ended Dec 2014, there are no more updates for it should there be any security issues with it.

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 27, 2015 1:44 pm
by FoxTek
Instructions say I can install a copy on a local computer for testing or development. Do I need to install all of the prerequisite software including the database onto my local computer and if so, where do I find such programs and are there instructions on how to do this?

Re: Apache Server at www.mysite.com Port 80

Posted: Mon Jul 27, 2015 2:06 pm
by Per Yngve Berg
Use LAMP, MAMP, WAMP or XAMP for development, depending on the OS you are running. These packages contains all you need (Web server, Database and Php).