Strange Joomla behavoir

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
abrodski
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 142
Joined: Fri Jul 10, 2009 10:08 pm

Strange Joomla behavoir

Post by abrodski » Sat Oct 10, 2015 3:34 am

Hello!
I've got an old Joomla 1.5 site with Virtuemart . I'm trying to use a payment module (written in PHP, of course), but when I input the necessary information, it automatically turns out into gibberish (like < echo bla bla etc>).
Also (maybe it could point us in a right direction)... It takes me 2-3 clicks to save the changes I make in Joomla admin panel.

itoctopus
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4026
Joined: Mon Nov 25, 2013 4:35 pm
Location: Montreal, Canada
Contact:

Re: Strange Joomla behavoir

Post by itoctopus » Sat Oct 10, 2015 6:29 am

Have you checked to make sure that your website is not hacked? Also, can you provide more context, like what is turning into gibberish, is it your entire Joomla website or just the module? And what is the name of that module?
http://www.itoctopus.com - Joomla consulting at its finest
https://twitter.com/itoctopus - Follow us on Twitter

User avatar
abrodski
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 142
Joined: Fri Jul 10, 2009 10:08 pm

Re: Strange Joomla behavoir

Post by abrodski » Sat Oct 10, 2015 3:59 pm

Thanks for your reply!
No, the site is not hacked. And all that is installed so far working great.
I'm talking ONLY about INSTALLING stuff inside admin panel of Joomla. You won't see it on the front end. What I've installed so far is working fine, actually. BUT (it's a big but), since it's an e-commerce site I must enable a module to accept payments from the future customers. But I can't install it in Joomla's back-end. Joomla simply doesn't save the changes that I make. Or... it puts some PHP pieces of code (like < ? echo bla-bla-bla> in the fields where I put some information needed for the module to function. Like my password etc. Anothe clue to the problem is that when I generally do stuff in Joomla's back-end, I have to save changes a few times. Like I save once, but nothing changes. All remains as it was before... I've never experienced that before since I'd started using Joomla 6 years ago. It's 2 e-commerce modules to accept credit cards etc. Robokassa and RBK Money (it's a local stuff, not something known world wide, I would think). It's not something you install like a Joomla component or a module. It's different somewhat. I have a few PHP files that I manually put into certain Virtuemart directories. Then I go to the place in Virtuemart admin panel where I can add a new form of payment. And there I have to input some info (passwords etc.) and then save it. Normally, it should update specific PHP file (the one that I put prior to that). And then when I make a purchase I see that new form of payment (Robokassa or RBK Money), it's just a link basically to their web site where I can provide my credit card details and finalize the purchase.


Locked

Return to “Administration 1.5”