Page 1 of 1

Problems with website

Posted: Mon Dec 07, 2015 11:58 pm
by marykvoss
I have a jooma 1.5 website here

http://www.mo-countrycars.com

Getting tons of error messages. We recently upgraded to php 5.4.0 on our web server, could that be the reason for the error messages? I need that version of php for another website on the server. If that is the reason for the errors, how can I fix this?

Thanks in advance for any help.

Mary

Re: Problems with website

Posted: Tue Dec 08, 2015 12:34 am
by itoctopus
Yes - the reason is the update to 5.4.0. Just open the configuration.php file and set $error_reporting to "none" instead of "Maximum". If you're able to login to the backend, then you can do this from the backend itself.

Re: Problems with website

Posted: Tue Dec 08, 2015 12:58 am
by marykvoss
Well, it was set to -1, not maximum

I switched to none and am still getting the errors

Re: Problems with website

Posted: Tue Dec 08, 2015 1:03 am
by marykvoss
I just tried switching to 0 instead of none, that didn't work either

Re: Problems with website

Posted: Tue Dec 08, 2015 5:54 am
by itoctopus
Sorry about that - since you are using Joomla 1.5 then the value must be -1 (the instructions I gave you were for Joomla 1.6+ - my mistake).

Since you are still seeing the errors, then most likely the error reporting is being overridden somewhere else (maybe in the index.php file, in the template, or somewhere else)... You can try finding where it's overridden, or maybe suppressing the problem in each line by adding "@" just before the function call.

You can also open the file "/home/.../libraries/joomla/application/application.php" and just add the following code to its very beginning:

Code: Select all

error_reporting(0);
You should also do the same for the other affected files.

Yet another solution would be to actually fix the code in each line (which is the best solution) - but it's probably not the easiest solution.

Re: Problems with website

Posted: Tue Dec 08, 2015 4:31 pm
by marykvoss
I just edited the php configuration and turned off error reporting, that worked

Re: Problems with website

Posted: Tue Dec 08, 2015 5:13 pm
by xfsgpr
marykvoss wrote:I just edited the php configuration and turned off error reporting, that worked
Are you still using version 1.5? Do you know the risk you are taking in using an unsecured package?

I would strongly recommend you to upgrade to version 3.4.5 as soon as possible. this would give you better security and also new features and responsive templates.

More and more people are using mobile devices and so it is vital that you keep up with them.

Good luck.