Error 500 after hosting provider to upgrade PHP 5.6

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Tue Feb 02, 2016 8:47 pm

Good afternoon, friends, I have problem in a joomla site, stopped working after hosting provider to upgrade PHP in version 5.6, shows the following error messages:

Warning: Creating default object from empty value in /home/luizfuganti/escolanomade.org/components/com_sh404sef/shInit.php on line 57

SH404SEF : headers were already sent when I got control!
Killed at line 126 in sh404sef.inc.php: HEADERS ALREADY SENT (200)
URL=http://escolanomade.org/
OPTION=com_content

I request help to restore the site.

<version>1.5.17</version>
<creationDate>2010-05-11</creationDate>

Thanks !!
You do not have the required permissions to view the files attached to this post.

 

mbabker
Joomla! Hero
Joomla! Hero
Posts: 2273
Joined: Sun Feb 28, 2010 8:26 pm

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by mbabker » Tue Feb 02, 2016 10:35 pm

Joomla 1.5 most likely won't function on PHP 5.6. Even with error reporting turned off, there's a good chance you're just going to end up on a white screen. For a 1.5 site, your best bet is to run with PHP 5.3 or 5.4 with error reporting turned off (5.3 was the last version things worked OK on, 5.4 started spitting out miles of messages on each page because of internal PHP changes).

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26799
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by Per Yngve Berg » Tue Feb 02, 2016 10:52 pm

<version>1.5.17</version>
You are not even running 1.5.26.
http://joomlacode.org/gf/download/frsre ... ackage.zip

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 10:01 am

Hello, guys, I managed to restore the back end, joined by the administrative, I tried to update the SH404SEF component but did not work. So I uninstalled it, and the site returned, but in a very old template version, whose layout was all disfigured.

Mbabker, Dreamhost hosting provider PHP runs not less than 5.6, unfortunately.

Per Yngve Berg, the site is running 1.5.15, the administrative panel does not update because it is very old, I believe.

Customer announced the job and I applied, I'm just now learned that the former manager installed joomla in 2010 and never did update the framework.

My task now is to update the joomla the best possible version and attempt to restore closer than it was before the Dreamhost have made the switch to PHP 5.6.

Thanks !!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26799
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by Per Yngve Berg » Thu Feb 04, 2016 10:12 am

You don't use the Administrator to update 1.5. Unzip the update package and upload with ftp.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Thu Feb 04, 2016 11:19 am

msanches wrote: Mbabker, Dreamhost hosting provider PHP runs not less than 5.6, unfortunately.

Per Yngve Berg, the site is running 1.5.15, the administrative panel does not update because it is very old, I believe.

Thanks !!
First update your joomla to 1.5.26 with upload the files of the patch as @Per Yngve Berg said you.
Then if you want to stay to your host with php 5.6 , migrate your joomla 1.5.26 to joomla 3.4.8 https://docs.joomla.org/Joomla_1.5_to_3 ... _Migration
You can do it also local to your pc if you want with xampp or wamp server if you want
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 11:41 am

Hmmm, I understand, Per Yngve Berg, then I send the directories and files from version 1.5.16 through FTP client and overwrite whatever is there on the server? That's it? OK !!

Ribo, is not a simple desire run on PHP 5.6, it's a requirement, Dreamhost is forcing me to do so, their server is not giving option to change PHP version.

Thanks, guys, I will now update to 1.5.26, if this works, we went to the next step, update further ...

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Thu Feb 04, 2016 11:48 am

msanches wrote: Ribo, is not a simple desire run on PHP 5.6, it's a requirement, Dreamhost is forcing me to do so, their server is not giving option to change PHP version.
I i understood what happens with Dreamhost. I was just told you or you change host with php 5.3.29 or you stay with php 5.6 and you migrate your joomla to 3.4.8 (i recommend this).
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 12:05 pm

This update via FTP, need special care? Directories can be sent in any order, just overwriting the conflict? Some of these files should I avoid?
You do not have the required permissions to view the files attached to this post.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Thu Feb 04, 2016 1:01 pm

Just overwrite the files of update patch of joomla 1.5.26 in the root folder of your joomla.
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 2:08 pm

Ribo, I am not able to find them (files of update patch). The folder plugins / system?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26799
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by Per Yngve Berg » Thu Feb 04, 2016 2:19 pm

Upload and overwrite all of it.

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 2:31 pm

Oh yeah, okay, thank you !!

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 3:45 pm

In includes folder can not change permissions ...
Command: SITE CHMOD 775 includes
Answer: 550 CHMOD 775 includes: Operation not permitted
Command: SITE CHMOD 755 includes
Answer: 550 CHMOD 755 includes: Operation not permitted

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Thu Feb 04, 2016 6:59 pm

msanches wrote:In includes folder can not change permissions ...
Command: SITE CHMOD 775 includes
Answer: 550 CHMOD 775 includes: Operation not permitted
Command: SITE CHMOD 755 includes
Answer: 550 CHMOD 755 includes: Operation not permitted
Ask from your host to fix it. folders have 755 and files 644
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Thu Feb 04, 2016 9:37 pm

Ok, Ribo, thanks

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 1:38 am

Well, my friends, I think I could upgrade in version 1.5.26. The next step would be to upgrade to 2.5.x, is that correct?

The method would be the same?

I appreciate the help offered to me so far, my client is very hopeful to see the site running properly !!
You do not have the required permissions to view the files attached to this post.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Fri Feb 05, 2016 6:55 am

The next step is to migrate to the latest version of j 3.x . The method is differend. Please check https://docs.joomla.org/Joomla_1.5_to_3 ... _Migration
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 9:43 am

Okay, Rigo, will follow step by step, thank you very much for now !!

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 1:33 pm

Ok, I read the article, but I found it confusing. Look, there're talking about "migration tools", i only use phpMyAdmin and FTP FileZilla client, a PHP editor, nothing ... can i migrate joomla using only these tools? See, let me explain, i am a php programmer, working in programming lines of code, you see, the frameworks i use are Cake, CodeIgniter, "Prado", the logic is different from the CMS, but now I'm with this demand a customer's friend rushed using joomla, but the site was abandoned this in 2010, he trusts me as a developer but unfortunately I've never worked with joomla, the last CMS that I worked it was in the 90s PHPNuke ... (!!!)

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 2:21 pm

I do not know if my logical thinking is deceiving me, but it is interesting to note that the database has many differences from one version to the other, even the fields of jos_menu table 1.5.26 version is equal to the same table fields in version 3.5 ... in the old version: id, menutype, name, alias, link, type ... in the new version: id, menutype, title, alias note ... this case is not a sequel, there is a break, there was a need to change the names of the table fields, that strange thing ... in fact it is necessary to have special software that make these changes as to make them manually will take forever ...

User avatar
fcoulter
Joomla! Ace
Joomla! Ace
Posts: 1685
Joined: Thu Sep 13, 2007 11:39 am
Location: UK
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by fcoulter » Fri Feb 05, 2016 2:54 pm

Yes, you really do need special software, particularly when migrating from 1.5 to 2.5, you really could not hope to accomplish this using just PHPMyAdmin.

There are various migration tools listed in the Joomla extensions directory: http://extensions.joomla.org/category/m ... mitstart=0. I can recommend SP Upgrade from my own experience, but there are some others which are probably good too, I expect others can recommend them.
http://www.spiralscripts.co.uk for Joomla! extensions
http://www.fionacoulter.com/blog my personal website
Security Forum moderator :: VEL team member
"Wearing my tin foil hat with pride"

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Fri Feb 05, 2016 3:14 pm

fcoulter wrote:Yes, you really do need special software, particularly when migrating from 1.5 to 2.5, you really could not hope to accomplish this using just PHPMyAdmin.
Now with these extensions he can migrate from j 1.5 to j 3.x .
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 3:58 pm

scouter, thank you for your contribution, if so, whether the tool is the free software philosophy, I will use it.
Okay, Ribo, thank you, you have helped me a lot, I'm glad to find them here !!

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 4:44 pm

That complex thing ... "Error! No XML file configuration of Joomla! Has been found in the package."
You do not have the required permissions to view the files attached to this post.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Fri Feb 05, 2016 7:26 pm

What are you trying to install?
chat room spontes : http://www.spontes.com

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Fri Feb 05, 2016 7:32 pm

Now i saw what are you trying to install. Every extension usually has a documentation. When you want to see what is better extension check the reviews
chat room spontes : http://www.spontes.com

msanches
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Jan 30, 2016 2:03 am

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by msanches » Fri Feb 05, 2016 10:41 pm

OK, Ribo, but the system is returning that there is no XML file in the package, when the XML file is present there in the package ... are strange things happening ...
You do not have the required permissions to view the files attached to this post.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3446
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Error 500 after hosting provider to upgrade PHP 5.6

Post by ribo » Fri Feb 05, 2016 10:48 pm

Is this compatible with joomla 1.5 or with joomla 3 and where do you try to install it? Also it s good to read their documentation and ask the creator if you want to use this extension.
chat room spontes : http://www.spontes.com

 

Locked

Return to “Administration 1.5”