Joomla 1.5 on PHP7 = JError Unable to load Database Driver

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
GTAlex
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 03, 2017 9:05 am

Joomla 1.5 on PHP7 = JError Unable to load Database Driver

Postby GTAlex » Fri Mar 03, 2017 9:08 am

Joomla 1.5 on PHP7

dbtype = "mysqli"
"JError Unable to load Database Driver"

try dbtype = "mysqli"
again
"JError Unable to load Database Driver"


help!

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2150
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Joomla 1.5 on PHP7 = JError Unable to load Database Driver

Postby mbabker » Fri Mar 03, 2017 1:29 pm

1.5 is not compatible with PHP 7. The last version it was actually compatible with without PHP warnings is PHP 5.3; it will run OK on 5.4 (and supposedly 5.5, I'm not sure on 5.6) but you will need to turn off error reporting because the platform will emit a lot of strict standards warnings due to its PHP 4 compatibility. You will need to downgrade PHP.
Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 26535
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Joomla 1.5 on PHP7 = JError Unable to load Database Driver

Postby imanickam » Fri Mar 03, 2017 1:43 pm

I doubt whether Joomla! 1.5 will run on PHP 7. As you would notice from the document https://docs.joomla.org/Joomla_1.5_won't_work_on_PHP_5.4 Joomla! 1.5 will not even work on PHP 5.4.

Be known that Joomla! 1.5 is no longer supported. The last version of Joomla! 1.5 is 1.5.26. In addition, there are two security hot fixed after v1.5.26.


Note:
As Joomla! 1.5 is no longer supported, you must plan to upgrade your site to Joomla! 3.6.5 (which is the latest version at present). Do the upgrade/migration in a test environment before attempting to upgrade the production live site.
- Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
http://www.eegan.org - helping the poor and underprivileged
educate. empower. enrich.
Support the poor and underprivileged


Return to “Administration 1.5”

Who is online

Users browsing this forum: No registered users and 14 guests