Page 1 of 1

JFTP::connect: Could not connect to host

Posted: Thu Jan 17, 2008 3:54 pm
by Wicer
I installed 1.5 RC4. Using ftp worked fine until recently. When I want to change something now I get the message:

* JFTP::connect: Could not connect to host on port 21
* JClientHelper::setCredentialsFromRequest failed

I use the same ftp username and password with which it worked so far! I have not changed anything. What can have happened?

Re: JFTP::connect: Could not connect to host

Posted: Sun Oct 19, 2008 9:54 pm
by Ian_B
I have just upgraded to 1.5.7 from 1.5.3 and now get the same error. Can anyone help please?

Re: JFTP::connect: Could not connect to host

Posted: Sun Oct 19, 2008 9:57 pm
by brad
Ian_B wrote:I have just upgraded to 1.5.7 from 1.5.3 and now get the same error. Can anyone help please?
Try disabling the FTP layer.

Re: JFTP::connect: Could not connect to host

Posted: Fri Oct 31, 2008 1:30 pm
by djseamus
judging by the number of users who're having serious issues with the ftp layer i can't believe the devs are persisting with it

Re: JFTP::connect: Could not connect to host

Posted: Sat Jan 17, 2009 2:13 am
by Gastrolith
I have exactly the same problem, and I do need to enable the FTP layer, as I have permission issues. This is driving me mad...
Has anyone found a solution yet?

Re: JFTP::connect: Could not connect to host

Posted: Sat Jan 17, 2009 4:06 am
by brad
Talk to your host? Put pressure on them to run suphp?
judging by the number of users who're having serious issues with the ftp layer i can't believe the devs are persisting with it
Good shared hosting setups don't need it anyway. If you need it.. and are having issues, read this: http://community.joomla.org/team-blogs/ ... -time.html and http://community.joomla.org/team-blogs/ ... en-up.html

Re: JFTP::connect: Could not connect to host

Posted: Sat Jan 17, 2009 4:36 pm
by Gastrolith
Thanks for your reply.
I did a phpinfo() and found that register_globals if OFF. I don't know how to check if they're running suphp. Can you tell me how to check it? I'm just a newbie.

By the way, my security problem was that Joomla was unable to work properly without CHMOD 777 in all files and directories. But this morning it got mysteriously fixed!!

Re: JFTP::connect: Could not connect to host

Posted: Wed May 20, 2009 3:17 pm
by sutliff
How do you disable the FTP layer? I looked in the global config but could find it.

Thanks.

Re: JFTP::connect: Could not connect to host

Posted: Wed May 20, 2009 3:40 pm
by sutliff
Strike that.
If it was snake it would have bit me. How embarrassing.

Re: JFTP::connect: Could not connect to host

Posted: Sun Sep 06, 2009 6:56 pm
by swapneal
Joomla Error: JFTP::login: Unable to login

While designing this site, I tried to upload some images to my articles. However, I received the following error message during the uploading:



JFTP::login: Unable to login

JFTP::write: Unable to use passive mode



I searched a lot, but could not find the solution. Then, at some forum, I figured out the issue. Here are the steps to solve the error:

1) Login to your administrator panel

2) Go to Site -à Global configuration -à Server

3) Under FTP settings, enter your FTP details and select yes for “Enable FTP”.

4) Click on Save at the upper right corner.



That’s It! After these settings, my error was completely resolved.

Re: JFTP::connect: Could not connect to host

Posted: Wed Oct 21, 2009 2:16 pm
by harial
FTP Host: try to use 「localhost」 instead of 「127.0.0.1」

Re: JFTP::connect: Could not connect to host

Posted: Thu Nov 26, 2009 12:16 am
by rthomas67
I had this same mystery for a while. Part of the problem turned out to be SELinux settings. Particularly, the httpd_can_network_connect boolean setting was "off" and had to be set to "on" before anything running under the httpd (Apache) process (like the Joomla! PHP files) would be able to establish an outbound network connection, even to localhost.

To check:
getenforce
...would display Enforcing
getsebool httpd_can_network_connect
....would report httpd_can_network_connect --> off

To set it temporarily and see if it helps:
setsebool httpd_can_network_connect=1

If it helped, set it in the selinux policy so it will survive a reboot:
setsebool -P httpd_can_network_connect=1

Re: JFTP::connect: Could not connect to host

Posted: Sun Feb 20, 2011 7:58 pm
by ahsharif
I have the same problem, but in a few features:
when I try to upload pictures to virtuemart do not warn me about FTP problem. But when I try to install a new plugin warns me:
# JFTP::login: Unable to login
# JFTP::store: Unable to use passive mode
Can anyone help me?

Re: JFTP::connect: Could not connect to host - Change hostna

Posted: Tue May 21, 2013 5:25 am
by vkpradeep
Hi,

Changing the hostname in FTP settings to 'localhost' solved my issue.

1) Login to your administrator panel

2) Go to Site -à Global configuration -à Server

3) Under FTP settings, enter your FTP details and select yes for “Enable FTP”.

4) Click on Save at the upper right corner.

Change it in var $ftp_host = 'localhost'; in configuration.php as well.