Article #22 not found

Discussion regarding Joomla! 1.5 Performance issues.
Locked
kenecm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 22, 2010 7:53 pm

Article #22 not found

Post by kenecm » Tue Nov 02, 2010 11:54 pm

My problem: Article #22 not found. The BlueHost tech I asked about this referred me to you. I can go to http://www.ecmin.org/joomla-ECM-two/adm ... /index.php and get in, but going to http://www.ecmin.org/joomla-ECM-two/ gives me an error 22.


I was asked to check this out for a possible solution: http://joomlacode.org/gf/project/joomla ... id=18050It looks like your joomla admin section is coming up at http://www.ecmin.org/joomla-ECM-two/administrator/ so you should be able to perform all operations mentioned here. I would also recommend checking out joomla support forums as this is a joomla-specific issue: http://forum.joomla.org/This is the tech response to my letter saying I am getting a 22 error:

Category:
Search Engine Friendly

Summary
**SEF category links lead to article not found**
Details

There is an option to display the category of an article and link that to a
category view. When a user is viewing an article, with SEF turned on those
category links will load an error page for article not found when no menu item
for the section or category is published.

To test:
set up a clean install of 1.5 with sample data
turn on sef in global config
unpublish 'More about Joomla' in the main menu
change the parameters of the 'Joomla Overview' menu item to display and create
links for the category
on the frontend, click the menu 'Joomla Overview'
click the category link

The tech. uploaded a patch for the content router to address the issue.

Details

There is an option to display the category of an article and link that to a
category view. When a user is viewing an article, with SEF turned on those
category links will load an error page for article not found when no menu item
for the section or category is published.

To test:
set up a clean install of 1.5 with sample data
turn on sef in global config
unpublish 'More about Joomla' in the main menu
change the parameters of the 'Joomla Overview' menu item to display and create
links for the category
on the frontend, click the menu 'Joomla Overview'
click the category link

He uploaded a patch for the content router to address the issue.

Here is my response to the BlueHost tech:

I did not set up a clean install , but I made the recommended changes shown in the test below and it did not work. I did that because yesterday

I was turning off all the Joomla stuff in the template on the frontpage, so felt that I could well have failed to turn off a Category that went with the
Sections and Articles. So turned everything back on ... in short ... made all those changes and I still get the 22 error.


Are you saying I should do a clean install back into joomla-ECM-two or into a newly created file?

You said you uploaded a patch for the content router. I don't know what that means. What is the patch and where is the content router, and how

am I to use it? Honest, I really don't know. Please help me through this. :-[

(You said) To test:
set up a clean install of 1.5 with sample data
turn on sef in global config
unpublish 'More about Joomla' in the main menu
change the parameters of the 'Joomla Overview' menu item to display and create
links for the category
on the frontend, click the menu 'Joomla Overview'
click the category link

User avatar
shibu
Joomla! Guru
Joomla! Guru
Posts: 681
Joined: Fri Oct 24, 2008 5:35 am
Location: Openkey Technologies, India
Contact:

Re: Article #22 not found

Post by shibu » Wed Nov 03, 2010 2:45 pm

Hi,

Login to your website admin side and check this article id 22 , Check the article id is published or not.
http://www.openkeytech.com/ - Joomla Extension Development

kenecm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 22, 2010 7:53 pm

Re: Article #22 not found

Post by kenecm » Mon Nov 08, 2010 9:21 pm

Hi Shibu,

Please excuse my taking so long to respond. I was at a conference for several days.

You are right, article ID 22 was not published and front page was not selected. By turning them on I was able to get my home page screen. BUT!!! The screen had a Joomla article in it. I had turned it off because it was one of the Joomla articles that came with the template.

I do not know what would happen if I were to delete the article and its section and category. I haven't deleted all that stuff so as to be able to keep track of where the segments are on the page so I could replace them.

I do not understand why turning them off hurt anything. They were off for days and I had done a lot of other work and all was well. Then when I came to work one morning the administrator screen would come up but the home page would not. So actually something else triggered this error 22 condition.

What do you think that condition was? Should I just delete all the Joomla articles, categories and sections to avoid other potential errors like this 22 thing?

I appreciate any instruction you give me, believe me.

Ken

kenecm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 22, 2010 7:53 pm

Re: Article #22 not found

Post by kenecm » Mon Nov 08, 2010 11:48 pm

Hi Shibu,

This is an addition to the message I sent to you earlier today.

Go to http://www.ecmin.org/joomla-ECM-two and see the code below the text. That code was not in the editable box, it is below it. That can not be right. I put the desired text in line 22, but it still is not correct, and the text that I put in and was showing fine is now not showing on front Page.

The text I originally put there was displaying properly for a few days ... and then went into this error 22 thing.

Thanks Ken

kenecm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Sep 22, 2010 7:53 pm

Re: Article #22 not found

Post by kenecm » Wed Nov 10, 2010 6:42 pm

Hi Shibu
I replied to your post two days ago and still have not received a reply. I think I have followed all the rules. Please respond!
I deleted the line 22 article since it was Joomla stuff that was in the template anyhow, and now I get a blank screen. But still can get into the administrator to make changes ... if I knew what to change.

vnesi12
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Mar 18, 2013 7:35 pm

Re: Article #22 not found

Post by vnesi12 » Mon Mar 18, 2013 7:55 pm

Thank you for this bookmark topic, I actually have the same problem as you probably!!
I get 404-error and at the end there was written Article #22 not found. I also did things you mention here. I get offline SEF-content plugin, sytem-backlink and i spent some time on trying ofline some of modules and plug-ins connected with Article with ID 22. I was REALLY angry. Ideleted modules that i allready install for forms and then I GET flash under head. Oh man what i am doing I deleted some articles before,beacuse i didn't need them anymore. I found out what it is logical and true mention of the problem,that i set priority nad first menu on article it didnt exist because i delete him. So I get article from trash and problem was solved,everything works normal as before:))


Locked

Return to “Performance - Joomla! 1.5”