Page 1 of 1

Help! Php 5.4.15 broke my 1.5 site

Posted: Thu May 23, 2013 6:26 pm
by Joshua_D
Hello,

I hope someone can be of some help. I manage a website for a local government in NC. Our web host upgraded to php 5.4.15 this morning and the upgrade pretty much broke my site.

The errors were flying.

I tried setting the error reporting to '0' in the configuration.pfp file, and that did nothing. All the errors and warnings continued to be displayed.

I then set the error level to '1' and that got rid of most of the errors. However, there is still a long list of Strict Standards errors showing up, and I can't manage to log into the back end.

The webiste is www.ci.morganton.nc.us.

Any help is greatly appreciate.

Re: Help! Php 5.4.15 broke my 1.5 site

Posted: Thu May 23, 2013 6:36 pm
by andymelichar
If I remember correctly, you just need to upgrade to the latest 1.5 version and there is a fix in place to work properly under PHP 5.4

Otherwise you can patch the files manually with the patches found in this thread: http://forum.joomla.org/viewtopic.php?f ... 6#p3022148

YMMV. You should upgrade to 2.5 as soon as possible, 1.5 is no longer supported.

Re: Help! Php 5.4.15 broke my 1.5 site

Posted: Fri Oct 18, 2013 12:56 pm
by Joshua_D
Thank you for the reply. I worked out a temp fix and did finally move to 2.5.