Homepage takes 10+ seconds to load

Discussion regarding Joomla! 1.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Sarah_Watson
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Mar 09, 2015 5:19 pm

Homepage takes 10+ seconds to load

Post by Sarah_Watson » Mon Mar 09, 2015 5:26 pm

Hi, I am a first time poster here.
I have taken over administration of my company's website which is through Joomla. I am not super familiar with it, but I am doing ok so far, however, I cannot figure out why the homepage is taking so long to load. It is only the homepage, every other page loads without difficulty.
The website is http://www.triplecdist.com.
Any help would be much appreciated.

jcms
I've been banned!
Posts: 2233
Joined: Wed Nov 19, 2014 9:23 am

Re: Homepage takes 10+ seconds to load

Post by jcms » Mon Mar 09, 2015 6:02 pm


almooj-craig
Joomla! Guru
Joomla! Guru
Posts: 500
Joined: Mon Aug 11, 2008 3:05 pm

Re: Homepage takes 10+ seconds to load

Post by almooj-craig » Tue Mar 31, 2015 1:44 am

Hello,

Just glancing at your site using webpagetest.org
http://www.webpagetest.org/result/15033 ... 1/details/

It shows that joomla is taking way too long to generate the file, so basically nothing can happen until that file has been sent to the browser. It takes about 10.5 seconds then the various other problems like multiple css files and lots of js files and loading js files before css files cause the start to render time to come in at about 11.19 seconds. Basically you have a blank white page for 11.19 seconds.

Currently you are not using any caching, so I think the simplest thing to try first would be to turn on the page caching plugin (plugins->system->cache) and see if that makes anything on your site go haywire. It would most likely shave 8 or 9 seconds off the home page file loading.

Craig

Sarah_Watson
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Mar 09, 2015 5:19 pm

Re: Homepage takes 10+ seconds to load

Post by Sarah_Watson » Wed Apr 01, 2015 3:47 pm

Thank you so much for all the suggestions; I have not been able to log back in to try to change any of the things yet (I'm also the graphic designer, things get a little busy for me.) But I will check out both of the things mentioned, and I will post back what happens.
Thank you again, it means a lot to receive help.

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11722
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Homepage takes 10+ seconds to load

Post by brian » Wed Apr 01, 2015 4:13 pm

Before doing anything else - disable the newsfeed module from the homepage and retest

Yes there are a lot of optimisations you can do to the site but as almooj-craig says they are after the main problem
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/


Locked

Return to “Performance - Joomla! 1.5”