Feil ved kjøring av 1.5.26

Spørsmål om administrasjon og installering

Moderators: sone12, Per Yngve Berg

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Feil ved kjøring av 1.5.26

Postby ingeva » Fri Jan 17, 2014 10:34 pm

Jeg trenger å oppgradere en 1.5.26 nettside og har kopiert alle filer og database til min egen maskin. Jeg får følgende feil når jeg prøver å kjøre:

Strict Standards: Non-static method JLoader::import() should not be called statically in /Digi/Nyhag/libraries/joomla/import.php on line 29

Hva er det som mangler? Er min php-versjon for ny (5.4.19)? I så fall er det noe jeg kan gjøre? Jeg vil helst benytte denne kopien for oppgradering så jeg slipper risikoen ved å gjøre det på en nettside som fremdeles virker (Vel, sånn noenlunde :) ).

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Re: Feil ved kjøring av 1.5.26

Postby ingeva » Sat Jan 18, 2014 5:59 am

I den engelske delen av forumet fant jeg en beskrivelse av hvordan fjerne denne filutskriften ved å modifisere php.ini. Det hadde ingen effekt.
Hvis jeg ignorerer filene og går videre, kommer jeg til at nettleseren ikke tillater cookies. Det gjør den, men derfra er det ingen vei videre (kun tilbake-knapp).

Så jeg sitter fast. Noen ideer?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Feil ved kjøring av 1.5.26

Postby Per Yngve Berg » Sat Jan 18, 2014 5:18 pm

Joomla 1.5 kjører ikke på php 5.4.

Skaff deg en XAMPP-versjon med php 5.2 eller 5.3.

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Re: Feil ved kjøring av 1.5.26

Postby ingeva » Sat Jan 18, 2014 5:51 pm

Per Yngve Berg wrote:Joomla 1.5 kjører ikke på php 5.4.

Skaff deg en XAMPP-versjon med php 5.2 eller 5.3.

Jeg hadde mistanke om det ja, men XAMPP vil ikke kjøre hos meg. Den nekter å starte serveren. Jeg vurderer å greie meg uten: Installere en nyere versjon og bygge alt opp fra grunnen. Det har jeg gjort tidligere med godt resultat. Mer jobb, men får et ryddigere system.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Feil ved kjøring av 1.5.26

Postby Per Yngve Berg » Sat Jan 18, 2014 7:13 pm

Prøv SPUpgrade. Den vil migrere uten at den gamle virker.

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Re: Feil ved kjøring av 1.5.26

Postby ingeva » Sun Jan 19, 2014 10:12 am

Per Yngve Berg wrote:Prøv SPUpgrade. Den vil migrere uten at den gamle virker.
Ah!
Takk for det!
Dette ser ut til å være tingen!
Jeg skal formidle det til eierne av siden, siden det koster €30. Det er sikkert ikke noe problem.

Jeg vurderer å oppgradere til 3.2.1 istedenfor 2.5.17. Dette er en stor side, og de vil gjerne ha et galleri. Jeg ville helst hatt galleriet separat fra Joomla!. Jeg regner med at det gamle galleriet, som er en Joomla extension, ikke er noe å satse videre på... Hva mener du er best?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Feil ved kjøring av 1.5.26

Postby Per Yngve Berg » Sun Jan 19, 2014 11:10 am

Det er flere gode gallery extensions. Selv bruker jeg phoca gallery.

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Re: Feil ved kjøring av 1.5.26

Postby ingeva » Sun Jan 19, 2014 11:38 am

Per Yngve Berg wrote:Det er flere gode gallery extensions. Selv bruker jeg phoca gallery.

Jeg bruker Phoca Gallery på en annen side. Det var det beste jeg fant, og det er mildest talt elendig, og så å si ingen support. Det er meget mulig at jeg bygger opp mitt eget galleri, kanskje basert på lightbox. Vi får se, jeg må ta en ting om gangen. :)

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Feil ved kjøring av 1.5.26

Postby Per Yngve Berg » Sun Jan 19, 2014 11:55 am

Utvikleren er meget aktiv og det er et support-forum her: http://www.phoca.cz/forum

ingeva
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Mon Jul 27, 2009 9:56 am

Re: Feil ved kjøring av 1.5.26

Postby ingeva » Sun Jan 19, 2014 12:37 pm

Per Yngve Berg wrote:Utvikleren er meget aktiv og det er et support-forum her: http://www.phoca.cz/forum

Been there, done that, men det er vel et års tid siden. Jeg ga opp å få hjelp der. Kanskjedet er bedre nå? Uansett var jeg ikke særlig fornøyd med programvaren, og integrerte enheter er ofte en dårlig ide. Det blir gjerne problemer ved oppgraderinger. Best å holde dem fra hverandre, syns jeg. Det er heller ikke bra et det er avhengig av én person.


Return to “Administrasjon/installasjon”

Who is online

Users browsing this forum: No registered users and 4 guests