Page 1 of 1

[Løst] .htaccess

Posted: Tue Nov 09, 2010 2:57 pm
by perbjune
hei
Jeg har opprettet en php.ini fil lagt i rot og lagt inn nye verdier på max_file_size etc. Og jeg opprettet også da .htaccess siden dette var nødvendig. Her skal jeg da fylle inn følgende suPHP_ConfigPath/home/brukernavn

Problemet er at i cpanel (bruker proisp) så synes ikke denne, mens i winscp som jeg bruker så kan jeg se den men ikke røre...dvs får ikke åpnet eller redigert den.

Hva kan jeg gjøre for å få til dette ? Og et spørsmål til..kanskje litt dumt men i php ini filen skal det være mellomrom før og etter = tegnet ?

Re: .htaccess

Posted: Tue Nov 09, 2010 6:12 pm
by rued
I cPanel, velg 'File Manager' og kryss av for 'Show Hidden Files (dotfiles)' i sprettopp-vinduet.
Får du ikke opp noen vindu med slikt valg ruller du ned til bunnen av cPanel og klikker på 'reset all interface settings'

For å kunne redigere via ftp må du sette riktige filrettigheter på fila.

Re: .htaccess

Posted: Wed Nov 10, 2010 2:30 am
by perbjune
Da lærte jeg noe nytt idag å...så takk for tipset Rued :)

Samtidig så oppstod det noe jeg ikke har sett før. I cpanel og filmanager så kan jeg se filstrukturen til venstre men når jeg trykker på noe der så kommer det ikke opp noe annet enn et bittelite vindu helt øverst i venstre hjørne...der hvor alle mapper og filer skulle vist seg. Dette er kun IE, mens Firefox er det som normalt

Re: .htaccess

Posted: Wed Nov 10, 2010 2:49 am
by perbjune
Og rett etter siste innlegget så kom jeg ikke inn på nettsiden men fikk denne feilmeldingen

The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, webmaster@...... and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Derfor slettet jeg .htaccess filen og da funket det igjen. Hva er dette for noe rart da tro ?
og etter å titte på errorloggen

[Wed Nov 10 03:42:04 2010] [alert] [client 90.149.101.31] /home/....../public_html/.htaccess: Invalid command 'suPHP_ConfigPath/home/.....', perhaps misspelled or defined by a module not included in the server configuration
[Wed Nov 10 00:54:54 2010] [error] [client 80.212.18.191] File does not exist: /home/....../public_html/404.shtml
[Wed Nov 10 00:54:54 2010] [error] [client 80.212.18.191] File does not exist: /home/....../public_html/images/favicon.ico
[Tue Nov 09 22:58:31 2010] [error] [client 90.149.101.31] File does not exist: /home/..../public_html/404.shtml, referer: http://.....no/index.php?option=com_alphauserpoints&view=buypoints&Itemid=9
[Tue Nov 09 22:58:31 2010] [error] [client 90.149.101.31] File does not exist: /home/....../public_html/components/com_alphauserpoints/assets/images/paypal_buttons/-1, referer: http://......./index.php?option=com_alphauserpoints&view=buypoints&Itemid=9


Skjønner ikke så mye hvorfor jeg får denne meldingen her, men ser jo at commandoen jeg la inn i .htaccess filen anses som ugyldig av en eller annen grunn. Lurer også på hvorfor jeg får files does not exist på komponenten com_alphauserpoints

Re: .htaccess

Posted: Wed Nov 10, 2010 7:52 am
by rued
http://www.proisp.no/konfigurasjon_php_ini/
/home/brukernavn/ skal erstattes med sti til mappen der du har lagt php.ini filen.
Du gir veldig lite opplysninger om hva du faktisk har gjort, og hva du vil oppnå ...

Re: .htaccess

Posted: Wed Nov 10, 2010 12:23 pm
by perbjune
Det jeg ville opppnå er å forandre/øke endel størrelser i forhold til standard. Jeg lagde da en php ini fil i rot, dvs home/mitt brukernavn med følgende innhold

upload_max_filesize = 20M
max_file_uploads = 30
post_max_size = 20
memory_limit = 128M

deretter opprettet jeg altså en .htaccess fil i public.html (hvor joomla ligger) med følgende innhold
suPHP_ConfigPath/home/mitt brukernavn. Da skulle vel konfig i php ini filen gjelde for alle filer under public.html deriblant joomla.

Nå ser jeg at der finnes .htaccess både i rot (home/brukernavn), og under public.html og www
Og alle er tomme inni

Re: .htaccess

Posted: Thu Nov 11, 2010 7:23 pm
by rued
Riktig skal være
suPHP_ConfigPath /home/...

Dvs. mellomrom mangler hos deg.

Anbefaler forøvrig at du legger både denne htaccess-fila og din tilpassede php.ini utenfor webrota (direkte under din bruker), så ligger de tryggere.

Re: .htaccess

Posted: Wed Dec 08, 2010 7:35 pm
by perbjune
Takk det hjalp :)

Trodde jeg hadde svart på denne, men tydeligvis ikke så beklager for det. Setter den til løst nå

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 10:19 am
by corex76
Hei....
Klarer ikke å få dette til å fungere.
Har laget en php.ini under public_html med innholdet:
upload_max_filesize = 20M;
post_max_size = 20M;
max_execution_time = 300;

Og endret .htaccess med innhold:
suPHP_ConfigPath /home/brukernavn/

Er sånn jeg forstår det fra tråden at det skal være, men ingen endring skjer. Noen som kan hjelpe?

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 2:06 pm
by rued
Om du leser guiden nøye vil du se at brukernavn skal erstattes med ditt brukernavn/din web-bruker.

Videre, om du skal ha php.ini og .htaccess under public_html må du naturligvis legge til dette i stien:
suPHP_ConfigPath /home/DITT-BRUKERNAVN/public_html/

Men tryggest er jo naturligvis å legge det et nivå opp, samt bruke komplett php.ini ...

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 4:41 pm
by corex76
Hei...
php.ini ligger nå under: home/DITT-BRUKERNAVN/ og .htaccess ligger under: /home/DITT-BRUKERNAVN/public_html/ med suPHP_ConfigPath /home/DITT-BRUKERNAVN/.

Da burde filsti være korrekt, men fortsatt ingen endring.

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 6:47 pm
by rued
Hvorfor ikke ha .htaccess og php.ini på samme nivå, som anbefalt/beskrevet?
Kjører server suPHP?

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 10:41 pm
by corex76
Fungerer ikke det heller....
Om server kjører suPHP har jeg ingen anelse om. Ligger hos Proisp.

Re: [Løst] .htaccess

Posted: Sat Jan 08, 2011 11:10 pm
by rued
Om det ikke fungerer har du feil, hva som er feil kan drimot neppe noen si ut fra de opplysninger som er gitt så langt.

Og vi må vel gå ut fra at du faktisk bruker ditt brukernavn i sti ... og ikke DITT-BRUKERNAVN ...

Re: [Løst] .htaccess

Posted: Sun Jan 09, 2011 1:13 am
by corex76
Takk for at du holder ut....

Filene php.ini og .htaccess ligger nå under home/brukernavn/public_html.

php.ini inneholder:upload_max_filesize = 20M;
post_max_size = 20M;
max_execution_time = 300;

.htaccess inneholder: suPHP_ConfigPath /home/brukernavn/public_html/

Det er oppsettet jeg nå har.

Re: [Løst] .htaccess

Posted: Sun Jan 09, 2011 1:28 am
by rued
Eh ... ditt brukernavn er det navnet som din konto er satt opp på, du er vel inneforstått med det?
Det skal ikke stå 'DITT-BRUKERNAVN' eller 'brukernavn', men det brukernavnet som du har fått fra PROISP - som er en del av stien til ditt område på serveren.

... {boink} ...

Re: [Løst] .htaccess

Posted: Sun Jan 09, 2011 9:31 am
by corex76
Heheh... det har jeg forstått. Bruker brukernavnet jeg har fått fra ProISP