Problemer med java-kode i en banner modul

Spørsmål relatert til tredjepartsutvidelser som komponenter, moduler etc.

Moderators: sone12, Per Yngve Berg

janbso
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 24, 2011 10:49 pm
Location: Costa Blanca
Contact:

Problemer med java-kode i en banner modul

Postby janbso » Wed Nov 09, 2011 3:39 pm

Har nå slitt med et problem i en uke og har søkt hjelp et utall steder.
Setter nå min lit til dere klokeste hoder.
(det er også litt lettere å kommunisere på eget språk)

Kjører Joomla 1.5
Skal legge inn java kode i en banner modul
Klippe og lime går greit. Midt inne i koden har jeg denne linjen;


document.write(unescape("%3Cscript src="/ + zfBaseURL
+ " type=\"text/javascript\"%3E%3C/script%3E"));

Det som skjer er at ETTER at jeg har lagret modulen, smetter det inn en "slash". Jeg har markert den i Bold og stor. Den synes kun på siten, men IKKE når jeg tar opp koden i modulen igjen.
Denne slashen gjør selvsagt at scriptet ikke er korrekt og kjører ikke.

Jeg har også forsøkt å lime koden inn i andre moduler s.s. "Special HTML for Joomla 1.5" som jeg finner veldig robust.

Er det noen der som kan hjelpe.
For å se koden på siten min finnes URL i signatur nedenfor.
Problemet finner dere helt nede til venstre på førstesiden.
Last edited by rued on Wed Nov 09, 2011 4:19 pm, edited 2 times in total.
Reason: Endret til en forklarende tittel. Vennligst les forumreglene!
Jan B.Sørensen
CTO http://www.mittspania.com

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4753
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: Problemer med java-kode i en banner modul

Postby rued » Wed Nov 09, 2011 4:20 pm

Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no

janbso
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 24, 2011 10:49 pm
Location: Costa Blanca
Contact:

Re: Problemer med java-kode i en banner modul

Postby janbso » Wed Nov 09, 2011 4:24 pm

Ja, som jeg sa har jeg postet den også i det forumet uten å få svar. Jeg har bedre erfaring med dere her på den norske avdelingen.
;)
Jan B.Sørensen
CTO http://www.mittspania.com

User avatar
zenior
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Tue Mar 06, 2007 7:20 pm
Location: Sandefjord - Norway
Contact:

Re: Problemer med java-kode i en banner modul

Postby zenior » Fri Nov 11, 2011 6:49 am

Dette ligger ganske sikkert i teksteditoren din... forsøkte samme scriptet her, først med problemer, deretter feilfritt med følgende innstillinger i TinyMCE:
You do not have the required permissions to view the files attached to this post.

janbso
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 24, 2011 10:49 pm
Location: Costa Blanca
Contact:

Re: Problemer med java-kode i en banner modul

Postby janbso » Fri Nov 11, 2011 8:45 am

Jeg var nesten helt sikker på at du hadde løsningen. Etter 1 time med fram og tilbake kom jeg til at det ikke ligger der.
Når man bruker banner modulen er man ikke innom editoren i det hele tatt.

Gjør jeg derimot et forsøk på å lage et dokument med koden og plasserer dokuemtet et eller annet sted, vises koden så fint som bare det.

Jeg har selvsagt også forsøkt med mange andre editorer.

Er det noen mulighet for å plassere et dokument til venstre eller høyre i min template?
Jan B.Sørensen
CTO http://www.mittspania.com

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4753
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: Problemer med java-kode i en banner modul

Postby rued » Fri Nov 11, 2011 9:25 am

Hvorfor vil du bruke bannermodul/-komponent til dette?
Kan du ikke bare bruke 'Egendefinert HTML'?
Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no

janbso
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 24, 2011 10:49 pm
Location: Costa Blanca
Contact:

Re: Problemer med java-kode i en banner modul

Postby janbso » Fri Nov 11, 2011 1:15 pm

Jeg har selvsagt også forsøkt det, med samme resultat. Vet snart ikke hva jeg ikke har prøvd.
Vet at dere klarer å løse problemet, så jeg setter over kaffen så lenge. ;)
Jan B.Sørensen
CTO http://www.mittspania.com

User avatar
zenior
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Tue Mar 06, 2007 7:20 pm
Location: Sandefjord - Norway
Contact:

Re: Problemer med java-kode i en banner modul

Postby zenior » Fri Nov 11, 2011 5:58 pm

Det fungerer i modul med egendefinert html, det var nemlig det jeg forsøkte, men du mister egen telling på visninger som du sikkert er ute etter ved å benytte bannermodulen...

celius
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 108
Joined: Tue Aug 23, 2005 8:32 pm

Re: Problemer med java-kode i en banner modul

Postby celius » Sun Nov 13, 2011 10:37 pm

I TinyMCE innstillingene setter du:
Rydding i kode ved åpning: av
Rydding i kode ved lagring: av

Gå inn i modulen din (det beste vil være en modul som er myntet på å bruke kode) å lagre. Etterpå kan du godt slå på de settingene du slo av, så lenge du ikke går inn på modulen og lagrer igjen.

Virket dette? Let me know.

janbso
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 24, 2011 10:49 pm
Location: Costa Blanca
Contact:

Re: Problemer med java-kode i en banner modul

Postby janbso » Mon Nov 14, 2011 10:55 pm

Eksakt samme resultat.


Brukte også denne gangen modulen "Special HTML" som jeg aldri har hatt problemer med før
Jan B.Sørensen
CTO http://www.mittspania.com


Return to “Komponenter/moduler/programutvidelser”

Who is online

Users browsing this forum: No registered users and 1 guest