Exploit i MMS Blog [LØST]

Sikkerhet i Joomla! 1.5 og tilhørende elementer som server etc.

Moderators: sone12, Per Yngve Berg

Post Reply
spurv
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Jan 14, 2009 2:31 pm

Exploit i MMS Blog [LØST]

Post by spurv » Wed May 12, 2010 11:55 am

Hei!

Jeg har fått meg en liten utfordring. Jeg er plaga med LFI/RFI attacks pga. en svakhet i MMS Bloggen jeg har.

Det er et slik type angrep som blir gjort på siden min, men ikke akkurat dette.
http://www.exploit-db.com/exploits/12318


Jeg kjører ver. 1.5.17 Stable, og synes det er fryktelig kjedelig å finne ukjente filer i Joomla.

Er det noen som tror dem kan hjelpe meg i denne sammenhengen?


Mvh.
Spurv!
Last edited by spurv on Thu May 13, 2010 11:43 am, edited 1 time in total.

User avatar
zenior
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Tue Mar 06, 2007 7:20 pm
Location: Sandefjord - Norway

Re: Exploit i MMS Blog

Post by zenior » Wed May 12, 2010 3:49 pm

Jeg benytter mms blog ganske heftig, har en webside hvor hvem som helst kan sende inn inlegg, har ikke merket noe til dette, vet ikke helt hvordan det fungerer heller...

Konstaterer forøvrig at prosjektet mms blog er lagt ned, blant annet grunnet en feil i scriptet som fører til dette...

spurv
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Jan 14, 2009 2:31 pm

Re: Exploit i MMS Blog

Post by spurv » Wed May 12, 2010 7:59 pm

Jeg har sett at prosjektet er lagt ned. Konkret hvilken feil er det du snakker om?
MMS Bloggen i seg selv fungerer utmerket, men det er det at den har et hull som er problem.

Er det noe jeg kan feks. skrive i htaccess -fila som gjør at feks noe som blir forsøkt skrevet inn i adressefeltet, blir redirekta til forsida eller noe?

Jeg snakker da om en lignende adresse som jeg linka til lengre opp.

Mvh.
Spurv!

User avatar
zenior
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Tue Mar 06, 2007 7:20 pm
Location: Sandefjord - Norway

Re: Exploit i MMS Blog

Post by zenior » Wed May 12, 2010 8:32 pm

Som sagt, jeg aner ikke hva som er problemet, selv har jeg ikke merket noe til dette....
Sikkerhetshullet er beskrevet her:
http://xforce.iss.net/xforce/xfdb/58030

spurv
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Jan 14, 2009 2:31 pm

Re: Exploit i MMS Blog

Post by spurv » Wed May 12, 2010 8:46 pm

OK, Det er det samme som jeg har blitt utsatt for. Håper noen kan fortelle meg om muligheter for å tette hullet. Er ikke dreven på php akkurat..

Takker for svar uansett,
Mvh.
Spurv!

oaasen
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Jun 12, 2007 5:48 am
Contact:

Re: Exploit i MMS Blog

Post by oaasen » Thu May 13, 2010 8:47 am

Denne exploit'en kan trolig enkelt fixes ved å oppdatere koden i mmsblog.php

bytt ut (ca. linje 19) :

Code: Select all

if($controller = JRequest::getVar('controller')) {

med følgende:

Code: Select all

if($controller = JRequest::getWord('controller')) {

Man får da validering på input parameter til controller som kun aksepterer bokstaver , og ikke spesialtegn.

Anbefaler i tillegg alle å lese http://docs.joomla.org/Security_Checklist_1_-_Getting_Started. Ved sikre Joomla innstallasjon i følge denne listen vil man kunne begrense skadevirkningene, og i enkelte situasjoner helt forhindre exploits som dette å kunne angripe .

:)

User avatar
zenior
Joomla! Explorer
Joomla! Explorer
Posts: 325
Joined: Tue Mar 06, 2007 7:20 pm
Location: Sandefjord - Norway

Re: Exploit i MMS Blog

Post by zenior » Thu May 13, 2010 9:00 am

Takker, linjen er for sikkerhets skyld lagt inn... men betyr dette at innsendte MMS ikke kan inneholde spesialtegn??? I så fall blir det vel problemer med punktum, komma og æ, ø, å ??

spurv
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Jan 14, 2009 2:31 pm

Re: Exploit i MMS Blog

Post by spurv » Thu May 13, 2010 10:40 am

Tusen takk oaasen! Det stengte hullet. Kjempegreier, nå er jeg meget fornøyd : )

Kan ikke se noe forskjell på særnorske tegn?

Mvh.
Spurv!


Post Reply

Return to “Sikkerhet”