Page 1 of 1

Feil i admin/menyer vises ikke/aktiver-knappen er forsvunnet

Posted: Thu Oct 29, 2009 6:22 pm
by Snopmaster
Hei!

Jeg lurte på om noen kunne hjelpe meg med en side, som har fått opp en error-melding og alle linkene i menyene er blitt borte.

Dette haster litt, da siden skal ha release til søndag allerede.

Vil tro at dette problemet er "barnemat" for de mest drevne her, men her er problemet i alle fall:

FRONTEND: Alle linker er forsvunnet og følgende tekst kommer frem:

Warning: Invalid argument supplied for foreach() in /customers/aldershot.no/aldershot.no/httpd.www/components/com_eventlist/helpers/route.php on line 87

Warning: Invalid argument supplied for foreach() in /customers/aldershot.no/aldershot.no/httpd.www/components/com_eventlist/helpers/route.php on line 96

ADMINISTRATOR: Virker som "Aktiver"-ikonene er forsvunnet... Skjønner ikke helt hva som kan ha skjedd.

NB! Har satt nettstedet på Feilrapportering: Enkel under "Global Konfigurasjon", som er under "Konfigurasjon".

EDIT: Har nå fått hjelp av min webleverandør (one.com), slik at linken på forsiden er kommet tilbake, men har ennå ikke fått til hvorfor linkene er borte på admin-sidene og aktiver-ikonet fortsatt er borte.

Det jeg gjorde var å endre helper.php i mod_mainmenus og fjernet ett &-tegn i "function buildXML($params)" som tidligere var "function buildXML(&$params)". Men resten er værre... :(

Her er ihvertfall feilmeldingen i admin:


Warning: Parameter 1 to JHTMLGrid::checkedOut() expected to be a reference, value given in /customers/aldershot.no/aldershot.no/httpd.www/libraries/joomla/html/html.php on line 87

Re: Feil i admin/menyer vises ikke/aktiver-knappen er forsvunnet

Posted: Sat Oct 31, 2009 8:47 am
by sone12
Snopmaster wrote: EDIT: webleverandør (one.com)
Kikk under rødt her http://forum.joomla.org/viewtopic.php?f=436&t=156319

Re: Feil i admin/menyer vises ikke/aktiver-knappen er forsvunnet

Posted: Sat Oct 31, 2009 9:59 am
by Snopmaster
Ja, vet at de er dårlig egnet for Joomla, men har ikke hatt problemer med defør nå og har hatt mange joomla-sider.

Det er først nå feilen har kommet.