Søk i Joomla gir feil link til artikler i Wordpress

Generelle spørsmål relatert til Joomla! 1.5, som ikke passer i andre forum ovenfor

Moderators: sone12, Per Yngve Berg

Locked
torvad
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Jul 27, 2010 12:36 pm

Søk i Joomla gir feil link til artikler i Wordpress

Post by torvad » Tue Jul 27, 2010 1:05 pm

Når jeg søker etter artikler fra bloggen min gjennom Joomla sin søkefunksjon og dertter viser dem, vises de annerledes enn på bloggen min. Blant annet mangler modulene på sidene.

URL-en til artiklene er også forskjellig fra slik de blir vist på bloggen.

Eksempel:
URL til artikkel vist på bloggen: http://www.xxxxdomenexxx.com/blogg/archives/215
URL til samme artikkel etter søk: http://www.xxxxdomenexxx.com/component/conten ... ratt-vekst

Dette skjer kun med artikler som er lagret gjennom Wordpress.

Kan noen forklare meg hva som er feil?

User avatar
EivindJ
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Nov 17, 2008 12:16 pm
Location: Drammen
Contact:

Re: Søk i Joomla gir feil link til artikler i Wordpress

Post by EivindJ » Wed Jul 28, 2010 12:31 pm

Første som slår meg er i hvert fall at itemid ikke kommer med når man går via søket. Jeg har hatt noen erfaringer tidligere med at dette kommer av søket heller ikke har itemid (har søket et menytilgangspunkt?). Vet ikke helt hvorfor, men ... (: Itemid kan godt være et nøkkelord her, i hvert fall, for det er den som bestemmer hvilke moduler som skal vises etc.
Trond Eivind Johnsen

[ lei en Joomla!-ekspert på www.exentra.no ]

torvad
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Jul 27, 2010 12:36 pm

Re: Søk i Joomla gir feil link til artikler i Wordpress

Post by torvad » Thu Jul 29, 2010 6:41 am

Jeg tror ikke det går...

Det virker som om artiklene er lagret i to forskjellige databaser, og at det blir brukt to ulike artikkelid-er for å hente dem ut...

Her er url for artikkelen når en søker ettter den i Joomla.
http://www.minside.net/component/conten ... ier/[b]466[/b]-8-gratis-lydbc3b8kerpodcaster-innen-marketing-management

Her er url til samme artikkel, men denne gang når den blir vist på bloggen.
http://www.minside.net/blogg/archives/215

I den første urlen er artikkelid-en 466, i den neste er id-en 215.

Jeg kan ikke da se hvordan det skal være mulig å omforme url-en slik at en kan hente ut artikkel med id 215...

User avatar
EivindJ
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Nov 17, 2008 12:16 pm
Location: Drammen
Contact:

Re: Søk i Joomla gir feil link til artikler i Wordpress

Post by EivindJ » Sat Jul 31, 2010 3:06 pm

Er du sikker på at 215 viser til artikkel-id, og ikke til itemid? Prøv å legge på "&itemid=215" ytterst på url-en når du finner artikkelen via søk ...
Trond Eivind Johnsen

[ lei en Joomla!-ekspert på www.exentra.no ]

torvad
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Jul 27, 2010 12:36 pm

Re: Søk i Joomla gir feil link til artikler i Wordpress

Post by torvad » Mon Aug 02, 2010 7:49 am

Jeg prøvde det du foreslo, å skrive &Itemid=215 på slutten av url-en, men det fungerte ikke. Artikkelen blir vist som før.

User avatar
EivindJ
Joomla! Explorer
Joomla! Explorer
Posts: 411
Joined: Mon Nov 17, 2008 12:16 pm
Location: Drammen
Contact:

Re: Søk i Joomla gir feil link til artikler i Wordpress

Post by EivindJ » Mon Aug 02, 2010 9:53 am

Hm, ok, da var ikke 215 itemid-en. Vel, da må du finne ut hva item-id for bloggen din er, noe som er litt vanskelig når du har på SEF-URL. Du kan enten:

1. Skru av SEF-URL og se hva som står etter "Itemid=" i url-en når du er i bloggen.
2. Legge inn følgende kode øverst i Index.php til templaten og se hva den skriver ut når du er inne i bloggen (ikke så dumt hvis du bruker en SEF-komponent, så slettes ikke alle URL-ene):

Code: Select all

$menus = &JSite::getMenu();
$menu  = $menus->getActive();
echo $menu->id;
Tallet du da får tak i er tallet som burde stå som Itemid i url-en i søkeresultatene, hvis du greier å hacke det inn backpå URL-en. ("Itemid=").

PS: Legg merke til at Itemid er case-sensitive ("itemid=" fungerer ikke alltid).
Trond Eivind Johnsen

[ lei en Joomla!-ekspert på www.exentra.no ]


Locked

Return to “Generelt”