Page 1 of 1

Warning: Parameter 1 to modMainMenuHelper::buildXML() expect

Posted: Wed Jun 20, 2012 7:50 am
by bofen
Jeg får opp denne meldingen under hovedmenyen på siden:
Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in/home/imonian/public_html/libraries/joomla/cache/handler/callback.phpon line 99

Inne på adm-siden får jeg også opp mye rart, se vedlagt fil

I ett forum fant jeg ett innlegg som fortalte at en skulle gjøre en endring i linje 87 for html.php fra:

return call_user_func_array( array( $className, $func ), $args );
til

return call_user_func_array( array( $className, $func ), &$args );

Gjorde dette og da forsvant feilmeldingene som på adm-siden som vist på vedlagt bilde.

Men fortsatt kommer feilmeldingen opp på hjemmesiden.

Forslag til hva som må gjøres mottas med stor TAKK?

Bruker versjon 1.5.14 og dette skjedde bare plutselig "helt av seg selv"

Re: Warning: Parameter 1 to modMainMenuHelper::buildXML() ex

Posted: Wed Jun 20, 2012 9:24 am
by rued
OPPDATER TIL SISTE VERSJON - 1.5.26 eller 2.5.6!!!

Du har brukt Joomla lenge nok nå til å vite at dette er første bud, bofen.
Ellers bør du jo nå også sjekke om det finnes ondsinnet kode på nettstedet, om du er hacket etter å ha sløvet så lenge med oppdateringer. ;)

Re: Warning: Parameter 1 to modMainMenuHelper::buildXML() ex

Posted: Wed Jun 20, 2012 8:13 pm
by bofen
Du er vel inne på noe der ja! ;D
Like godt å renske det som er der for så å innstallere nyeste versjon helt på nytt eller..?

Hvordan får jeg sjekket om det finnes ondsinnet kode på nettstedet?

Har gjort dette nå:
Oppgradert til 1.5.25, fant ikke noe for 1.5.26
Skal jeg oppgradere til 1.5.26 nå fra 1.5.25?

Hva med å gå til 1.7 eller 2.5? Kan dette gjøres direkte, og er det å anbefale?

Re: Warning: Parameter 1 to modMainMenuHelper::buildXML() ex

Posted: Wed Jun 20, 2012 10:44 pm
by rued
Ondsinnet kode finner du ved å sjekke filer. Noen webhoteller har støtte for virussøk, som også fanger opp mye annen "grums". Men man kan også laste ned en kopi lokalt og skanne der. Kjøre filsammenligning. osv. osv. Admin Tools m.fl. har også mulighet for å skanne filene.

http://extensions.joomla.org/extensions ... protection

1.5.26: https://www.joomlainorge.no/nyheter/joo ... -er-utgitt

1.7 er utdatert. Migrering til 2.5 finnes det mye informasjon om allerede, så det behøver vi ikke repetere her tror jeg. Finnes lenke til info om oppdatering/migrering i alle annonseringene også.

Søk og du vil finne det meste av informasjon som du måtte behøve for å drifte siden din sikkert fremover. Begynn f.eks. med security på docs.joomla.org, og søk videre på Google.

Re: Warning: Parameter 1 to modMainMenuHelper::buildXML() ex

Posted: Mon Aug 13, 2012 10:29 pm
by bofen
Fikk fikset den siden jeg omtalte på denne tråden ved å oppgradere tiil 1.5.26

En annen side er nå angrepet (har bedt om noen som kan hjelpe i en annen tråd).

Du nevner over at Admin Tools kan brukes til å skanne filene. Er det mulig å innstallere dette programmet nå etter at siden er hacket?
Har også lastet ned backup men McAfee finner ikke noe feil med backupen. Må den evt unzippes for å få kjørt en scanning.

Google sier at det er lagt inn en kode som viderekobler brukerne til en annen side:
"Da Google testet denne siden, ble det ikke returnert noe innhold fra tjeneren din. Nettleseren ble i stedet omdirigert til en nettside med skadelig programvare. Vi anbefaler deg å sjekke tjenerkonfigurasjonsfilene dine (som Apaches .htaccess) for å se om det har blitt gjort noen uautoriserte endringer, og at du sjekker retningslinjene våre for rensking av nettstedet ditt og forespørsler om vurderinger."

Står litt fast her nå og føler at jeg trenger noe hjelp da jeg ikke helt vet hvor jeg skal starte.....

Jeg trodde jeg også hadde oppgradert denne siden til 1.5.26 men i admin står det 1.5.18....