Cannot send session cookie - headers already sent

Diskutera frågor rörande installation, backup, migrering och säkerhet avseende Joomla! 1.5.

Moderators: Zello, chrille

Forum rules
Forumregler
Locked
User avatar
spehe
Joomla! Intern
Joomla! Intern
Posts: 58
Joined: Fri Aug 22, 2008 7:53 am
Location: Kungsbacka, Sweden

Cannot send session cookie - headers already sent

Post by spehe » Thu Oct 28, 2010 1:48 pm

Jag har kopierat en hemsida från ett ställe till ett annat för att ändra i den utan att störa. När jag går till den 'nya' hemsidan så dyker följande meddelande upp. Under dessa meddelanden syns hemsidan. Vad har hänt?

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/configuration.php:1) in /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/libraries/joomla/session/session.php on line 423

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/configuration.php:1) in /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/libraries/joomla/session/session.php on line 423

Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/configuration.php:1) in /mounted-storage/home110c/sub007/sc60390-WSMS/www/up/libraries/joomla/session/session.php on line 426

Jag har läst på andra forum att det förmodligen finns en blankrad någonstans i någon fil, men jag har bara ändrat i configuration.php, allt annat är exakt samma.
Det är först när man studerar myror under ett förstoringsglas en solig dag, som man inser hur ofta de råkar ut för spontan självantändning.

 
User avatar
Zello
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3869
Joined: Wed Jan 10, 2007 11:23 am
Location: Västerås - Sweden

Re: Cannot send session cookie - headers already sent

Post by Zello » Thu Oct 28, 2010 10:00 pm

Är du säker på att det inte finns en blankrad eller en BOM (Bite Order Mark) först i config-filen.
Vad använde du för editor när du ändrade i den filen?

Lite info om BOM - http://en.wikipedia.org/wiki/Byte_order_mark
Olle Zettergren
Freelance Senior Joomla developer
Moderator Swedish forum

User avatar
spehe
Joomla! Intern
Joomla! Intern
Posts: 58
Joined: Fri Aug 22, 2008 7:53 am
Location: Kungsbacka, Sweden

Re: Cannot send session cookie - headers already sent

Post by spehe » Fri Oct 29, 2010 6:31 am

Jag var säker, men hade fel.... :o) Använder Notepad++ och sparade configuration.php som UTF-8 utan BOM, och då funkade det. Fattar inte varför det fungerar hos en ISP men inte hos en annan, men problemet är löst iallafall. Tack för visat intresse.
Det är först när man studerar myror under ett förstoringsglas en solig dag, som man inser hur ofta de råkar ut för spontan självantändning.

 

Locked

Return to “Installation, backup och säkerhet”