Bad Google index for old urls

harisg7
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Wed Jul 22, 2009 10:11 pm

Bad Google index for old urls

Postby harisg7 » Tue Oct 01, 2013 5:31 pm

Many of my old urls are indexed in Google like this:
http://www.site.com/component/content/34?task=view

But the correct is this:
http://www.site.com/section/category/34-article-title

These articles was migrated 2 years before from joomla 1.0 to joomla 1.5. Maybe I forgot to do something important?

waarnemer
Joomla! Ace
Joomla! Ace
Posts: 1800
Joined: Sun May 04, 2008 12:37 pm

Re: Bad Google index for old urls

Postby waarnemer » Tue Oct 01, 2013 7:53 pm

Make à line in robots.txt saying: disallow /component/content/
Do a request in Google webmastertools to delete the wrong urls from their cache

It takes a while (2weeks can happen) but then it is gone.

harisg7
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Wed Jul 22, 2009 10:11 pm

Re: Bad Google index for old urls

Postby harisg7 » Tue Oct 01, 2013 8:02 pm

But then these articles will disappear from Google completely.. Right?

And I wonder why the urls changed? Is it normal? Ηas happened to someone else something like that?

waarnemer
Joomla! Ace
Joomla! Ace
Posts: 1800
Joined: Sun May 04, 2008 12:37 pm

Re: Bad Google index for old urls

Postby waarnemer » Tue Oct 01, 2013 8:28 pm

There probably is a rss or atom feed on that page running. Read this viewtopic.php?f=618&t=681384 .

I had this similar problem.. It happens because of your feeds..

The robot.txt and webmaster tools thingies should suffice.


Return to “Joomla! 1.5.x”

Who is online

Users browsing this forum: No registered users and 1 guest