Problem med lokal installation, EasyPHP + Joomla

Her kan du søge hjælp til installation og opdatering, og stille spørgsmål om webhosts.

Moderators: b-ronnow, General Support Moderators

Locked
User avatar
Preben Nielsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Oct 15, 2010 12:42 pm
Location: Nordsjælland
Contact:

Problem med lokal installation, EasyPHP + Joomla

Post by Preben Nielsen » Fri Oct 15, 2010 1:30 pm

Jeg er interesseret i at prøve Joomla på min lokale computer, men jeg har ikke kunnet få det til at virke med EasyPHP. Det strander i allersidste fase, hvor jeg får beskeden:
Error: the XML response that was returned from the server cannot be processed

Jeg kører med en XP maskine, og EasyPHP er installeret i roden på C-drevet.
EasyPHP er version 5.3.3, Joomla er version 1.5.21.

Jeg har set i tråden http://forum.joomla.org/viewtopic.php?p=2143551, hvor samme problem er løst ved i php.ini (i EasyPHP's mappe Apache, går jeg ud fra) at sætte Timezone, hvilket allererede er gjort i min fil:
date.timezone = Europe/Paris
Man opfordres desuden til i samme fil at sætte:
error_reporting = E_ALL & ~E_NOTICE;
I min fil står
; error_reporting
; Default Value: E_ALL & ~E_NOTICE
; Development Value: E_ALL | E_STRICT
; Production Value: E_ALL & ~E_DEPRECATED
hvilket vel må være ok?

Er der noget jeg har overset her? Eller er der nogle andre ideer til hvordan jeg kan rette fejlen?
Alternativt: Kan nogen anbefale en anden løsning (dvs. uden EasyPHP) til at teste Joomla lokalt?
Last edited by Preben Nielsen on Sat Oct 16, 2010 8:44 pm, edited 1 time in total.

User avatar
Torben Grover
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 212
Joined: Sat Apr 01, 2006 9:20 am

Re: Problem med lokal installation, EasyPHP + Joomla

Post by Torben Grover » Fri Oct 15, 2010 2:13 pm

Hej Preben.
Velkommen til.
Jeg bruger xampp http://www.apachefriends.org/en/xampp.html
Det virker fint og er nemt at installere. Prøv det :laugh:

Torben

User avatar
Preben Nielsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Oct 15, 2010 12:42 pm
Location: Nordsjælland
Contact:

Re: Problem med lokal installation, EasyPHP + Joomla

Post by Preben Nielsen » Fri Oct 15, 2010 5:07 pm

Hej Torben

Tak for svar og velkomst.
XAMPP er nu installeret. Der findes sikkert en guide til hvordan jeg får Joomla installeret, så den virker sammen med XAMPP. Har du et link?

/Preben

User avatar
Torben Grover
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 212
Joined: Sat Apr 01, 2006 9:20 am

Re: Problem med lokal installation, EasyPHP + Joomla

Post by Torben Grover » Fri Oct 15, 2010 5:56 pm

Hvis du vil have en dansk udgave af joomla kan du hente denne zip fil http://joomlacode.org/gf/project/danish ... se_id=6561
Den ligger under fanebladet "files"
Udpak den og kopier alle mapper og filer til mappen "htdocs" som ligger i c:/xampp

Åben din browser og skriv http://localhost/phpmyadmin/
Opret en database, når du har gjort dette, skriver du bare http://localhost/ så skulle installation af Joomla gerne starte.

Du kan også lave en mappe i "htdocs" f.eks. joomla så bliver adressen bare http://localhost/joomla
På den måde kan du have flere installationer kørende samtidig.

Håber det giver mening :)

User avatar
Preben Nielsen
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Oct 15, 2010 12:42 pm
Location: Nordsjælland
Contact:

Re: Problem med lokal installation, EasyPHP + Joomla

Post by Preben Nielsen » Sat Oct 16, 2010 8:11 am

Tak for hjælpen. Det lykkedes altsammen.

/Preben

User avatar
Torben Grover
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 212
Joined: Sat Apr 01, 2006 9:20 am

Re: Problem med lokal installation, EasyPHP + Joomla

Post by Torben Grover » Sat Oct 16, 2010 10:14 am

Dejligt at høre, så god fornøjelse med Joomla.

Du kan vise at spørgsmålet er besvaret, du trykker edit ved første indlæg i tråden og så markere du det grønne solved ikon.

cthrane
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 24, 2007 5:21 pm
Contact:

Re: Problem med lokal installation, EasyPHP + Joomla

Post by cthrane » Wed Feb 02, 2011 12:49 pm

jeg kan ikke få det til at virke
jeg benytter windows 7
jeg bruger Xampp
der er både en production- og en development php.ini fil, hvilken benyttes?

Jeg har også forsøgt mig med IIS og joomla
fra dette site http://www.microsoft.com/web/joomla/
det gik i stå ved oprettelsen af databasen

nedenstående fejl opstår:
Strict Standards: Non-static method JLoader::import() should not be called statically in C:\xampp\htdocs\jcrew\libraries\joomla\import.php on line 29

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\jcrew\libraries\loader.php on line 71

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\xampp\htdocs\jcrew\libraries\joomla\import.php on line 32

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\jcrew\libraries\loader.php on line 71

Strict Standards: Non-static method JLoader::load() should not be called statically in C:\xampp\htdocs\jcrew\libraries\loader.php on line 161

Strict Standards: Non-static method JLoader::register() should not be called statically in C:\xampp\htdocs\jcrew\libraries\loader.php on line 138

Strict Standards: Non-static method JRequest::clean() should not be called statically in C:\xampp\htdocs\jcrew\libraries\joomla\import.php on line 33


Locked

Return to “Installation, backup, opdatering og flytning - Godt igang”