Page 1 of 1

Fejl efter installation

Posted: Thu Feb 24, 2011 9:37 am
by Hanne
Jeg har installeret Joomla på et nyt domæne under Web10, og får nu følgende fejl: Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in /usr/home/web/web479756/hadstenjagtforening.dk/libraries/joomla/cache/handler/callback.php on line 99

Jeg kan se i en anden tråd, at det er noget med et par stier i configuration fil, der skal ændres, men jeg kan ikke finde ud af hvilken sti & hvordan ???

Er der en, som kan give en forklaring for "dummies"? Da jeg er helt ny i arbejdet med sådan noget.

På forhånd tak for hjælpen :)

Re: Fejl efter installation

Posted: Thu Feb 24, 2011 7:44 pm
by ot2sen
Hej Hanne - og velkommen til :)

Har du installeret nyeste joomla 1.5.22?

Fejlen kunne indikere at du har installeret en joomla version < 1.5.15

Re: Fejl efter installation

Posted: Fri Feb 25, 2011 7:17 am
by Hanne
Tak for velkomsten.

Iflg. Web10 er det version 1.5.9

Re: Fejl efter installation

Posted: Fri Feb 25, 2011 7:32 am
by ot2sen
Så er det meget sandsynligt at webhotellet kører PHP 5.3.x og at fejlen opstår fordi joomla 1.5.9 ikke er kompatibel med PHP 5.3.x

Det er vel ikke en autoinstaller hos Web10 der installerer den version?

Hvis det er en joomla du selv har installeret, så skal du opdatere til 1.5.22 for at få problemet løst.
Opdateringspakker kan du finde her:
http://joomlacode.org/gf/project/joomla ... ge_id=5498

Re: Fejl efter installation

Posted: Fri Feb 25, 2011 9:51 am
by Hanne
Jeg har netop haft kontakt med webhotellet, og det er ganske rigtigt serveren der er problemet.
Jeg får flyttet mit domæne til en anden server, hvilket forhåbentligt løser mit problem.

Tak for svarerne, jeg er sikker på, i nok skal komme til at høre fra mig igen :-)

Re: Fejl efter installation

Posted: Fri Feb 25, 2011 10:11 am
by ot2sen
Det vigtige er at du kommer til at anvende joomla 1.5.22 istedet for den nævnte 1.5.9
Der er mange sikkerhedsrettelser mellem de to versioner, og for at have en sikker hjemmeside skal du altid anvende nyeste version.

Hvis webhotellet "bare" flytter dig til en server med PHP 5.2.x, så løser det det selvfølgelig det visuelle problem, men din hjemme side vil stadig være med kendte sikkerhedsbrister så længe den er 1.5.9