Kan ikke forbinde til DB efter flytning

Her kan du søge hjælp til installation og opdatering, og stille spørgsmål om webhosts.

Moderators: b-ronnow, ot2sen

User avatar
Jakobseen
Joomla! Explorer
Joomla! Explorer
Posts: 386
Joined: Fri May 04, 2007 5:41 am
Location: Skive
Contact:

Kan ikke forbinde til DB efter flytning

Postby Jakobseen » Fri Dec 02, 2011 9:22 pm

Hejsa,

Jeg har op til flere gange flyttet et Joomlasite fra en server til en anden, eller fra en submappe og op i roden eks. Denne gang kan jeg ikke få det til at virke!

Det drejer sig om www.chskive.dk som oprindeligt blev lavet som et subdomæne på en anden side (samme servere hos Gigahost!). Efterfølgende blev chskive.dk flyttet til sit eget domæne, no problem!

Herefter bliver selv roden, som siden blev flyttet fra (www.chskive.towasushi.dk) altså, towasushi.dk blev helt flyttet fra serverne, kan det have lavet noget rod? Jeg spørger fordi jeg kan se at mine log paths lå med towasushi.dk som adresse.

Jeg har ændret databasenavnet, kode osv. men jeg kan simpelthen ikke knække, hvor den er gal. Jeg har sågar eksporteret databasens indhold til en ny database, og derefter henvist til den i min configuration.php.

På forhånd mange tak for hjælpen!
http://www.dannijakobsen.dk

User avatar
ot2sen
Joomla! Master
Joomla! Master
Posts: 10379
Joined: Thu Aug 18, 2005 9:58 am
Location: Hillerød - Denmark
Contact:

Re: Kan ikke forbinde til DB efter flytning

Postby ot2sen » Fri Dec 02, 2011 9:59 pm

Hej Jakobseen,

Du må kigge i din configuration.php igen, og så dobbelttjekke at alle værdier nu er nye, både for database og stier.

/* Database Settings */
var $dbtype = 'mysql';
var $host = 'hostnav_feks_localhost';
var $user = 'dindatabasebruger';
var $password = 'brugerensadgangskode';
var $db = 'databasensnavn';
var $dbprefix = 'jos_';
og
var $log_path = 'din/sti/her';
var $tmp_path = 'din/sti/her';
Ole Bang Ottosen
Dansk frivillig Joomla! support websted - joomla.dk
OpenTranslators Core Team opentranslators.org

User avatar
Jakobseen
Joomla! Explorer
Joomla! Explorer
Posts: 386
Joined: Fri May 04, 2007 5:41 am
Location: Skive
Contact:

Re: Kan ikke forbinde til DB efter flytning

Postby Jakobseen » Thu Jan 12, 2012 4:11 pm

Hej ot2sen,

tror du det kan være "secret" som er forkert? Jeg har tjekket så mange gange efterhånden, og jeg kan simpelthen ikke se hvad det ellers skulle være!
http://www.dannijakobsen.dk

User avatar
ot2sen
Joomla! Master
Joomla! Master
Posts: 10379
Joined: Thu Aug 18, 2005 9:58 am
Location: Hillerød - Denmark
Contact:

Re: Kan ikke forbinde til DB efter flytning

Postby ot2sen » Thu Jan 12, 2012 4:38 pm

Jeg vil stadig tro at det er en detalje der er forkert i en af de 4 databaserelaterede felter.

En anden mulighed er også at tjekke om den databasebruger du oprettede faktisk blev forbundet til databasen, med korrekte rettigheder
Ole Bang Ottosen
Dansk frivillig Joomla! support websted - joomla.dk
OpenTranslators Core Team opentranslators.org

User avatar
Jakobseen
Joomla! Explorer
Joomla! Explorer
Posts: 386
Joined: Fri May 04, 2007 5:41 am
Location: Skive
Contact:

Re: Kan ikke forbinde til DB efter flytning

Postby Jakobseen » Fri Jan 13, 2012 9:25 am

Hvordan tjekeks om den blev forbundet rigtigt? Jeg har tjekket indholdet på phpmyadmin og kan se de tabeller den indeholder, er de rigtige til hotellet - altså, det skulle gerne være den rigtig database jeg forsøger at forbinde til :-)
http://www.dannijakobsen.dk


Return to “Installation, backup, opdatering og flytning - Godt igang”

Who is online

Users browsing this forum: No registered users and 1 guest